<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" >
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />
<link rel="shortcut icon" href="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/SmallBallLogo.png" /><link rel="pingback" href="http://www.basketballinsiders.com/xmlrpc.php" />
<meta property="og:type" content="article" />
					<meta property="og:image" content="http://www.basketballinsiders.com/wp-content/uploads/2019/10/Adam_Silver_Jazz_All-Star2023_2019_AP.jpg" />
		<meta name="twitter:image" content="http://www.basketballinsiders.com/wp-content/uploads/2019/10/Adam_Silver_Jazz_All-Star2023_2019_AP.jpg" />
	<meta property="og:url" content="http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/" />
<meta property="og:title" content="What Else Should The NBA Change? Part 1" />
<meta property="og:description" content="David Yapkowitz considers what long-term changes the NBA should consider making as the league moves forward." />
<meta name="twitter:card" content="summary">
<meta name="twitter:url" content="http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/">
<meta name="twitter:title" content="What Else Should The NBA Change? Part 1">
<meta name="twitter:description" content="David Yapkowitz considers what long-term changes the NBA should consider making as the league moves forward.">
<title>What Else Should The NBA Change? Part 1 | Basketball Insiders | NBA Rumors And Basketball News</title>

<!-- All In One SEO Pack 3.4.2[1485,1592] -->
<meta name="description"  content="David Yapkowitz considers what long-term changes the NBA should consider making as the league moves forward." />

<meta name="keywords"  content="main page,nba" />

<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"http://www.basketballinsiders.com/#organization","url":"http://www.basketballinsiders.com/","name":"Basketball Insiders | NBA Rumors And Basketball News","sameAs":[]},{"@type":"WebSite","@id":"http://www.basketballinsiders.com/#website","url":"http://www.basketballinsiders.com/","name":"Basketball Insiders | NBA Rumors And Basketball News","publisher":{"@id":"http://www.basketballinsiders.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"http://www.basketballinsiders.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/#webpage","url":"http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/","inLanguage":"en-US","name":"What Else Should The NBA Change? Part 1","isPartOf":{"@id":"http://www.basketballinsiders.com/#website"},"breadcrumb":{"@id":"http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/#breadcrumblist"},"image":{"@type":"ImageObject","@id":"http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/#primaryimage","url":"http://www.basketballinsiders.com/wp-content/uploads/2019/10/Adam_Silver_Jazz_All-Star2023_2019_AP.jpg","width":1000,"height":600},"primaryImageOfPage":{"@id":"http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/#primaryimage"},"datePublished":"2020-05-09T17:29:40-04:00","dateModified":"2020-05-09T17:29:53-04:00","description":"David Yapkowitz considers what long-term changes the NBA should consider making as the league moves forward."},{"@type":"Article","@id":"http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/#article","isPartOf":{"@id":"http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/#webpage"},"author":{"@id":"http://www.basketballinsiders.com/author/dyapkowitz/#author"},"headline":"What Else Should The NBA Change? Part 1","datePublished":"2020-05-09T17:29:40-04:00","dateModified":"2020-05-09T17:29:53-04:00","commentCount":0,"mainEntityOfPage":{"@id":"http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/#webpage"},"publisher":{"@id":"http://www.basketballinsiders.com/#organization"},"articleSection":"NBA, NBA DAILY, Main Page, NBA","image":{"@type":"ImageObject","@id":"http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/#primaryimage","url":"http://www.basketballinsiders.com/wp-content/uploads/2019/10/Adam_Silver_Jazz_All-Star2023_2019_AP.jpg","width":1000,"height":600}},{"@type":"Person","@id":"http://www.basketballinsiders.com/author/dyapkowitz/#author","name":"David Yapkowitz","sameAs":[],"image":{"@type":"ImageObject","@id":"http://www.basketballinsiders.com/#personlogo","url":"http://www.basketballinsiders.com/wp-content/uploads/2014/07/BI_Ball_Small.jpg","width":96,"height":96,"caption":"David Yapkowitz"}},{"@type":"BreadcrumbList","@id":"http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/#breadcrumblist","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"http://www.basketballinsiders.com/","url":"http://www.basketballinsiders.com/","name":"Basketball Insiders | NBA Rumors And Basketball News"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/","url":"http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/","name":"What Else Should The NBA Change? Part 1"}}]}]}</script>
<link rel="canonical" href="http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/" />
<!-- All In One SEO Pack -->
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Basketball Insiders | NBA Rumors And Basketball News &raquo; Feed" href="http://www.basketballinsiders.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Basketball Insiders | NBA Rumors And Basketball News &raquo; Comments Feed" href="http://www.basketballinsiders.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Basketball Insiders | NBA Rumors And Basketball News &raquo; What Else Should The NBA Change? Part 1 Comments Feed" href="http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/feed/" />
		<script type="text/javascript">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</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-includes/css/dist/block-library/style.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='bcct_style-css'  href='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/better-click-to-tweet/assets/css/styles.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='theiaPostSlider-css'  href='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/theia-post-slider/css/base.css?ver=1.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='theiaPostSlider-font-css'  href='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/theia-post-slider/fonts/style.css?ver=1.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='aioseop-toolbar-menu-css'  href='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/all-in-one-seo-pack/css/admin-toolbar-menu.css?ver=3.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-custom-style-css'  href='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/themes/zox-news/style.css?ver=5.4.1' type='text/css' media='all' />
<style id='mvp-custom-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='mvp-reset-css'  href='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/themes/zox-news/css/reset.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/themes/zox-news/font-awesome/css/font-awesome.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-fonts-css'  href='//fonts.googleapis.com/css?family=Advent+Pro%3A700%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese%7COpen+Sans%3A700%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese%7CAnton%3A400%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese%7COswald%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese%7COswald%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese%7CRoboto%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese%7CRoboto%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese%7CPT+Serif%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese%7COswald%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-media-queries-css'  href='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/themes/zox-news/css/media-queries.css?ver=5.4.1' type='text/css' media='all' />
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-includes/js/jquery/jquery-migrate.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/sticky-ad-bar/js/sab_bar_script.js?ver=5.4.1'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/sticky-ad-bar/js/jquery.cookie.js?ver=5.4.1'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/theia-post-slider/js/balupton-history.js/jquery.history.js?ver=1.7.1'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/theia-post-slider/js/async.min.js?ver=25.11.2012'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/theia-post-slider/js/tps.js?ver=1.6.4'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/theia-post-slider/js/tps-transition-slide.js?ver=1.6.4'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/wp-infinite-scrolling/js/jquery.sifs.js?ver=5.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpifs_options = {"container":".blog-layout1","post":".infinite-post","pagination":".navigation","next":".next-post-link a","loading":"<div style=\"text-align: center; font-weight: bold; font-size: 22px; color: #b5b5b5;\">Loading More Posts...<\/div>"};
/* ]]> */
</script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/wp-infinite-scrolling/js/wpifs.js?ver=5.4.1'></script>
<!-- This site uses the Better Analytics plugin.  https://marketplace.digitalpoint.com/better-analytics.3354/item -->
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/better-analytics/js/loader.php?ver=1.2.5.js' ></script><link rel='https://api.w.org/' href='http://www.basketballinsiders.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.basketballinsiders.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.basketballinsiders.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Adam Silver: Season Could Resume at One or Two &#8216;bubble sites&#8217;' href='http://www.basketballinsiders.com/adam-silver-season-could-resume-at-one-or-two-bubble-sites/' />
<link rel='shortlink' href='http://www.basketballinsiders.com/?p=65217' />
<link rel="alternate" type="application/json+oembed" href="http://www.basketballinsiders.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.basketballinsiders.com%2Fwhat-else-should-the-nba-change-part-1%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.basketballinsiders.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.basketballinsiders.com%2Fwhat-else-should-the-nba-change-part-1%2F&#038;format=xml" />
<meta name='pubexchange:image' content='http://www.basketballinsiders.com/wp-content/uploads/2019/10/Adam_Silver_Jazz_All-Star2023_2019_AP-300x180.jpg'>
<meta name='pubexchange:title' content='What Else Should The NBA Change? Part 1'>
        <style>
            .theiaPostSlider_nav.fontTheme ._title {
                line-height: 48px;
            }

            .theiaPostSlider_nav.fontTheme ._prev,
            .theiaPostSlider_nav.fontTheme ._next {
                font-size: 48px;
                color: #dd0000;
                line-height: 0;
            }

            .theiaPostSlider_nav.fontTheme ._prev:hover,
            .theiaPostSlider_nav.fontTheme ._next:hover {
                color: #ff2626;
            }

            .theiaPostSlider_nav.fontTheme ._disabled {
                color: #6d6d6d !important;
            }
        </style>
        
<!-- Twitter Cards Meta - V 2.5.4 -->
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@bballinsiders" />
<meta name="twitter:creator" content="@bballinsiders" />
<meta name="twitter:url" content="http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/" />
<meta name="twitter:title" content="What Else Should The NBA Change? Part 1" />
<meta name="twitter:description" content="David Yapkowitz considers what long-term changes the NBA should consider making as the league moves forward." />
<meta name="twitter:image" content="http://www.basketballinsiders.com/wp-content/uploads/2019/10/Adam_Silver_Jazz_All-Star2023_2019_AP.jpg" />
<!-- Twitter Cards Meta By WPDeveloper.net -->

<style id="tt-easy-google-font-styles" type="text/css">p { }
h1 { }
h2 { }
h3 { }
h4 { }
h5 { }
h6 { }
</style>
<!-- DFP Tags Start -->
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/1246049/BasketballInsiders_1x1', [1, 1], 'div-gpt-ad-1509057907764-1').addService(googletag.pubads());
    googletag.defineSlot('/1246049/BasketballInsiders_1x1_Passback', [1, 1], 'div-gpt-ad-1509057907764-2').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().enableVideoAds();
    googletag.companionAds().setRefreshUnfilledSlots(true);
    googletag.enableServices();
  });
</script>
<!-- DFP Tags End -->
<!-- Please add to the top of the head element —>

<script src="//tags-cdn.deployads.com/a/basketballinsiders.com.js" async ></script>

<!-- Start AIR.TV Viral -->
<script async src='https://embed.air.tv/v1/twoview_bootstrap.js?organization=b6V9NyTdRQGeWbnMmfnvwg'></script>
<!-- End AIR.TV Viral -->

<!-- Start Sharethrough Tag -->
<script type="text/javascript" src="//native.sharethrough.com/assets/sfp.js"></script>
<!-- End Sharethrough Tag -->
</head>
<body class="post-template-default single single-post postid-65217 single-format-standard">
	<div id="mvp-fly-wrap">
	<div id="mvp-fly-menu-top" class="left relative">
		<div class="mvp-fly-top-out left relative">
			<div class="mvp-fly-top-in">
				<div id="mvp-fly-logo" class="left relative">
											<a href="http://www.basketballinsiders.com/"><img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/LargeLogo_w30.png" alt="Basketball Insiders | NBA Rumors And Basketball News" data-rjs="2" /></a>
									</div><!--mvp-fly-logo-->
			</div><!--mvp-fly-top-in-->
			<div class="mvp-fly-but-wrap mvp-fly-but-menu mvp-fly-but-click">
				<span></span>
				<span></span>
				<span></span>
				<span></span>
			</div><!--mvp-fly-but-wrap-->
		</div><!--mvp-fly-top-out-->
	</div><!--mvp-fly-menu-top-->
	<div id="mvp-fly-menu-wrap">
		<nav class="mvp-fly-nav-menu left relative">
			<div class="menu-top-nav-container"><ul id="menu-top-nav" class="menu"><li id="menu-item-148" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-148"><a href="http://www.basketballinsiders.com/category/nba-news/">NBA News</a>
<ul class="sub-menu">
	<li id="menu-item-486" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-486"><a href="http://www.basketballinsiders.com/key-nba-dates/">Key NBA Dates &#8211; 2019-20</a></li>
	<li id="menu-item-10601" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10601"><a href="http://www.basketballinsiders.com/category/insiders-video/">Insiders Video</a></li>
	<li id="menu-item-17063" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17063"><a href="http://www.basketballinsiders.com/authors/">Our Team</a></li>
	<li id="menu-item-15328" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15328"><a href="http://www.basketballinsiders.com/contact-us/">Contact Us</a></li>
</ul>
</li>
<li id="menu-item-182" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-182"><a href="http://www.basketballinsiders.com/nba-team-salaries-at-a-glance/">NBA Salary Cap &#8211; By Team</a></li>
<li id="menu-item-61325" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-61325"><a href="http://www.basketballinsiders.com/2019-20-nba-salary-cap-109-140-million/">2019-20 NBA Salary Cap – $109.140M</a></li>
<li id="menu-item-55120" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-55120"><a href="http://www.basketballinsiders.com/nba-salaries/nba-free-agents-2019-2020-2/">NBA Free Agents – 2019-2020</a></li>
<li id="menu-item-186" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-186"><a href="http://www.basketballinsiders.com/nba-news-sorted-by-team/">NBA News By Team</a></li>
<li id="menu-item-501" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-501"><a href="http://www.basketballinsiders.com/nba-trade-history/">NBA Trade History</a></li>
<li id="menu-item-2819" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2819"><a href="http://www.basketballinsiders.com/nba-salaries/nba-rookie-salary-scale-by-draft-year/">NBA Rookie Salary Scale</a></li>
<li id="menu-item-51042" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51042"><a href="http://www.basketballinsiders.com/top-100-nba-draft-prospects/">Top 100 NBA Draft Prospects</a></li>
<li id="menu-item-6571" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6571"><a href="http://www.basketballinsiders.com/tag/mock-drafts/">Mock Drafts</a></li>
<li id="menu-item-446" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-446"><a href="http://www.basketballinsiders.com/history-of-the-nba-draft-by-pick/">History of the NBA Draft – By Pick</a></li>
<li id="menu-item-467" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-467"><a href="http://www.basketballinsiders.com/history-of-the-nba-draft-by-team/">History of the NBA Draft – By Team</a></li>
</ul></div>		</nav>
	</div><!--mvp-fly-menu-wrap-->
	<div id="mvp-fly-soc-wrap">
		<span class="mvp-fly-soc-head">Connect with us</span>
		<ul class="mvp-fly-soc-list left relative">
							<li><a href="https://www.facebook.com/BasketballInsiders" target="_blank" class="fa fa-facebook fa-2"></a></li>
										<li><a href="https://twitter.com/BBallInsiders" target="_blank" class="fa fa-twitter fa-2"></a></li>
										<li><a href="http://www.pinterest.com/bballinsiders/" target="_blank" class="fa fa-pinterest-p fa-2"></a></li>
										<li><a href="http://instagram.com/basketballinsiders" target="_blank" class="fa fa-instagram fa-2"></a></li>
										<li><a href="https://plus.google.com/u/0/+Basketballinsiderscom/" target="_blank" class="fa fa-google-plus fa-2"></a></li>
										<li><a href="https://www.youtube.com/user/BasketballInsiders" target="_blank" class="fa fa-youtube-play fa-2"></a></li>
											</ul>
	</div><!--mvp-fly-soc-wrap-->
</div><!--mvp-fly-wrap-->	<div id="mvp-site" class="left relative">
		<div id="mvp-search-wrap">
			<div id="mvp-search-box">
				<form method="get" id="searchform" action="http://www.basketballinsiders.com/">
	<input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' />
	<input type="hidden" id="searchsubmit" value="Search" />
</form>			</div><!--mvp-search-box-->
			<div class="mvp-search-but-wrap mvp-search-click">
				<span></span>
				<span></span>
			</div><!--mvp-search-but-wrap-->
		</div><!--mvp-search-wrap-->
				<div id="mvp-site-wall" class="left relative">
											<div id="mvp-leader-wrap">
					<table border="0" width="100%" bgcolor="#000000" cellspacing="0" cellpadding="0">
	<tr>
		<td>

<p align="center">
<!-- BI_Homepage_MidLeader (responsive) -->
<div class="ad-tag" data-ad-name="BI_Homepage_MidLeader" data-ad-size="auto" ></div>
<script src="//tags-cdn.deployads.com/a/basketballinsiders.com.js" async ></script>
<script>(deployads = window.deployads || []).push({});</script>
</p>		
</td>
	</tr>
</table>				</div><!--mvp-leader-wrap-->
										<div id="mvp-site-main" class="left relative">
			<header id="mvp-main-head-wrap" class="left relative">
									<nav id="mvp-main-nav-wrap" class="left relative">
						<div id="mvp-main-nav-top" class="left relative">
							<div class="mvp-main-box">
								<div id="mvp-nav-top-wrap" class="left relative">
									<div class="mvp-nav-top-right-out left relative">
										<div class="mvp-nav-top-right-in">
											<div class="mvp-nav-top-cont left relative">
												<div class="mvp-nav-top-left-out relative">
													<div class="mvp-nav-top-left">
														<div class="mvp-nav-soc-wrap">
																															<a href="https://www.facebook.com/BasketballInsiders" target="_blank"><span class="mvp-nav-soc-but fa fa-facebook fa-2"></span></a>
																																														<a href="https://twitter.com/BBallInsiders" target="_blank"><span class="mvp-nav-soc-but fa fa-twitter fa-2"></span></a>
																																														<a href="http://instagram.com/basketballinsiders" target="_blank"><span class="mvp-nav-soc-but fa fa-instagram fa-2"></span></a>
																																														<a href="https://www.youtube.com/user/BasketballInsiders" target="_blank"><span class="mvp-nav-soc-but fa fa-youtube-play fa-2"></span></a>
																													</div><!--mvp-nav-soc-wrap-->
														<div class="mvp-fly-but-wrap mvp-fly-but-click left relative">
															<span></span>
															<span></span>
															<span></span>
															<span></span>
														</div><!--mvp-fly-but-wrap-->
													</div><!--mvp-nav-top-left-->
													<div class="mvp-nav-top-left-in">
														<div class="mvp-nav-top-mid left relative" itemscope itemtype="http://schema.org/Organization">
																															<a class="mvp-nav-logo-reg" itemprop="url" href="http://www.basketballinsiders.com/"><img itemprop="logo" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/LargeLogo_WithWhite200-1.png" alt="Basketball Insiders | NBA Rumors And Basketball News" data-rjs="2" /></a>
																																														<a class="mvp-nav-logo-small" href="http://www.basketballinsiders.com/"><img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/LargeLogo_w30.png" alt="Basketball Insiders | NBA Rumors And Basketball News" data-rjs="2" /></a>
																																														<h2 class="mvp-logo-title">Basketball Insiders | NBA Rumors And Basketball News</h2>
																																														<div class="mvp-drop-nav-title left">
																	<h4>What Else Should The NBA Change? Part 1</h4>
																</div><!--mvp-drop-nav-title-->
																													</div><!--mvp-nav-top-mid-->
													</div><!--mvp-nav-top-left-in-->
												</div><!--mvp-nav-top-left-out-->
											</div><!--mvp-nav-top-cont-->
										</div><!--mvp-nav-top-right-in-->
										<div class="mvp-nav-top-right">
																						<span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span>
										</div><!--mvp-nav-top-right-->
									</div><!--mvp-nav-top-right-out-->
								</div><!--mvp-nav-top-wrap-->
							</div><!--mvp-main-box-->
						</div><!--mvp-main-nav-top-->
						<div id="mvp-main-nav-bot" class="left relative">
							<div id="mvp-main-nav-bot-cont" class="left">
								<div class="mvp-main-box">
									<div id="mvp-nav-bot-wrap" class="left">
										<div class="mvp-nav-bot-right-out left">
											<div class="mvp-nav-bot-right-in">
												<div class="mvp-nav-bot-cont left">
													<div class="mvp-nav-bot-left-out">
														<div class="mvp-nav-bot-left left relative">
															<div class="mvp-fly-but-wrap mvp-fly-but-click left relative">
																<span></span>
																<span></span>
																<span></span>
																<span></span>
															</div><!--mvp-fly-but-wrap-->
														</div><!--mvp-nav-bot-left-->
														<div class="mvp-nav-bot-left-in">
															<div class="mvp-nav-menu left">
																<div class="menu-main-nav-container"><ul id="menu-main-nav" class="menu"><li id="menu-item-48819" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48819"><a href="http://www.basketballinsiders.com/category/basketball-headlines/nba-headlines/">NBA Headlines</a><div class="mvp-mega-dropdown"><div class="mvp-main-box"><ul class="mvp-mega-list"><li><a href="http://www.basketballinsiders.com/adam-silver-season-could-resume-at-one-or-two-bubble-sites/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>Adam Silver: Season Could Resume at One or Two &#8216;bubble sites&#8217;</p></a></li><li><a href="http://www.basketballinsiders.com/sources-bulls-considering-coaching-change/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/11/Jim_Boylen_Bulls_2019_AP4-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/11/Jim_Boylen_Bulls_2019_AP4-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/11/Jim_Boylen_Bulls_2019_AP4-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/11/Jim_Boylen_Bulls_2019_AP4-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/11/Jim_Boylen_Bulls_2019_AP4-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/11/Jim_Boylen_Bulls_2019_AP4.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>Sources: Bulls Considering Coaching Change</p></a></li><li><a href="http://www.basketballinsiders.com/sources-warriors-have-been-preparing-for-years-to-pursue-giannis-antetokounmpo/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Giannis_Antetokounmpo_Bucks_2019_AP_Focused-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Giannis_Antetokounmpo_Bucks_2019_AP_Focused-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Giannis_Antetokounmpo_Bucks_2019_AP_Focused-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Giannis_Antetokounmpo_Bucks_2019_AP_Focused-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Giannis_Antetokounmpo_Bucks_2019_AP_Focused-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Giannis_Antetokounmpo_Bucks_2019_AP_Focused.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>Sources: Warriors &#8216;have been preparing for years&#8217; to Pursue Giannis Antetokounmpo</p></a></li><li><a href="http://www.basketballinsiders.com/sources-nets-rockets-interested-in-tom-thibodeau/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2018/09/Tom_Thibodeau_Timberwolves_2018_AP-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2018/09/Tom_Thibodeau_Timberwolves_2018_AP-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2018/09/Tom_Thibodeau_Timberwolves_2018_AP-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2018/09/Tom_Thibodeau_Timberwolves_2018_AP-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2018/09/Tom_Thibodeau_Timberwolves_2018_AP-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2018/09/Tom_Thibodeau_Timberwolves_2018_AP.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>Sources: Nets, Rockets Interested in Tom Thibodeau</p></a></li><li><a href="http://www.basketballinsiders.com/sources-nba-considering-disney-world-as-neutral-playing-site-to-restart-season/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>Sources: NBA Considering Disney World as Neutral Playing Site to Restart Season</p></a></li></ul></div></div></li>
<li id="menu-item-48820" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-48820"><a href="http://www.basketballinsiders.com/category/nba-news/">NBA News</a><div class="mvp-mega-dropdown"><div class="mvp-main-box"><ul class="mvp-mega-list"><li><a href="http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Adam_Silver_Jazz_All-Star2023_2019_AP-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Adam_Silver_Jazz_All-Star2023_2019_AP-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Adam_Silver_Jazz_All-Star2023_2019_AP-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Adam_Silver_Jazz_All-Star2023_2019_AP-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Adam_Silver_Jazz_All-Star2023_2019_AP-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Adam_Silver_Jazz_All-Star2023_2019_AP.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>What Else Should The NBA Change? Part 1</p></a></li><li><a href="http://www.basketballinsiders.com/the-nba-draft-look-back-2017/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Jayson_Tatum_Celtics_2019_AP1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Jayson_Tatum_Celtics_2019_AP1-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Jayson_Tatum_Celtics_2019_AP1-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Jayson_Tatum_Celtics_2019_AP1-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Jayson_Tatum_Celtics_2019_AP1-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Jayson_Tatum_Celtics_2019_AP1.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>The NBA Draft Look-Back: 2017</p></a></li><li><a href="http://www.basketballinsiders.com/the-nba-draft-look-back-2016/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Brandon_Ingram_Pelicans_2019_AP_Smiling-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Brandon_Ingram_Pelicans_2019_AP_Smiling-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Brandon_Ingram_Pelicans_2019_AP_Smiling-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Brandon_Ingram_Pelicans_2019_AP_Smiling-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Brandon_Ingram_Pelicans_2019_AP_Smiling-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Brandon_Ingram_Pelicans_2019_AP_Smiling.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>The NBA Draft Look-Back: 2016</p></a></li><li><a href="http://www.basketballinsiders.com/the-next-all-stars-southwest-division/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Zion_Williamson_Pelicans_2019_AP3-1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Zion_Williamson_Pelicans_2019_AP3-1-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Zion_Williamson_Pelicans_2019_AP3-1-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Zion_Williamson_Pelicans_2019_AP3-1-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Zion_Williamson_Pelicans_2019_AP3-1-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Zion_Williamson_Pelicans_2019_AP3-1.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>The Next All-Stars: Southwest Division</p></a></li><li><a href="http://www.basketballinsiders.com/the-nba-draft-look-back-2015/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Montrezl_Harrell_Clippers_2019_AP_Smile-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Montrezl_Harrell_Clippers_2019_AP_Smile-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Montrezl_Harrell_Clippers_2019_AP_Smile-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Montrezl_Harrell_Clippers_2019_AP_Smile-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Montrezl_Harrell_Clippers_2019_AP_Smile-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Montrezl_Harrell_Clippers_2019_AP_Smile.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>The NBA Draft Look-Back: 2015</p></a></li></ul></div></div></li>
<li id="menu-item-60338" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60338"><a href="http://www.basketballinsiders.com/nba-salaries/nba-free-agents-2019-2020-2/">NBA Free Agents</a></li>
<li id="menu-item-48842" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48842"><a href="http://www.basketballinsiders.com/top-100-nba-draft-prospects/">Top 100 Draft Prospects</a></li>
<li id="menu-item-48844" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48844"><a href="http://www.basketballinsiders.com/category/nba-draft/mock-drafts/">Mock Drafts</a><div class="mvp-mega-dropdown"><div class="mvp-main-box"><ul class="mvp-mega-list"><li><a href="http://www.basketballinsiders.com/2019-nba-consensus-mock-draft-final/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/01/Draft_Williamson_Barrett_Morant-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/01/Draft_Williamson_Barrett_Morant-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/01/Draft_Williamson_Barrett_Morant-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/01/Draft_Williamson_Barrett_Morant-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/01/Draft_Williamson_Barrett_Morant-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/01/Draft_Williamson_Barrett_Morant.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>2019 NBA Consensus Mock Draft – Final</p></a></li><li><a href="http://www.basketballinsiders.com/nba-daily-60-pick-nba-mock-draft-6-18-2019/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Draft_Okpala_Hayes_Gafford-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Draft_Okpala_Hayes_Gafford-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Draft_Okpala_Hayes_Gafford-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Draft_Okpala_Hayes_Gafford-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Draft_Okpala_Hayes_Gafford-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Draft_Okpala_Hayes_Gafford.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>NBA Daily: 60-Pick Mock Draft &#8211; 6/18/2019</p></a></li><li><a href="http://www.basketballinsiders.com/2019-nba-consensus-mock-draft-ver-6-0/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/01/Draft_Williamson_Barrett_Morant-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/01/Draft_Williamson_Barrett_Morant-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/01/Draft_Williamson_Barrett_Morant-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/01/Draft_Williamson_Barrett_Morant-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/01/Draft_Williamson_Barrett_Morant-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/01/Draft_Williamson_Barrett_Morant.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>2019 NBA Consensus Mock Draft &#8211; Ver 6.0</p></a></li><li><a href="http://www.basketballinsiders.com/2019-nba-consensus-mock-draft-ver-5-0/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/03/Thybulle_Mortant_Clarke_Draft-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/03/Thybulle_Mortant_Clarke_Draft-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/03/Thybulle_Mortant_Clarke_Draft-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/03/Thybulle_Mortant_Clarke_Draft-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/03/Thybulle_Mortant_Clarke_Draft-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/03/Thybulle_Mortant_Clarke_Draft.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>2019 NBA Consensus Mock Draft &#8211; Ver 5.0</p></a></li><li><a href="http://www.basketballinsiders.com/nba-daily-60-pick-nba-mock-draft-5-28-19/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Draft_Reddish_Hachimura_LIttle-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Draft_Reddish_Hachimura_LIttle-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Draft_Reddish_Hachimura_LIttle-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Draft_Reddish_Hachimura_LIttle-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Draft_Reddish_Hachimura_LIttle-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Draft_Reddish_Hachimura_LIttle.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>NBA Daily: 60-Pick NBA Mock Draft – 5/28/19</p></a></li></ul></div></div></li>
<li id="menu-item-48823" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48823"><a href="http://www.basketballinsiders.com/category/insiders-podcast/">Insiders Podcast</a><div class="mvp-mega-dropdown"><div class="mvp-main-box"><ul class="mvp-mega-list"><li><a href="http://www.basketballinsiders.com/podcast-from-the-final-four-to-the-g-league-with-collin-terry/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_4-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_4-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_4-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_4-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_4-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_4.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>PODCAST: From The Final Four To The G-League With Collin Terry</p></a></li><li><a href="http://www.basketballinsiders.com/podcast-the-agent-life-with-daniel-poneman/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2015/06/BIThePodcast-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2015/06/BIThePodcast-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2015/06/BIThePodcast-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2015/06/BIThePodcast-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2015/06/BIThePodcast-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2015/06/BIThePodcast.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>PODCAST: The Agent Life With Daniel Poneman</p></a></li><li><a href="http://www.basketballinsiders.com/podcast-whos-got-next-with-jordan-fair/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_7-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_7-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_7-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_7-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_7-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_7.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>PODCAST: Who&#8217;s Got Next With Jordan Fair</p></a></li><li><a href="http://www.basketballinsiders.com/podcast-the-next-part-of-the-journey-with-xavier-silas/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_1-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_1-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_1-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_1-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_1.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>PODCAST: The Next Part Of The Journey With Xavier Silas</p></a></li><li><a href="http://www.basketballinsiders.com/podcast-catching-up-with-john-henson-the-pros-pro/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_5-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_5-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_5-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_5-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_5-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_5.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>PODCAST: Catching Up With John Henson, The Pro&#8217;s Pro</p></a></li></ul></div></div></li>
<li id="menu-item-48836" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-48836"><a href="http://www.basketballinsiders.com/nba-team-salaries-at-a-glance/">NBA Team Salaries</a>
<ul class="sub-menu">
	<li id="menu-item-48838" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48838"><a href="http://www.basketballinsiders.com/nbas-top-50-highest-paid-players/">NBA&#8217;s Top 50 Highest Paid Players</a></li>
	<li id="menu-item-48834" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48834"><a href="http://www.basketballinsiders.com/nba-salaries/nba-rookie-salary-scale-by-draft-year/">NBA Rookie Salary Scale – By Draft Year</a></li>
	<li id="menu-item-48835" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48835"><a href="http://www.basketballinsiders.com/nba-salaries/nba-salary-cap-notes/">NBA Salary Cap Notes</a></li>
	<li id="menu-item-54315" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54315"><a href="http://www.basketballinsiders.com/nba-salaries/nba-free-agents-2018-2019/">NBA Free Agents – 2018-2019</a></li>
	<li id="menu-item-54320" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54320"><a href="http://www.basketballinsiders.com/nba-salaries/nba-free-agents-2019-2020-2/">NBA Free Agents – 2019-2020</a></li>
	<li id="menu-item-54321" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54321"><a href="http://www.basketballinsiders.com/nba-salaries/nba-free-agents-2020-2021/">NBA Free Agents – 2020-2021</a></li>
	<li id="menu-item-48868" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48868"><a href="http://www.basketballinsiders.com/nba-salaries/2015-16-nba-salary-cap-70-million/">2015-16 NBA Salary Cap – $70 Million</a></li>
	<li id="menu-item-48867" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48867"><a href="http://www.basketballinsiders.com/nba-salaries/2016-17-nba-salary-cap-94-143-million/">2016-17 NBA Salary Cap – $94.143 million</a></li>
	<li id="menu-item-48866" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48866"><a href="http://www.basketballinsiders.com/nba-salaries/2017-18-nba-salary-cap-99-093-million/">2017-18 NBA Salary Cap – $99.093 Million</a></li>
	<li id="menu-item-54377" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54377"><a href="http://www.basketballinsiders.com/nba-salaries/2018-19-nba-salary-cap-101-869-million/">2018-19 NBA Salary Cap – $101.869 Million</a></li>
	<li id="menu-item-60893" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-60893"><a href="http://www.basketballinsiders.com/2019-20-nba-salary-cap-109-140-million/">2019-20 NBA Salary Cap – $109.140 Million</a></li>
</ul>
</li>
<li id="menu-item-48824" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-48824"><a href="http://#">More</a>
<ul class="sub-menu">
	<li id="menu-item-48829" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48829"><a href="http://www.basketballinsiders.com/authors/">Our Team</a></li>
	<li id="menu-item-48822" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48822"><a href="http://www.basketballinsiders.com/category/nba-draft/">NBA Draft</a><div class="mvp-mega-dropdown"><div class="mvp-main-box"><ul class="mvp-mega-list"><li><a href="http://www.basketballinsiders.com/nba-announces-early-entry-candidates-for-2020-nba-draft/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/04/2020NBADraft-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/04/2020NBADraft-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/04/2020NBADraft-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/04/2020NBADraft-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/04/2020NBADraft.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/04/2020NBADraft-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>NBA ANNOUNCES EARLY ENTRY CANDIDATES FOR 2020 NBA DRAFT</p></a></li><li><a href="http://www.basketballinsiders.com/nba-daily-biggest-winners-on-draft-night/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Reddish-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Reddish-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Reddish-1000x600.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Reddish-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>NBA Daily: Biggest Winners On Draft Night</p></a></li><li><a href="http://www.basketballinsiders.com/2019-nba-draft-trade-recap/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Culver_Shake-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Culver_Shake-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Culver_Shake-300x179.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Culver_Shake-768x458.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Culver_Shake-1024x611.jpg 1024w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Culver_Shake-1000x600.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Culver_Shake-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Culver_Shake.jpg 1250w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>2019 NBA Draft Trade Recap</p></a></li><li><a href="http://www.basketballinsiders.com/nba-daily-the-undrafted-list-who-got-missed/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/880C8E4D-347B-420F-9C5E-595CFBDA8877-400x240.jpeg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/880C8E4D-347B-420F-9C5E-595CFBDA8877-400x240.jpeg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/880C8E4D-347B-420F-9C5E-595CFBDA8877-1000x600.jpeg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/880C8E4D-347B-420F-9C5E-595CFBDA8877-590x354.jpeg 590w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>NBA Daily: The Undrafted List &#8211; Who Got Missed</p></a></li><li><a href="http://www.basketballinsiders.com/30-kevin-porter-jr-cleveland-cavaliers/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Kevin_Porter_USC_2019_AP-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Kevin_Porter_USC_2019_AP-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Kevin_Porter_USC_2019_AP-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Kevin_Porter_USC_2019_AP-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Kevin_Porter_USC_2019_AP-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Kevin_Porter_USC_2019_AP.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>#30 – Kevin Porter Jr. – Cleveland Cavaliers</p></a></li></ul></div></div></li>
	<li id="menu-item-48839" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48839"><a href="http://www.basketballinsiders.com/history-of-the-nba-draft-by-team/">History of the NBA Draft – By Team</a></li>
	<li id="menu-item-48840" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48840"><a href="http://www.basketballinsiders.com/history-of-the-nba-draft-by-pick/">History of the NBA Draft – By Pick</a></li>
	<li id="menu-item-48827" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48827"><a href="http://www.basketballinsiders.com/nba-trade-history/">NBA Trade History</a></li>
	<li id="menu-item-48828" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48828"><a href="http://www.basketballinsiders.com/key-nba-dates/">Key NBA Dates &#8211; 2019-20</a></li>
	<li id="menu-item-48826" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48826"><a href="http://www.basketballinsiders.com/privacy-policy/">Privacy Policy</a></li>
	<li id="menu-item-48825" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48825"><a href="http://www.basketballinsiders.com/terms-of-service/">Terms Of Service</a></li>
	<li id="menu-item-48830" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48830"><a href="http://www.basketballinsiders.com/contact-us/">Contact Us</a></li>
</ul>
</li>
</ul></div>															</div><!--mvp-nav-menu-->
														</div><!--mvp-nav-bot-left-in-->
													</div><!--mvp-nav-bot-left-out-->
												</div><!--mvp-nav-bot-cont-->
											</div><!--mvp-nav-bot-right-in-->
											<div class="mvp-nav-bot-right left relative">
												<span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span>
											</div><!--mvp-nav-bot-right-->
										</div><!--mvp-nav-bot-right-out-->
									</div><!--mvp-nav-bot-wrap-->
								</div><!--mvp-main-nav-bot-cont-->
							</div><!--mvp-main-box-->
						</div><!--mvp-main-nav-bot-->
					</nav><!--mvp-main-nav-wrap-->
							</header><!--mvp-main-head-wrap-->
			
			<div id="mvp-main-body-wrap" class="left relative"><article id="mvp-article-wrap" itemscope itemtype="http://schema.org/NewsArticle">
			<meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/"/>
						<div id="mvp-article-cont" class="left relative">
			<div class="mvp-main-box">
				<div id="mvp-post-main" class="left relative">
										<header id="mvp-post-head" class="left relative">
						<h3 class="mvp-post-cat left relative"><a class="mvp-post-cat-link" href="http://www.basketballinsiders.com/category/nba-news/"><span class="mvp-post-cat left">NBA</span></a></h3>
						<h1 class="mvp-post-title left entry-title" itemprop="headline">What Else Should The NBA Change? Part 1</h1>
													<span class="mvp-post-excerpt left"><p>David Yapkowitz considers what long-term changes the NBA should consider making as the league moves forward.</p>
</span>
																			<div class="mvp-author-info-wrap left relative">
								<div class="mvp-author-info-thumb left relative">
									<img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2014/07/BI_Ball_Small-80x80.jpg" width="46" height="46" alt="David Yapkowitz" class="avatar avatar-46 wp-user-avatar wp-user-avatar-46 alignnone photo" />								</div><!--mvp-author-info-thumb-->
								<div class="mvp-author-info-text left relative">
									<div class="mvp-author-info-date left relative">
										<p>Published</p> <span class="mvp-post-date">3 hours ago</span> <p>on</p> <span class="mvp-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2020-05-09">May 9, 2020</time></span>
										<meta itemprop="dateModified" content="2020-05-09"/>
									</div><!--mvp-author-info-date-->
									<div class="mvp-author-info-name left relative" itemprop="author" itemscope itemtype="https://schema.org/Person">
										<p>By</p> <span class="author-name vcard fn author" itemprop="name"><a href="http://www.basketballinsiders.com/author/dyapkowitz/" title="Posts by David Yapkowitz" rel="author">David Yapkowitz</a></span> <a href="" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a>
									</div><!--mvp-author-info-name-->
								</div><!--mvp-author-info-text-->
							</div><!--mvp-author-info-wrap-->
											</header>
										<div class="mvp-post-main-out left relative">
						<div class="mvp-post-main-in">
							<div id="mvp-post-content" class="left relative">
																																																			<div id="mvp-video-embed-wrap" class="left relative">
											<div id="mvp-video-embed-cont" class="left relative">
												<span class="mvp-video-close fa fa-times" aria-hidden="true"></span>
												<div id="mvp-video-embed" class="left relative">
													<div class='s2nPlayer k-xN7MeEOC' data-type='float'></div><script type='text/javascript' src='//embed.sendtonews.com/player3/embedcode.js?fk=xN7MeEOC&cid=7380&offsetx=0&offsety=0&floatwidth=400&floatposition=bottom-right' data-type='s2nScript'></script>												</div><!--mvp-video-embed-->
											</div><!--mvp-video-embed-cont-->
										</div><!--mvp-video-embed-wrap-->
										<div class="mvp-post-img-hide" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
																						<meta itemprop="url" content="http://www.basketballinsiders.com/wp-content/uploads/2019/10/Adam_Silver_Jazz_All-Star2023_2019_AP.jpg">
											<meta itemprop="width" content="1000">
											<meta itemprop="height" content="600">
										</div><!--mvp-post-img-hide-->
																																									<div id="mvp-content-wrap" class="left relative">
									<div class="mvp-post-soc-out right relative">
																																		<div class="mvp-post-soc-wrap left relative">
		<ul class="mvp-post-soc-list left relative">
			<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/&amp;t=What Else Should The NBA Change? Part 1', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
			<li class="mvp-post-soc-fb">
				<i class="fa fa-2 fa-facebook" aria-hidden="true"></i>
			</li>
			</a>
			<a href="#" onclick="window.open('http://twitter.com/share?text=What Else Should The NBA Change? Part 1 -&amp;url=http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
			<li class="mvp-post-soc-twit">
				<i class="fa fa-2 fa-twitter" aria-hidden="true"></i>
			</li>
			</a>
			<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/&amp;media=http://www.basketballinsiders.com/wp-content/uploads/2019/10/Adam_Silver_Jazz_All-Star2023_2019_AP.jpg&amp;description=What Else Should The NBA Change? Part 1', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
			<li class="mvp-post-soc-pin">
				<i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i>
			</li>
			</a>
			<a href="mailto:?subject=What Else Should The NBA Change? Part 1&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/">
			<li class="mvp-post-soc-email">
				<i class="fa fa-2 fa-envelope" aria-hidden="true"></i>
			</li>
			</a>
												<a href="http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/#respond">
					<li class="mvp-post-soc-com mvp-com-click">
						<i class="fa fa-2 fa-commenting" aria-hidden="true"></i>
					</li>
					</a>
									</ul>
	</div><!--mvp-post-soc-wrap-->
	<div id="mvp-soc-mob-wrap">
		<div class="mvp-soc-mob-out left relative">
			<div class="mvp-soc-mob-in">
				<div class="mvp-soc-mob-left left relative">
					<ul class="mvp-soc-mob-list left relative">
						<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/&amp;t=What Else Should The NBA Change? Part 1', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
						<li class="mvp-soc-mob-fb">
							<i class="fa fa-facebook" aria-hidden="true"></i><span class="mvp-soc-mob-fb">Share</span>
						</li>
						</a>
						<a href="#" onclick="window.open('http://twitter.com/share?text=What Else Should The NBA Change? Part 1 -&amp;url=http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
						<li class="mvp-soc-mob-twit">
							<i class="fa fa-twitter" aria-hidden="true"></i><span class="mvp-soc-mob-fb">Tweet</span>
						</li>
						</a>
						<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/&amp;media=http://www.basketballinsiders.com/wp-content/uploads/2019/10/Adam_Silver_Jazz_All-Star2023_2019_AP.jpg&amp;description=What Else Should The NBA Change? Part 1', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
						<li class="mvp-soc-mob-pin">
							<i class="fa fa-pinterest-p" aria-hidden="true"></i>
						</li>
						</a>
						<a href="whatsapp://send?text=What Else Should The NBA Change? Part 1 http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/"><div class="whatsapp-share"><span class="whatsapp-but1">
						<li class="mvp-soc-mob-what">
							<i class="fa fa-whatsapp" aria-hidden="true"></i>
						</li>
						</a>
						<a href="mailto:?subject=What Else Should The NBA Change? Part 1&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/">
						<li class="mvp-soc-mob-email">
							<i class="fa fa-envelope-o" aria-hidden="true"></i>
						</li>
						</a>
																					<a href="http://www.basketballinsiders.com/what-else-should-the-nba-change-part-1/#respond">
								<li class="mvp-soc-mob-com mvp-com-click">
									<i class="fa fa-comment-o" aria-hidden="true"></i>
								</li>
								</a>
																		</ul>
				</div><!--mvp-soc-mob-left-->
			</div><!--mvp-soc-mob-in-->
			<div class="mvp-soc-mob-right left relative">
				<i class="fa fa-ellipsis-h" aria-hidden="true"></i>
			</div><!--mvp-soc-mob-right-->
		</div><!--mvp-soc-mob-out-->
	</div><!--mvp-soc-mob-wrap-->
																															<div class="mvp-post-soc-in">
											<div id="mvp-content-body" class="left relative">
												<div id="mvp-content-body-top" class=left relative">
																																							<div id="mvp-content-main" class="left relative">
														<p><!-- BEGIN THEIA POST SLIDER --></p>
<p>We&#8217;re coming up on two months since the 2019-20 NBA season was abruptly halted – and now, we&#8217;re still no closer to resuming the season as we were back then. Adam Silver hosted a conference call with players on Friday afternoon during which scenarios as to possibly restarting the season were reportedly discussed.</p>
<p>In any case, whether the season is able to continue or not, this has already affected several other NBA events such as the annual Draft Combine, the lottery and, possibly, the draft itself. Free agency and summer league will also most likely be affected.</p>
<p>In the call with players, Silver reportedly said that regardless of whether play resumes or not, the start of the 2020-21 season will be pushed back until December.</p>
<p>All of this raises a couple of very important questions, what other possible changes should the NBA make – and should those changes become more permanent?</p>
<p>This past week at Basketball Insiders, in our quest to provide you with basketball content during these uncertain times, we&#8217;ve looked back at the last several drafts and how those players have since panned out. We&#8217;re culminating the week with a look at what changes should the NBA implement moving forward.</p>
<p>Here is are a list of things the NBA should consider when planning future seasons.</p>
<h3><strong>A shortened season with a later start time</strong></h3>
<p>In the NBA&#8217;s inaugural season back in 1946, the league played a total of 60 games with 11 teams. Throughout their first few seasons, and up until the 1952-53 season, the regular season consisted of about 60 or so games. Following that season, 72 games became the norm, gradually increasing until the 1967-68 season when the league settled on the standard 82 game season that we know today.</p>
<p>There&#8217;s no question that football is America&#8217;s sport. From the NFL to college football to even high school, there&#8217;s no pastime that captures Americans more than football. Football season begins in the fall and with the NBA starting up right after in October, it overlaps with one of the country&#8217;s biggest draws.</p>
<p>The NBA should consider starting their regular season in December permanently. Right around Christmas would be a wonderful time to begin. Can you imagine families gathered around the TV on Christmas night as the defending champions receive their rings? Football season is over not too long after that as well.</p>
<p>Over the years, there have also been suggestions that the NBA consider shortening the season. If they did decide to start the season in December from now on, perhaps it would be a good idea to shorten the season a bit rather than try and squish 82 games in a condescend time frame.</p>
<h3>Playoffs revert to best of five in the first-round</h3>
<p>Growing up, for many,  the first round of the NBA playoffs was always a best-of-five series. Often, it added a little bit more intrigue and, while not the heightened anxiety of the NCAA single elimination style, it still paved the way for the possible upset of a higher-seeded team.</p>
<p>In a seven-game series, the better team is usually able to pull off the series victory. Better teams have better players, better coaching and better scouting. Over the course of seven games, they&#8217;ll eventually wear you down and beat you.</p>
<p>We&#8217;ve had some upsets back during the best of five first-round series. In this lifetime, the top two that come to mind are the New York Knicks&#8217; first-round win over the Miami HEAT in the 1999 playoffs and the Denver Nuggets come-from-behind win over the Seattle Supersonics in the 1994 version. In today&#8217;s format, Allan Houston&#8217;s game-winner would&#8217;ve just given the Knicks a 3-2 lead and Miami might have still been able to win that series.</p>
<p>Aside from the possible intrigue though, and getting back to the main topic, reverting to a best-of-five instead of seven would shorten the playoffs and allow the NBA to shave off a few games from the 82 and go with a shorter season. If there aren&#8217;t as many possible playoff games, then a shortened season with a later start time could possibly work.</p>
<h3>Limitations/reductions on courtside seats</h3>
<p>One of the best experiences of an NBA game is being able to sit right alongside the court and have an up-close and personal view of all the action. Fans get to hear all the chatter and perhaps even get to interact with a player or two.</p>
<p>It&#8217;s a distinct possibility that in a post-COVID-19 world, some form of social distancing will remain. Some of it might become part of a new normal. That could carry over to professional sports in that fan/player interactions will be more limited and controlled. NBA courtside seating would appear to fall under that banner.</p>
<p>There have already been player complaints about being harassed verbally, even physically, by fans sitting courtside. With a new virus making its way through the population and seemingly passed on with close contact, it might give the NBA an excuse to push some of those seats back for the health and safety of the players.</p>
<p>These are all just musings, however, there is absolutely no inkling that the NBA is even remotely considering any of these possibilities. A post-COVID-19 world is most likely going to be a bit different than what we&#8217;re accustomed to – and the NBA probably won&#8217;t be sparred. But until we know for sure, it&#8217;s fun to speculate what the NBA could or would not consider changing.</p>
<p><!-- END THEIA POST SLIDER --></p>
																											</div><!--mvp-content-main-->
													<div id="mvp-content-bot" class="left">
																												<div class="mvp-post-tags">
															<span class="mvp-post-tags-header">Related Topics:</span><span itemprop="keywords"><a href="http://www.basketballinsiders.com/tag/main-page/" rel="tag">Main Page</a><a href="http://www.basketballinsiders.com/tag/nba/" rel="tag">NBA</a></span>
														</div><!--mvp-post-tags-->
														<div class="posts-nav-link">
																													</div><!--posts-nav-link-->
																													<div id="mvp-prev-next-wrap" class="left relative">
																																																	<div class="mvp-prev-post-wrap left relative">
																		<a href="http://www.basketballinsiders.com/the-nba-draft-look-back-2017/" rel="bookmark">
																		<div class="mvp-prev-next-cont left relative">
																			<div class="mvp-prev-cont-out right relative">
																				<span class="mvp-prev-arr fa fa-chevron-left left"></span>
																				<div class="mvp-prev-cont-in">
																					<div class="mvp-prev-next-text left relative">
																						<span class="mvp-prev-next-label left relative">Don&#039;t Miss</span>
																						<p>The NBA Draft Look-Back: 2017</p>
																					</div><!--mvp-prev-next-text-->
																				</div><!--mvp-prev-cont-in-->
																			</div><!--mvp-prev-cont-out-->
																		</div><!--mvp-prev-next-cont-->
																		</a>
																	</div><!--mvp-prev-post-wrap-->
																															</div><!--mvp-prev-next-wrap-->
																																											<div id="mvp-author-box-wrap" class="left relative">
																<div class="mvp-author-box-out right relative">
																	<div id="mvp-author-box-img" class="left relative">
																		<img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2014/07/BI_Ball_Small-80x80.jpg" width="60" height="60" alt="David Yapkowitz" class="avatar avatar-60 wp-user-avatar wp-user-avatar-60 alignnone photo" />																	</div><!--mvp-author-box-img-->
																	<div class="mvp-author-box-in">
																		<div id="mvp-author-box-head" class="left relative">
																			<span class="mvp-author-box-name left relative"><a href="http://www.basketballinsiders.com/author/dyapkowitz/" title="Posts by David Yapkowitz" rel="author">David Yapkowitz</a></span>
																			<div id="mvp-author-box-soc-wrap" class="left relative">
																																																																																																																																																															</div><!--mvp-author-box-soc-wrap-->
																		</div><!--mvp-author-box-head-->
																	</div><!--mvp-author-box-in-->
																</div><!--mvp-author-box-out-->
																<div id="mvp-author-box-text" class="left relative">
																	<p></p>
																</div><!--mvp-author-box-text-->
															</div><!--mvp-author-box-wrap-->
																												<div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
															<div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
																																	<img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/LargeLogo_WithWhite200-1.png"/>
																	<meta itemprop="url" content="http://www.basketballinsiders.com/wp-content/uploads/2017/08/LargeLogo_WithWhite200-1.png">
																															</div><!--mvp-org-logo-->
															<meta itemprop="name" content="Basketball Insiders | NBA Rumors And Basketball News">
														</div><!--mvp-org-wrap-->
													</div><!--mvp-content-bot-->
												</div><!--mvp-content-body-top-->
												<div class="mvp-cont-read-wrap">
																																								<div id="mvp-post-bot-ad" class="left relative">
															<span class="mvp-ad-label">Advertisement</span>
															<!-- Rev Content Start -->
<div id="rcjsload_b16eff"></div>
<script type="text/javascript">
(function() {
var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);
var rcel = document.createElement("script");
rcel.id = 'rc_' + Math.floor(Math.random() * 1000);
rcel.type = 'text/javascript';
rcel.src = "http://trends.revcontent.com/serve.js.php?w=1750&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth)+"&referer="+referer;
rcel.async = true;
var rcds = document.getElementById("rcjsload_b16eff"); rcds.appendChild(rcel);
})();
</script>
<!-- Rev Content End -->
<br><br>
<!-- BI_Homepage_Leaderboard_BTF (responsive) -->
<div class="ad-tag" data-ad-name="BI_Homepage_Leaderboard_BTF" data-ad-size="auto" ></div>
<script src="//tags-cdn.deployads.com/a/basketballinsiders.com.js" async ></script>
<script>(deployads = window.deployads || []).push({});</script>
<br><br>														</div><!--mvp-post-bot-ad-->
																																								<div id="mvp-related-posts" class="left relative">

															<h4 class="mvp-widget-home-title">
																<span class="mvp-widget-home-title">You may like</span>
															</h4>
																			<ul class="mvp-related-posts-list left related">
            								<a href="http://www.basketballinsiders.com/adam-silver-season-could-resume-at-one-or-two-bubble-sites/" rel="bookmark">
            			<li>
							                				<div class="mvp-related-img left relative">
									<img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" />									<img width="80" height="80" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-80x80.jpg 80w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																	</div><!--mvp-related-img-->
														<div class="mvp-related-text left relative">
								<p>Adam Silver: Season Could Resume at One or Two &#8216;bubble sites&#8217;</p>
							</div><!--mvp-related-text-->
            			</li>
						</a>
            								<a href="http://www.basketballinsiders.com/sources-nba-considering-disney-world-as-neutral-playing-site-to-restart-season/" rel="bookmark">
            			<li>
							                				<div class="mvp-related-img left relative">
									<img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" />									<img width="80" height="80" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-80x80.jpg 80w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																	</div><!--mvp-related-img-->
														<div class="mvp-related-text left relative">
								<p>Sources: NBA Considering Disney World as Neutral Playing Site to Restart Season</p>
							</div><!--mvp-related-text-->
            			</li>
						</a>
            								<a href="http://www.basketballinsiders.com/sources-nba-angling-to-cancel-rest-of-season/" rel="bookmark">
            			<li>
							                				<div class="mvp-related-img left relative">
									<img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" />									<img width="80" height="80" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-80x80.jpg 80w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																	</div><!--mvp-related-img-->
														<div class="mvp-related-text left relative">
								<p>Sources: NBA &#8216;angling&#8217; to Cancel Rest of 2020 Season</p>
							</div><!--mvp-related-text-->
            			</li>
						</a>
            		</ul>															
														</div><!--mvp-related-posts-->
																																																																						<div id="mvp-comments-button" class="left relative mvp-com-click">
																<span class="mvp-comment-but-text">Click to comment</span>
															</div><!--mvp-comments-button-->
															<div id="comments">
				
	
	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><h4 class="mvp-widget-home-title"><span class="mvp-widget-home-title">Leave a Reply</span></h4> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/what-else-should-the-nba-change-part-1/#respond" style="display:none;">Cancel reply</a></small></h3><form action="http://www.basketballinsiders.com/wp-comments-post.php?wpe-comment-post=insiderssports" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='65217' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="86da57823a" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="91"/></p></form>	</div><!-- #respond -->
	
</div><!--comments-->																																							</div><!--mvp-cont-read-wrap-->
											</div><!--mvp-content-body-->
										</div><!--mvp-post-soc-in-->
									</div><!--mvp-post-soc-out-->
								</div><!--mvp-content-wrap-->
													<div id="mvp-post-add-box">
								<div id="mvp-post-add-wrap" class="left relative">
																			<div class="mvp-post-add-story left relative">
											<div class="mvp-post-add-head left relative">
												<h3 class="mvp-post-cat left relative"><a class="mvp-post-cat-link" href="http://www.basketballinsiders.com/category/nba-news/"><span class="mvp-post-cat left">NBA</span></a></h3>
												<h1 class="mvp-post-title left">The NBA Draft Look-Back: 2017</h1>
																									<span class="mvp-post-excerpt left"><p>Drew Maresca examines the controversial 2017 NBA Draft, identifying class hits, misses and guys on whom the jury is still out. </p>
</span>
																																					<div class="mvp-author-info-wrap left relative">
														<div class="mvp-author-info-thumb left relative">
															<img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Drew_Marseca_InsidersSM-80x80.jpg" width="46" height="46" alt="Drew Maresca" class="avatar avatar-46 wp-user-avatar wp-user-avatar-46 alignnone photo" />														</div><!--mvp-author-info-thumb-->
														<div class="mvp-author-info-text left relative">
															<div class="mvp-author-info-date left relative">
																<p>Published</p> <span class="mvp-post-date">2 days ago</span> <p>on</p> <span class="mvp-post-date">May 7, 2020</span>
															</div><!--mvp-author-info-date-->
															<div class="mvp-author-info-name left relative">
																<p>By</p> <span class="author-name"><a href="http://www.basketballinsiders.com/author/dmaresca/" title="Posts by Drew Maresca" rel="author">Drew Maresca</a></span> <a href="https://twitter.com/DrewMaresca" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a>
															</div><!--mvp-author-info-name-->
														</div><!--mvp-author-info-text-->
													</div><!--mvp-author-info-wrap-->
																							</div><!--mvp-post-add-head-->
											<div class="mvp-post-add-body left relative">
																																							<div class="mvp-post-add-img left relative">
															<img width="1000" height="600" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Jayson_Tatum_Celtics_2019_AP1.jpg" class="attachment- size- wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Jayson_Tatum_Celtics_2019_AP1.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Jayson_Tatum_Celtics_2019_AP1-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Jayson_Tatum_Celtics_2019_AP1-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Jayson_Tatum_Celtics_2019_AP1-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Jayson_Tatum_Celtics_2019_AP1-400x240.jpg 400w" sizes="(max-width: 1000px) 100vw, 1000px" />														</div><!--mvp-post-feat-img-->
																																																			<div class="mvp-post-add-cont left relative">
													<div class="mvp-post-add-main right relative">
														<p><!-- BEGIN THEIA POST SLIDER --></p>
<p>In an ongoing attempt to continue to get you your basketball fix, Basketball Insiders is taking a look back at recent draft classes and assessing them relative to the expectations that were in place as of their respect NBA Drafts.</p>
<p>We are grading according to the following criteria:</p>
<p><strong>The Hits – the players that panned out</strong><br />
<strong>The Misses – the players that did not pan out</strong><br />
<strong>The Sleepers – the players that exceeded minimal expectations</strong><br />
<strong>The Jury Is Out – those that have shown flashes</strong></p>
<p>Matt John did a fantastic job assessing the <a href="http://www.basketballinsiders.com/nba-daily-the-nba-draft-look-back-2014/" target="_blank" rel="noopener noreferrer">2014</a> NBA Draft. Ben Nadeau and Spencer Davies did an equally impressive job reviewing the <a href="http://www.basketballinsiders.com/the-nba-draft-look-back-2015/" target="_blank" rel="noopener noreferrer">2015</a> and <a href="http://www.basketballinsiders.com/the-nba-draft-look-back-2016/" target="_blank" rel="noopener noreferrer">2016</a> draft classes, respectively. Up next, we’ll dive into the controversial 2017 NBA Draft class.</p>
<p>The 2017 NBA Draft appeared to be as stocked with high-end talent as any of the other recent draft. But for those of us who needed a refresher on the old “everything that glimmers isn’t gold” adage, 2017 served that purpose.  No one anticipated the struggles that Markelle Fultz would face due to a shoulder ailment and a case of the yips; Fultz is probably the highest-profile “bust” since Greg Oden.</p>
<p>And while Fultz has at least gained some traction in Orlando since his challenging time with Philly, there are plenty of other interesting storylines from the 2017 draft. It was seen as the year of the point guard, but its best players don’t exactly fit that bill. Now with all of that being said, let’s jump in.</p>
<h3><strong>The Hits</strong></h3>
<h3>Jayson Tatum, No. 3</h3>
<p>Tatum was special in his lone season at Duke. No one thought he’d be this special, though. Tatum fits perfectly in the modern NBA. He’s as smooth as they come offensively, and his length and mobility make him an above-average defender and rebounder. He’s a dead-eye shooter and he’s one of the best tough-shot makers in the league. Tatum is the rare talent who can put a team on his back for extremely long stretches. Oh, and he also plays nice with others. No one expected Tatum to be THIS good.</p>
<h3>De’Aaron Fox, No. 5</h3>
<p>Fox was viewed as the steal of the draft before the draft was even over. He was a boom-or-bust prospect whose style fit the league perfectly. He’s a lightning-quick lead guard who wants all of the smoke. Despite being ranked as a lesser prospect, he took it to Lonzo Ball in just about every matchup they’d had in college. And he’s continued to impress in the NBA. Fox is the kind of player around whom you build your franchise. While that’s always been thought of as his ceiling, it’s rare to see players live up to their potential to the degree in which Fox has.</p>
<h3>Jonathan Isaac, No. 6</h3>
<p>Entering the draft, Isaac was seen as the prototypical stretch-four. He took time to develop – averaging only 5.4 points per game in his rookie season. But he blossomed in his third season in the league. Isaac supplanted Aaron Gordon as the Magic’s best defender, and his defensive versatility gives the Magic options they&#8217;d only dreamed of prior to this season. He’s also a pretty efficient offensive player who poster a better than 50% effective field goal percentage. Isaac still has to prove he can play at a high level with consistency, but he made major strides this year – living up to his draft position, and then some.</p>
<h3>Donovan Mitchell, No. 13</h3>
<p>Mitchell is the major surprise of the 2017 NBA Draft. The Louisville standout was seen as too small to succeed in the NBA. But that way of thinking was quickly debunked as Mitchell proceeded to average more than 20 points per game as a rookie – and he hasn’t looked back since.</p>
<p>Mitchell since established himself as the cornerstone of the Utah Jazz, and he’ll probably hold that title for the next decade or so – if he wants it. Mitchell easily outperformed pre-draft expectations. Phil Jackson, then president of the Knicks, saw potential in Mitchell. Few others did with the exception of the Jazz. And now they’re reaping the rewards.</p>
<h3>Bam Adebayo, No. 14</h3>
<p>2019-20 was Adebayo’s coming out party. Prior to this season, Adebayo was a reserve. Still, his per-36 numbers projected an effective and versatile big man. This season, he delivered, averaging 16.2 points, 10.5 rebounds and 5.1 assists per game. Adebayo affects the game in every way possible. And considering his relatively low profile entering the draft – Adebayo was projected to be drafted 17<sup>th</sup> overall by NBADraft.net and was called “raw” and an “energy big” by various outlets– he turned out to be a steal in the late lottery.</p>
<h3><strong>The Misses</strong></h3>
<h3>Markelle Fultz, No. 1</h3>
<p>Fultz got all of the hype you’d expect a first overall pick would receive. Despite missing the NCAA tournament in his lone season at Washington, he was a generational athlete who shot it well from deep and possessed game-changing size and physicality for a point guard.</p>
<p>But Fultz’s rookie season was derailed thanks to shoulder issues. He was (probably) mismanaged by the Philadelphia 76ers and allowed to play too early, leading to a loss in confidence and – ultimately – his departure from Philadelphia. Fultz contributed far more consistently in Orlando in 2019-20, but he still underperformed for his draft position. And he’s still not anywhere near as good as pundits felt he’d be prior to the 2017 NBA Draft. It’s a sad story, but it’s not over yet. At least he’s righted the ship.</p>
<h3>Josh Jackson, No. 4</h3>
<p>Fultz might provide more interesting – albeit premature – headlines, but Jackson’s path been more painful to watch – mostly because his setbacks are mostly his own fault. Jackson entered the 2017 NBA Draft as the Swiss Army knife of the bunch. He was seen as a do-it-all wing whose game fits the modern NBA’s as perfect as any prospect. Instead of hitting the ground running, Jackson had multiple run-ins with the law, resulting in suspensions and a trade from the Phoenix Suns. But Jackson flourished in the G-League after being dealt to the Memphis Grizzlies, and he continued to play efficiently after being called back up.</p>
<p>Jackson could still easily turn his career around. But the setbacks he’s undergone make his first three years a major disappointment.</p>
<h3>Dennis Smith Jr., No. 8</h3>
<p>Smith Jr. was one of the more celebrated prospects in 2017. And based on his rookie season, his profile seemed justified. But then Luka Doncic shook up the NBA – and Smith Jr.’s effectiveness waned.</p>
<p>Still, Smith Jr. has shown signs as recently as the end of 2018-19. He was traded to New York as part of the deal that sent Kristaps Porzingis to the Dallas Mavericks. He averaged 20 points and 5 assists in March 2019. And while he might not have looked like a cornerstone, that was more than the Knicks had at point guard in some time. He struggled with personal loss and a back injury early on this season and he never recovered. And while he possesses the athleticism and ability to be a borderline All-Star, he’ll need to prove it on the court before this writer is comfortable calling him anything less than a miss relative to expectations.</p>
<h3><strong>Sleepers </strong></h3>
<h3>John Collins, No. 19</h3>
<p>Collins has progressed pretty much exactly how teams like their young stars to do so. His scoring average, minutes per game and PER have all shot up in the last three seasons: 10.5 points in 24.3 minutes per game with an 18.3 PER in 2017-18; 19.5 points in 30 minutes per game with a 21.8 PER in 2018-19; and 21.6 points in 33.2 minutes per game with a 23.5 PER in 2019-20. Further, he’s an excellent three-point shooter (40.1% in 2019-20) and extremely active around the rim.</p>
<p>Collins is not THE centerpiece of a contending NBA team, but he’s got all the right attributes to be a starter and a third option. And at 22-years-old, Collins could get even better. Not bad value at all for the late-middle of the first round.</p>
<h3>Jarrett Allen, No. 22</h3>
<p>Despite the fact that Allen’s status on his own team is in question, he’s still an elite defender who’s an above-average lob-catcher and screener. He’s versatile enough to switch on to ball-handlers in screen-and-rolls, and he’s already built an impressive highlight reel of blocked shots that includes LeBron James and Giannis Antetokunmpo.</p>
<p>Yes, Allen was an integral part of a playoff team as recently as two months ago. But expectations were nowhere near that high for him. And while there is some uncertainty ahead for Allen, his talent and work ethic will win out. While he’ll probably never develop a consistent jump shot, his motor and defensive gifts render him a starter in the NBA for years to come</p>
<h3>OG Anunoby, No. 23</h3>
<p>Anunoby was pegged as a breakout player for 2018-19. But Pascal Siakam stole his thunder. While Siakam delivered again this season, Anunoby would not be ignored in two straight seasons.</p>
<p>But rewind a bit and you’ll read about a risky prospect projected to fall into the second round. Unfortunately for the rest of the league, Masai Ujiri and his staff saw the potential of Anunoby, and he’s rewarded them for their faith. He came into his own in 2019-20, establishing himself as a legitimate starter in the NBA. Who knows what he’ll look like next season.</p>
<h3>Kyle Kuzma, No. 27</h3>
<p>Kuzma quickly proved his worth, averaging 16.1 points per game as a rookie. His scoring average jumped in his sophomore season (18.7); but his production took a fairly big hit in 2019-20 after his good friend Lonzo Ball was sent to New Orleans alongside Josh Hart, Brandon Ingram and numerous draft considerations in exchange for Anthony Davis.</p>
<p>But Kuzma is still viewed very favorably around the league. His fit alongside the win-now Lakers might not be ideal, but he’s still seen as an extremely valuable building block for most teams – especially ones in the middle of a rebuild. Kuzma was selected late in the first-round, and he’s already outperformed even the highest of expectations for the 27<sup>th</sup> pick of virtually any draft. In the right situation, he could put up All-Star-caliber numbers. And the Lakers are running low on trade chips. This writer wouldn’t be surprised to see Kuzma playing elsewhere as soon as next season – whenever that is.</p>
<p><strong>Derrick White, No. 29</strong></p>
<p><strong>Thomas Bryant, No. 42</strong></p>
<p><strong>Dillion Brooks, No. 45</strong></p>
<p><strong>Monte Morris, No. 51</strong></p>
<h3><strong>Jury Is Still Out<br />
</strong></h3>
<h3>Lonzo Ball, No. 2</h3>
<p>Ball entered the NBA with tremendous fanfare thanks, in part, to his father’s loud endorsements. LaVar Ball wasn’t entirely wrong about his son, though; It’s just that Lonzo hasn’t translated as well as his dad predicted.</p>
<p>But Ball’s quickness, court vision and defense render him a huge net positive. His shot, on the other hand, has hurt his ability to stretch the defense and be a scoring threat at all times when on offense – even though it did look significantly better in 2019-20 than in years’ past. Ball isn’t the first player who’s experienced relative success in the league while also undershooting expectations, and he won’t be the last. He <em>could </em>still grow into an All-Star, but he’s not the transcendent talent we were led to believe he’d be.</p>
<h3>Lauri Markkanen, No. 7</h3>
<p>By the parameters of this series, Markkanen looked way more like a hit entering 2019-20. But then this season happened. Markkanen was used as more of a spot-up shooter than he’d been in the previous two seasons. His minutes dropped slightly, as did his scoring (18.7 to 14.7 per game), rebounding (9.0 to 6.3) and his three-point percentage (36.1% to 34.4%). And his field goal attempts were down considerably from inside the three point line all the way to three feet from the basket.</p>
<p>But Markkanen doesn’t qualify as a bust, either. He still averaged 14.7 points and 6.3 rebounds in less than 28 minutes per game. He’s a seven-footer who is still an above-average marksman given his size and position, and he’s still just 22. Markkanen might end up as a multi-time All-Star, so <a href="http://www.basketballinsiders.com/the-next-all-stars-central-division/" target="_blank" rel="noopener noreferrer">no need for too much alarm</a>. And expectations weren’t too high on him as of 2017. But he’s hasn’t established himself as much as the “hits” featured above.</p>
<h3>Frank Ntilikina, No. 8</h3>
<p>The Knicks were dead set on a point guard in 2017. They were reportedly down to Ntilikina and Smith Jr. – ironically, they now employ both. But where Smith Jr. started off strongly and tapered off, Ntilikina took time to ramp up. In fact, he’s still ramping. Ntilikina is a sneaky good defender whose offensive prowess continues to grow. He’s a high-IQ player who will require more polished offensive talent around him if he’s going to start on a contender. But ultimately, the jury is still out. Ntilikina hasn’t been nearly consistent enough to be deemed anything but an unfinished product. He flashes the ability to oversee the offense, remain aggressive on offense, create for others and (obviously) defend multiple positions at a very high level. He just hasn’t done it regularly. He’s still only 21, so there is still ample time for Ntilikina to fulfill all of his potential and then some.</p>
<p>Every draft class is interesting with its share of hits and misses. While analyzing how well players perform relative to past expectations feels unnecessary, it’s also really fun. And doing so with the 2017 draft class is no different – and it provides even more opportunity than most to examine the draft order really closely and embrace the “what ifs.&#8221;</p>
<p>2017 might not have brought us any new entries into the GOAT debate, but it certainly left us with plenty of other items to discuss.</p>
<p><!-- END THEIA POST SLIDER --></p>
													</div><!--mvp-post-add-main-->
													<div class="mvp-post-add-link">
														<a href="http://www.basketballinsiders.com/the-nba-draft-look-back-2017/" rel="bookmark"><span class="mvp-post-add-link-but">Continue Reading</span></a>
													</div><!--mvp-post-add-link-->
												</div><!--mvp-post-add-cont-->
											</div><!--mvp-post-add-body-->
										</div><!--mvp-post-add-story-->
																			<div class="mvp-post-add-story left relative">
											<div class="mvp-post-add-head left relative">
												<h3 class="mvp-post-cat left relative"><a class="mvp-post-cat-link" href="http://www.basketballinsiders.com/category/nba-news/"><span class="mvp-post-cat left">NBA</span></a></h3>
												<h1 class="mvp-post-title left">The NBA Draft Look-Back: 2016</h1>
																									<span class="mvp-post-excerpt left"><p>Spencer Davies goes back to take a look at the 2016 NBA Draft to see the hits, sleepers and misses from the class.</p>
</span>
																																					<div class="mvp-author-info-wrap left relative">
														<div class="mvp-author-info-thumb left relative">
															<img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/11/SpinHeadshot-80x80.png" width="46" height="46" alt="Spencer Davies" class="avatar avatar-46 wp-user-avatar wp-user-avatar-46 alignnone photo" />														</div><!--mvp-author-info-thumb-->
														<div class="mvp-author-info-text left relative">
															<div class="mvp-author-info-date left relative">
																<p>Published</p> <span class="mvp-post-date">3 days ago</span> <p>on</p> <span class="mvp-post-date">May 6, 2020</span>
															</div><!--mvp-author-info-date-->
															<div class="mvp-author-info-name left relative">
																<p>By</p> <span class="author-name"><a href="http://www.basketballinsiders.com/author/sdavies/" title="Posts by Spencer Davies" rel="author">Spencer Davies</a></span> <a href="https://twitter.com/SpinDavies" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a>
															</div><!--mvp-author-info-name-->
														</div><!--mvp-author-info-text-->
													</div><!--mvp-author-info-wrap-->
																							</div><!--mvp-post-add-head-->
											<div class="mvp-post-add-body left relative">
																																							<div class="mvp-post-add-img left relative">
															<img width="1000" height="600" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Brandon_Ingram_Pelicans_2019_AP_Smiling.jpg" class="attachment- size- wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Brandon_Ingram_Pelicans_2019_AP_Smiling.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Brandon_Ingram_Pelicans_2019_AP_Smiling-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Brandon_Ingram_Pelicans_2019_AP_Smiling-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Brandon_Ingram_Pelicans_2019_AP_Smiling-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Brandon_Ingram_Pelicans_2019_AP_Smiling-400x240.jpg 400w" sizes="(max-width: 1000px) 100vw, 1000px" />														</div><!--mvp-post-feat-img-->
																																																			<div class="mvp-post-add-cont left relative">
													<div class="mvp-post-add-main right relative">
														<p><!-- BEGIN THEIA POST SLIDER --></p>
<p>This week at Basketball Insiders, we’ve taken a trip back in time together. Since we haven’t seen any NBA action since mid-March, we’ve gone ahead to take a look at how drafts of the past have worked out.</p>
<p>The 2016 NBA Draft can be classified as “studs and duds,” with the duds almost outweighing the studs. It says something that its undrafted free agents &#8212; Fred VanVleet, Danuel House, Dorian Finney-Smith, Derrick Jones Jr. &#8212; have been more successful than most of the first-round crop. It’s also notable that some of these players have had success outside of the organization that originally drafted them. That’s why it’s hard to evaluate whether picks are good or bad. Is it due to the players themselves or the franchises who took them there? It’s a fine line to toe, so we’ve broken it down into four categories.</p>
<p><strong>A. The Hits</strong><br />
<strong>B. The Misses</strong><br />
<strong>C. The Sleepers</strong><br />
<strong>D. Jury Is Out</strong></p>
<p>So without further ado, a look at the class of 2016!</p>
<h3><b>The Hits</b></h3>
<h3>Ben Simmons, No. 1</h3>
<p>Well, not exactly right away. Simmons, as per Philadelphia 76ers first-round pick luck, had to miss the entirety of the 2016-17 campaign with a foot injury. He returned with a vengeance in his “rookie” second season &#8212; take that up with Donovan Mitchell and Utah Jazz faithful &#8212; and made an enormous impact as the Sixers finally got to see what waiting “The Process” out could look like when their pieces were healthy. Nobody expected Simmons to be a shooter, but the expectations placed on the 6-foot-10 Aussie have been tough to meet.</p>
<p>Once marveled over by his innate vision, poise in transition and size as a ball-handler, Simmons is no longer treated like the All-Star he truly is. It’s just easier to make jokes about his lack of threes, apparently. The debate over whether he and Joel Embiid can take that next step as championship-caliber teammates, however, is a question we’d all like the answer to.</p>
<h3>Brandon Ingram, No. 2</h3>
<p>Ingram is a good case study for staying patient with young prospects. At 22 years old and in his fourth season, he was just selected to the All-Star Game for the first time in his career. Would you have believed that if you were provided his statistics as a rookie? They’re not exactly pretty, nor was the situation in Los Angeles. Structure and player development can have a symbiotic relationship. Clearly, the environment was not conducive to growth back then. That doesn’t mean Ingram was completely faultless, though, and the following seasons were a major bounceback in shaping who he became elsewhere.</p>
<p>His length is quite problematic on both ends. He’s been letting it fly from deep at a career rate and is converting 38 percent of those, forcing the opposition to close out. Now a primary option with the New Orleans Pelicans, we’ll find out what he and the other promising youngsters are made of as this franchise moves forward</p>
<h3>Domantas Sabonis, No. 11</h3>
<p>Little did the Oklahoma City Thunder know that they had a future double-double machine just camping out on the perimeter as a spot-up guy. That’s why the general public was up in arms when Sabonis and Victor Oladipo were the pieces going back to the Indiana Pacers for superstar Paul George. Funny how we grade that trade in the present day now, isn’t it? Nate McMillan has utilized Sabonis as an elite, physical screen-and-roller that can rebound the heck out of the ball. The son of Arvydas earned his first All-Star honors this season, too, so Domantas’ best is likely still ahead of him.</p>
<h3>Jaylen Brown, No. 3</h3>
<p>It’s not normal for a team that was in the playoffs to have the third overall pick, but the Boston Celtics had this luxury for two straight seasons thanks to the Brooklyn Nets. It allowed the C’s to establish their cornerstone pieces moving forward, starting with Brown and then with Jayson Tatum the following year. While Brown received playing time in his rookie season, the focus was on learning behind the team’s young mainstays. Despite a surge in his second season alongside a first-year Tatum, both players hit a bump in the road during 2018-19. Fortunately for Boston, this current version of Brown is exactly what they’ve envisioned &#8212; aggressive, unafraid and gritty. As Tatum’s star begins to shine, his partner shouldn’t be too far behind. Danny Ainge oughta send a thank you card to Billy King for Boston’s two franchise faces.</p>
<h3><strong>Buddy Hield, No. 6</strong></h3>
<h3><strong>Jamal Murray, No. 7</strong></h3>
<p>Both of these guards are hits in the sense of producing big numbers and taking their games to new heights with each season. They should be considered solid picks at these positions, albeit not home runs. Hield was traded in the middle of his rookie season to the Sacramento Kings, where he’s blossomed as a top-tier volume scorer just getting into his prime. Murray has hovered around the same level player as he’s been the last few years, forever waiting for fewer passive nights and more attack-heavy outings in which the Blue Arrow can shine.</p>
<h3><b>The Misses</b></h3>
<h3>Dragan Bender, No. 4</h3>
<p>Often (incorrectly) compared to Kristaps Porzingis coming into the draft, Bender was ironically selected in the same slot as he was. The seven-foot Croatian big man was highly touted as the best prospect coming from overseas. In reality, he wasn’t even close to ready. He was too slow on his feet to keep up with faster wings and too small to guard players in the post. The shooting touch was supposed to be his most consistent quality, and even that portion of his game didn’t come through aside from a decent effort in year two. Sure, it didn’t help that the Phoenix Suns were a bottom-dweller – but that doesn’t mean Bender did himself any favors. He’s got one silver lining going for him &#8212; he’s 22 years old and there’s nowhere to go but up, as evidenced by a 23-point night for the Golden State Warriors before the league shut down.</p>
<h3>Kris Dunn, No. 5</h3>
<p>It’s really difficult to include Dunn on this list because he is a legitimate individual defender that can lock up a lot of talented guards and change momentum with just a few plays. In fact, he could be a real steal for a team looking for a specialist this offseason. His road is far from ending. That said, you can’t justify a top-five pick being a specialist &#8212; even if it was in a class scarce of upside.</p>
<h3>Marquese Chriss, No. 8</h3>
<p>The majority of what we’ve seen with Chriss is a well-below-average shooter that has a ton of athleticism&#8230; without the skills necessary to succeed consistently. However, an opportunity with the Warriors has given Chriss the stage to showcase what some hands-on learning and hard work can accomplish. We’ll see if his name gets removed off the “miss” list in the future. That’s a long way away though for the former eighth overall pick.</p>
<h3>Thon Maker, No. 10</h3>
<p>When the Milwaukee Bucks decided to select Maker with the 10th overall pick, most agreed that the South Sudanese center would be a raw prospect in need of major polishing. Those concerns were valid to this day, as he has yet to average 20 minutes per game. He just isn’t consistent enough to warrant valuable playing time. When you can’t stretch the floor and struggle with players that overpower you, it doesn’t help your case. Similar to Bender, he’s got age on his side. The Detroit Pistons have taken a less is more approach with Maker, leading to an uptick in efficiency as a decent backup big &#8212; not at all worthy of a top 10 selection.</p>
<h3>Georgios Papagiannis, No. 13</h3>
<p>Considering the slew of disappointments in this draft class, Papagiannis actually put up respectable production as a rookie with the Sacramento Kings&#8230; in 22 games&#8230; after the season was given up on. He played 16 more games with them afterward &#8212; never more than 16 minutes &#8212; before being waived at the 2018 trade deadline. Papagiannis would appear in exactly one NBA game for the Portland Trail Blazers following that. Currently, he is playing for Panathinaikos back home in Greece. So, in other words, thumbs *down* for a lottery pick.</p>
<h3><strong>Guerschon Yabusele, No. 16</strong></h3>
<h3><strong>Wade Baldwin, No. 17</strong></h3>
<p>Just because they were mid-round picks doesn’t exclude the Celtics and Grizzlies from their swings and misses on these two. Yabusele and Baldwin had made their fair share of noise in the G League, but that’s not enough. The former is in year four with no role and the clock ticking, while the latter is playing for Olympiacos in the Euroleague.</p>
<h3><b>Sleepers</b></h3>
<p><b>Malik Beasley, No. 19<br />
</b><b>DeAndre’ Bembry, No. 21<br />
</b><b>Furkan Korkmaz, No. 26<br />
Ivica Zubac, No. 32<br />
</b><b>Patrick McCaw, No. 38<br />
</b><b>Jake Layman, No. 47<br />
</b><b>Georges Niang, No. 50</b><b></b></p>
<h3>Pascal Siakam, No. 27</h3>
<p>The year-to-year rise of Siakam has been astounding. It’s the beauty of what can happen with a little time and a plan. He waited his turn, observed the players ahead of him and <a href="http://www.basketballinsiders.com/pascal-siakam-and-battle-tested-raptors-bench-full-of-promise/">starred in his role</a> off the bench. Eventually, that turned into a promotion to starter and the man they call Spicy P just took off from there. His determination to expand his game manifested itself into becoming Kawhi Leonard’s right-hand man en route to a Toronto Raptors championship. Now, he’s an All-Star, one of the top point forwards in the Eastern Conference and very well could be its best player in the near future. Shame on me for thinking he’d struggle to handle alpha status.</p>
<h3>Malcolm Brogdon, No. 36</h3>
<p>It’s not often that the class Rookie of the Year is considered a sleeper. A second-rounder had never won the prestigious award until Brogdon came along. As he did so well under Tony Bennett at Virginia, the upperclassman point guard proved to be a true floor general with an advanced feel for the game right from the jump in Milwaukee. He alternated backcourt roles in his first three seasons with the Bucks, punishing the opposition from deep and on the defensive end. He’s fought some injury issues here and there as well. In his debut season with the Indiana Pacers, we’ve seen more pick-and-roll wizardry from the talented guard with Sabonis. And though his shooting numbers have dipped noticeably, that’s probably an outlier. Indiana’s got a solid future with Brogdon running the show alongside a pair of All-Stars.</p>
<h3><b>Jury Is Still Out</b></h3>
<h3>Caris LeVert, No. 20</h3>
<p>Injury issues plummeted LeVert down to No. 20. He’s been plagued by a few of them here and there in the NBA, but none have stopped him from putting on the show he’s capable of. He’s one of those players that when he sees one shot go in, there’s no telling how far his hot hand will go. All you have to do is go back to his 51-point outburst in a comeback win back in early March. LeVert’s 6-foot-6 frame with a wide wingspan is perfect for the modern NBA. If he puts on a little more weight, the Nets could see him taking a giant step forward with Kyrie Irving and Kevin Durant leading the charge.</p>
<h3>DeJounte Murray, No. 29</h3>
<p>The San Antonio Spurs know how to draft. Murray was the first of two 29th overall picks that they’ve seen promise from, the other being Derrick White. Murray’s a stat-sheet stuffing, athletic, long pest of a player on both ends. Defensively, he doesn’t give you an inch to get by, nor does he make it easy for a clean pass anywhere. His hands are among the quickest in the league. The offensive portion of his game is slowly but surely coming back to him after a devastating ACL injury last season caused him to miss all of 2018-19, but there’s been no sense of fear whatsoever. He’s driving and dishing and knocking down his triples. Let’s just hope those injuries are behind Murray for good and he can continue to ascend the way he has.</p>
<h3>Jakob Poeltl, No. 9</h3>
<p>You know the saying “the best ability is availability?” That’s been Poeltl’s MO since he entered the league. Unfortunately, there’s little a traditional big man can offer if he doesn’t excel in more than one area. The former Ute is adept at protecting the rim and snagging rebounds and&#8230; that’s pretty much it. Even so, his advanced statistics point to a big improvement since his move to the Spurs. Not enough to be declared a hit, but surely not enough to be called a miss either. He’s in the middle for now.</p>
<p>The 2016 class is, for lack of a better word, a weird one to look back at. There’s plenty of first-round names that have succeeded, while others have flamed out of the league. Even the second-round picks were slim pickings if you want to go that far. But still, there are stars in the room and those are the standouts we love to watch play the game &#8212; and we could see more pan out if we’re lucky.</p>
<p><!-- END THEIA POST SLIDER --></p>
													</div><!--mvp-post-add-main-->
													<div class="mvp-post-add-link">
														<a href="http://www.basketballinsiders.com/the-nba-draft-look-back-2016/" rel="bookmark"><span class="mvp-post-add-link-but">Continue Reading</span></a>
													</div><!--mvp-post-add-link-->
												</div><!--mvp-post-add-cont-->
											</div><!--mvp-post-add-body-->
										</div><!--mvp-post-add-story-->
																			<div class="mvp-post-add-story left relative">
											<div class="mvp-post-add-head left relative">
												<h3 class="mvp-post-cat left relative"><a class="mvp-post-cat-link" href="http://www.basketballinsiders.com/category/nba-news/"><span class="mvp-post-cat left">NBA</span></a></h3>
												<h1 class="mvp-post-title left">The Next All-Stars: Southwest Division</h1>
																									<span class="mvp-post-excerpt left"><p>Shane Rhodes continues Basketball Insiders&#8217; The Next All-Stars series, taking a look at the potential first-time All-Stars from the Southwest division. </p>
</span>
																																					<div class="mvp-author-info-wrap left relative">
														<div class="mvp-author-info-thumb left relative">
															<img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2014/07/BI_Ball_Small-80x80.jpg" width="46" height="46" alt="Shane Rhodes" class="avatar avatar-46 wp-user-avatar wp-user-avatar-46 alignnone photo" />														</div><!--mvp-author-info-thumb-->
														<div class="mvp-author-info-text left relative">
															<div class="mvp-author-info-date left relative">
																<p>Published</p> <span class="mvp-post-date">4 days ago</span> <p>on</p> <span class="mvp-post-date">May 5, 2020</span>
															</div><!--mvp-author-info-date-->
															<div class="mvp-author-info-name left relative">
																<p>By</p> <span class="author-name"><a href="http://www.basketballinsiders.com/author/srhodes/" title="Posts by Shane Rhodes" rel="author">Shane Rhodes</a></span> <a href="" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a>
															</div><!--mvp-author-info-name-->
														</div><!--mvp-author-info-text-->
													</div><!--mvp-author-info-wrap-->
																							</div><!--mvp-post-add-head-->
											<div class="mvp-post-add-body left relative">
																																							<div class="mvp-post-add-img left relative">
															<img width="1000" height="600" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Zion_Williamson_Pelicans_2019_AP3-1.jpg" class="attachment- size- wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Zion_Williamson_Pelicans_2019_AP3-1.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Zion_Williamson_Pelicans_2019_AP3-1-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Zion_Williamson_Pelicans_2019_AP3-1-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Zion_Williamson_Pelicans_2019_AP3-1-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Zion_Williamson_Pelicans_2019_AP3-1-400x240.jpg 400w" sizes="(max-width: 1000px) 100vw, 1000px" />														</div><!--mvp-post-feat-img-->
																																																			<div class="mvp-post-add-cont left relative">
													<div class="mvp-post-add-main right relative">
														<p><!-- BEGIN THEIA POST SLIDER --></p>
<p><span style="font-weight: 400;">To make it to the NBA, to be considered among the world’s best at the sport of basketball, is quite the accomplishment. The dedication, talent and work ethic required to reach such a height is astronomical, and it’s what separates them from the everyday athlete.</span></p>
<p><span style="font-weight: 400;">But that feat alone doesn’t satisfy everyone. For some, the climb is endless, the journey to the top evergoing, with the ultimate goal to be considered among the best of the best: an All-Star.</span></p>
<p><span style="font-weight: 400;">Every year, players make their bid to be considered among the 24 best in the NBA. And, seemingly every year, more and more prove worthy of consideration. With that in mind, Basketball Insiders set out to identify the next crop of All-Stars in each division. </span></p>
<p><span style="font-weight: 400;">We’ve already looked at the </span><a href="http://www.basketballinsiders.com/the-next-all-stars-atlantic-division/"><span style="font-weight: 400;">Atlantic</span></a><span style="font-weight: 400;">, </span><a href="http://www.basketballinsiders.com/the-next-all-stars-central-division/"><span style="font-weight: 400;">Central</span></a><span style="font-weight: 400;">, </span><a href="http://www.basketballinsiders.com/the-next-all-stars-northwest-division/"><span style="font-weight: 400;">Northwest</span></a><span style="font-weight: 400;"> and </span><a href="http://www.basketballinsiders.com/the-next-all-stars-pacific-division/"><span style="font-weight: 400;">Pacific</span></a><span style="font-weight: 400;"> divisions. Today, we’ll look at the Southwest. Let’s get to it.  </span></p>
<h3><b>Zion Williamson — New Orleans Pelicans</b></h3>
<p><span style="font-weight: 400;">This one’s obvious, isn’t it?</span></p>
<p><span style="font-weight: 400;">Williamson hype-train has been running since his time in high school. Now, on the world’s greatest stage, he did everything he could to prove that, not only was that hype warranted, but that he belonged among the best of the NBA’s best.</span></p>
<p><span style="font-weight: 400;">So, let’s keep this short: despite the fact that he missed the first 44 games of the season, the promise Williamson showed upon his return to the court — 23.6 points, 6.8 rebounds and 2.2 assists while shooting 58.9 percent from the field and a blistering 46.2 percent from three — should have him representing the Pelicans at the midseason classic for years to come.</span></p>
<p><span style="font-weight: 400;">Had he been healthy to start the year, one could argue that Williamson would have already been ineligible for this list. Either way, don’t expect to see his name here next season.</span></p>
<h3><b>Ja Morant, Memphis Grizzlies</b></h3>
<p><span style="font-weight: 400;">Another future shoo-in, Morant took a Grizzlies squad that was supposed to be one of the worst in the league to the postseason’s doorstep. Prior to the league’s shutdown, and despite Williams’ return to the court, he was arguably a lock for Rookie of the Year as well.</span></p>
<p><span style="font-weight: 400;">Morant was comfortable with the NCAA-to-NBA transition from the jump; in 54 games, the 20-year-old posted 17.6 points, 3.5 rebounds and 6.5 assists per game. He was </span><a href="https://www.youtube.com/watch?v=SJvHeuCLJAs"><span style="font-weight: 400;">fearless</span></a><span style="font-weight: 400;">, looking to make something happen whenever he could. That energy, the excitement Morant can generate on any given night and on any given play, is exactly what the NBA All-Star Game is all about and, beyond the stats, it’s why he’ll find his way into the game sooner rather than later.</span></p>
<p><span style="font-weight: 400;">Like Williamson, don’t expect to see Morant’s name on this list for long.</span></p>
<h3><b>Dejounte Murray, San Antonio Spurs</b></h3>
<p><span style="font-weight: 400;">Murray’s 2019-20 line — 10.7 points, 5.8 rebounds and 4.1 assists — won’t blow anyone away. And, in a star-studded Western Conference, it would be difficult for anyone to break through into the All-Star Game.</span></p>
<p><span style="font-weight: 400;">But Murray certainly has the potential and, more importantly, the coming opportunity. </span></p>
<p><span style="font-weight: 400;">Murray hasn’t seen much growth as a player on the offense. But that’s not for lack of talent &#8212; the </span><span style="font-weight: 400;">Spurs have just never needed him to contribute that much on that end of the court.</span><span style="font-weight: 400;"> Even this season, his third, Murray managed just 9.3 shots per game and only 537 on the season, good for </span><a href="https://www.basketball-reference.com/leagues/NBA_2020_totals.html#totals_stats::fga"><span style="font-weight: 400;">120th in the NBA.</span></a><span style="font-weight: 400;"> But, with LaMarcus Aldridge heading into the last year of his deal and DeMar DeRozan a potential free agent (player option) next season, Murray is in line for a significantly larger role on offense. </span></p>
<p><span style="font-weight: 400;">The volume alone would give Murray’s production a major boost, which would make him an interesting case when considered alongside his defensive prowess. Murray certainly flashed some offensive ability at the University of Washington, where he averaged 16.1 points in his lone season with the Huskies, so it isn’t too much of a stretch to think he could do the same at the NBA level.</span></p>
<p><span style="font-weight: 400;">If Murray can take that step and do so efficiently — Murray shot 37.8 percent from three and managed a 50.7 percent effective field goal percentage — he would be hard to ignore once the selection process got underway. And, if he somehow managed to advance his offensive game to that of his defense? </span><span style="font-weight: 400;">Watch out.</span></p>
<h3><b>Tim Hardaway Jr., Dallas Mavericks</b></h3>
<p><span style="font-weight: 400;">Some may seriously question how Hardway, in a loaded Western Conference, could ever earn an All-Star nod. But it’s more probable than you may think.</span></p>
<p>Back in 2014, in the midst of the Atlanta Hawks<span style="font-weight: 400;">’ first </span>60-win season, Kyle Korver earned a reserve spot while he averaged only 12.1 points, 4.1 rebounds and 2.6 assists.</p>
<p>Of course, Korver also led the NBA in three-point percentage, knocking them down from behind the arc at a ridiculous 49.2 percent clip. That said, it<span style="font-weight: 400;">’s hard to deny </span>Hardaway<span style="font-weight: 400;">’s talent on offense, with comparable averages to Korver’s lone All-Star appearance, the historic three-point percentage notwithstanding.</span></p>
<p>Going back to 2016, his fourth season and the first in which he averaged more than 25 minutes per game, Hardaway has found no trouble dropping it in the bucket, posting 16.3 points per game on strong shooting numbers. Even this season, as the Mavericks’ third option to Luka Doncic and Kirstaps Porzingis, Hardaway managed 15.8 points per game and shot over 40 percent from three. A near-perfect complement to the Doncic-Porzingis duo, Hardaway should prove the beneficiary of the attention they draw on offense for years to come. And, as they improve (and draw even further attention), so too should Hardaway and his own numbers.</p>
<p>With that in mind, it wouldn<span style="font-weight: 400;">’t be unprecedented to see Hardaway earn a nod. He’ll need some help from his teammates, and maybe a bit of luck in regards to other All-Stars losing a step, but don’t be shocked if Hardaway’s is one of the many names under consideration come next season.</span></p>
<p><b>Robert Covington, Houston Rockets</b></p>
<p><span style="font-weight: 400;">Like Hardaway, Covington is going to need help to break into the mid-season classic.</span><span style="font-weight: 400;"> But, also like Hardaway, he’s set to thrive in a role behind the Rockets’ stars, James Harden and Russell Westbrook.</span></p>
<p><span style="font-weight: 400;">Covington has made a name for himself on the defensive side of the ball. But, in Houston, he’s staked his claim as one of the NBA’s biggest pests: in 14 games, <a href="https://www.basketball-reference.com/players/c/covinro01.html#pbp::none">and spending most of his time at center</a>, Covington totaled 35 blocks &#8212; an average of 2.5 per game that, over the course of the season, would place him second only to Hassan Whiteside’s 3.1.</span></p>
<p>Covington is 6-foot-7.</p>
<p>Even his season-long average of <em>just </em>1.3 blocks per game has him alone amongst the trees; <a href="https://www.basketball-reference.com/leagues/NBA_2020_per_game.html#per_game_stats::blk_per_g">every other player in the top-20</a>, save for Daniel Theis (6-foot-8) and Bam Adebayo (6-foot-9), is at 6-foot-10 or taller. Were he somehow able to sustain his ridiculous average with the Rockets over the course of the season, he would be just the fourth player ever 6-foot-7 or shorter to average at least two blocks per game.</p>
<p>And don<span style="font-weight: 400;">’t let that ridiculousness distract from Covington’s other qualities. In his time split between Houston and the Minnesota Timberwolves, Covington averaged 1.5 steals per game. He also posted 12.8 points per and shot 34.9 percent from three &#8212; and, with the number of wide-open shots he should see because of Harden and Westbrook, a la Hardaway with Doncic and Porzingis, expect both of those numbers to jump next season.</span></p>
<p>It can take a lot to reach All-Star status. The effort, drive and focus required to reach that next level is so great, not even the superstars of the NBA world could rest on their laurels. <span style="font-weight: 400;">But, almost every year, there seems to be a new crop of players that <em>have</em> put in the work, putting the league on notice and pushing themselves into that conversation.</span></p>
<p><span style="font-weight: 400;">From the Southwest? These may be the next guys to do just that next season.</span></p>
<p><!-- END THEIA POST SLIDER --></p>
													</div><!--mvp-post-add-main-->
													<div class="mvp-post-add-link">
														<a href="http://www.basketballinsiders.com/the-next-all-stars-southwest-division/" rel="bookmark"><span class="mvp-post-add-link-but">Continue Reading</span></a>
													</div><!--mvp-post-add-link-->
												</div><!--mvp-post-add-cont-->
											</div><!--mvp-post-add-body-->
										</div><!--mvp-post-add-story-->
																	</div><!--mvp-post-add-wrap-->
							</div><!--mvp-post-add-box-->
													</div><!--mvp-post-content-->
						</div><!--mvp-post-main-in-->
													<div id="mvp-side-wrap" class="left relative">
						<section id="mvp_ad_widget-17" class="mvp-side-widget mvp_ad_widget">			<div class="mvp-widget-ad left relative">
				<span class="mvp-ad-label">Advertisement</span>
				<!-- BasketballInsiders_300x250_ROS_ATF (responsive) -->
<div class="ad-tag" data-ad-name="BasketballInsiders_300x250_ROS_ATF" data-ad-size="auto" ></div>
<script src="//tags-cdn.deployads.com/a/basketballinsiders.com.js" async ></script>
<script>(deployads = window.deployads || []).push({});</script>			</div><!--mvp-widget-ad-->
		</section><section id="mvp_ad_widget-20" class="mvp-side-widget mvp_ad_widget">			<div class="mvp-widget-ad left relative">
				<span class="mvp-ad-label">Advertisement</span>
				<!-- Betway Ad expires 11/4/2020 -->
<center><a href="https://sports.betway.com/en/sports" title="Online Betting Site Betway" target="_blank">
<img border="0" src="http://basketballinsiders.com/ads/online%20betting%20site%20betway%20300x250.jpg" width="300" height="250" alt="Online Betting Site Betway"></a>
</center>
<!-- Betway Ad end-->			</div><!--mvp-widget-ad-->
		</section><section id="mvp_ad_widget-21" class="mvp-side-widget mvp_ad_widget">			<div class="mvp-widget-ad left relative">
				<span class="mvp-ad-label">Advertisement</span>
				<!-- NJ Ads expires 11/27/2020 -->
<center><a href="https://www.americancasinoguide.com/" title="American Casino Guide" target="_blank">
<img border="0" src="http://basketballinsiders.com/ads/american-casino-guide-logo_200x140.jpg" alt="American Casino Guide"></a>
</center>
<center><a href="https://www.njcasino.com/" title="NJ Casino" target="_blank">
<img border="0" src="http://basketballinsiders.com/ads/nj-casino_225x150.png" alt="NJ Casino"></a>
</center>
<center><a href="https://www.betnj.com/" title="NJ Casino" target="_blank">
<img border="0" src="http://basketballinsiders.com/ads/bet-nj-logo_200x140.jpg" alt="NJ Casino"></a>
</center>
<!-- NJ Ads end-->			</div><!--mvp-widget-ad-->
		</section><section id="text-45" class="mvp-side-widget widget_text"><div class="mvp-widget-home-head"><h4 class="mvp-widget-home-title"><span class="mvp-widget-home-title">NBA Team Salaries</span></h4></div>			<div class="textwidget"><div style=" float: left; width: 100%; height: 370px;">
<div style="text-align: center">
<table style="border: none;  width: 100%;" cellspacing="0" cellpadding="0">
<tr>
<td> <a href="http://www.basketballinsiders.com/atlanta-hawks-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_01.png" alt="Atlanta Hawks" ></a></td>
<td> <a href="http://www.basketballinsiders.com/boston-celtics-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_02.png" alt="Boston Celtics" ></a></td>
<td> <a href="http://www.basketballinsiders.com/brooklyn-nets-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_18.png" alt="Brooklyn Nets" ></a></td>
<td> <a href="http://www.basketballinsiders.com/charlotte-hornets-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_03.png" alt="Charlotte Hornets" ></a></td>
<td> <a href="http://www.basketballinsiders.com/chicago-bulls-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_04.png" alt="Chicago Bulls" ></a></td>
</tr>
<tr>
<td> <a href="http://www.basketballinsiders.com/cleveland-cavaliers-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_05.png" alt="Cleveland Cavaliers" ></a></td>
<td> <a href="http://www.basketballinsiders.com/dallas-mavericks-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_06.png" alt="Dallas Mavericks" ></a></td>
<td> <a href="http://www.basketballinsiders.com/denver-nuggets-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_07.png" alt="Denver Nuggets" ></a></td>
<td> <a href="http://www.basketballinsiders.com/detroit-pistons-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_08.png" alt="Detroit Pistons" ></a></td>
<td> <a href="http://www.basketballinsiders.com/golden-state-warriors-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_09.png" alt="Golden State Warriors" ></a></td>
</tr>
<tr>
<td> <a href="http://www.basketballinsiders.com/houston-rockets-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_10.png" alt="Houston Rockets" ></a></td>
<td> <a href="http://www.basketballinsiders.com/indiana-pacers-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_11.png" alt="Indiana Pacers" ></a></td>
<td> <a href="http://www.basketballinsiders.com/los-angeles-clippers-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_12.png" alt="Los Angeles Clippers" ></a></td>
<td> <a href="http://www.basketballinsiders.com/los-angeles-lakers-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_13.png" alt="Los Angeles Lakers" ></a></td>
<td> <a href="http://www.basketballinsiders.com/memphis-grizzlies-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_14.png" alt="Memphis Grizzlies" ></a></td>
</tr>
<tr>
<td> <a href="http://www.basketballinsiders.com/miami-heat-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_15.png" alt="Miami Heat" ></a></td>
<td> <a href="http://www.basketballinsiders.com/milwaukee-bucks-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_16.png" alt="Milwaukee Bucks" ></a></td>
<td> <a href="http://www.basketballinsiders.com/minnesota-timberwolves-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_17.png" alt="Minnesota Timberwolves" ></a></td>
<td> <a href="http://www.basketballinsiders.com/new-orleans-pelicans-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_19a.png" alt="New Orleans Pelicans" ></a></td>
<td> <a href="http://www.basketballinsiders.com/new-york-knicks-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_20.png" alt="New York Knicks" ></a></td>
</tr>
<tr>
<td> <a href="http://www.basketballinsiders.com/oklahoma-city-thunder-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_21.png" alt="Oklahoma City Thunder" ></a></td>
<td> <a href="http://www.basketballinsiders.com/orlando-magic-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_22.png" alt="Orlando Magic" ></a></td>
<td> <a href="http://www.basketballinsiders.com/philadelphia-76ers-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_23.png" alt="Philidelphia 76ers" ></a></td>
<td> <a href="http://www.basketballinsiders.com/phoenix-suns-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_24.png" alt="Phoenix Suns" ></a></td>
<td> <a href="http://www.basketballinsiders.com/portland-trail-blazers-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_25.png" alt="Portland Trail Blazers" ></a></td>
</tr>
<tr>
<td> <a href="http://www.basketballinsiders.com/sacramento-kings-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_26.png" alt="Sacramento Kings" ></a></td>
<td> <a href="http://www.basketballinsiders.com/san-antonio-spurs-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_27.png" alt="San Antonio Spurs" ></a></td>
<td> <a href="http://www.basketballinsiders.com/toronto-raptors-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_29.png" alt="Toronto Raptors" ></a></td>
<td> <a href="http://www.basketballinsiders.com/utah-jazz-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_31.png" alt="Utah Jazz" ></a></td>
<td> <a href="http://www.basketballinsiders.com/washington-wizards-team-salary" target="_blank" rel="noopener noreferrer"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_32.png" alt="Washington Wizards" ></a></td>
</tr>
</table>
</div>
</div>
</div>
		</section><section id="mvp_ad_widget-18" class="mvp-side-widget mvp_ad_widget">			<div class="mvp-widget-ad left relative">
				<span class="mvp-ad-label">Advertisement</span>
				<script src='https://www.googletagservices.com/tag/js/gpt.js'>
  googletag.pubads().definePassback('/12906217/aff.display.insiderssports/bannerad_300x250', [300, 250]).display();
</script>			</div><!--mvp-widget-ad-->
		</section><section id="custom_html-6" class="widget_text mvp-side-widget widget_custom_html"><div class="mvp-widget-home-head"><h4 class="mvp-widget-home-title"><span class="mvp-widget-home-title">CloseUp360</span></h4></div><div class="textwidget custom-html-widget"><div class="feedgrabbr_widget" id="fgid_19cbac95836de6d19da621a29"></div>
<script>if (typeof (fg_widgets) === "undefined") fg_widgets = new Array(); fg_widgets.push("fgid_19cbac95836de6d19da621a29");</script>
<script async src="https://www.feedgrabbr.com/widget/fgwidget.js"></script> 

</div></section><section id="custom_html-4" class="widget_text mvp-side-widget widget_custom_html"><div class="mvp-widget-home-head"><h4 class="mvp-widget-home-title"><span class="mvp-widget-home-title">Insiders On Twitter</span></h4></div><div class="textwidget custom-html-widget"><a class="twitter-timeline" data-height="450" href="https://twitter.com/stevekylerNBA/lists/our-team?ref_src=twsrc%5Etfw" data-chrome="noheader nofooter noborder"></a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></div></section><section id="custom_html-5" class="widget_text mvp-side-widget widget_custom_html"><div class="mvp-widget-home-head"><h4 class="mvp-widget-home-title"><span class="mvp-widget-home-title">NBA On Twitter</span></h4></div><div class="textwidget custom-html-widget"><a class="twitter-timeline" data-width="300" data-height="700" href="https://twitter.com/stevekylerNBA/lists/nba-news-2?ref_src=twsrc%5Etfw" data-chrome="noheader nofooter noborder"></a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></div></section>			</div><!--mvp-side-wrap-->											</div><!--mvp-post-main-out-->
				</div><!--mvp-post-main-->
							<div id="mvp-post-more-wrap" class="left relative">
					<h4 class="mvp-widget-home-title">
						<span class="mvp-widget-home-title">Trending Now</span>
					</h4>
					<ul class="mvp-post-more-list left relative">
													<a href="http://www.basketballinsiders.com/the-underrated-executives/" rel="bookmark">
							<li>
																	<div class="mvp-post-more-img left relative">
										<img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/01/Pat_Riley_HEAT_2016_AP_1-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/01/Pat_Riley_HEAT_2016_AP_1-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/01/Pat_Riley_HEAT_2016_AP_1-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/01/Pat_Riley_HEAT_2016_AP_1-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/01/Pat_Riley_HEAT_2016_AP_1-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/01/Pat_Riley_HEAT_2016_AP_1.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" />										<img width="80" height="80" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/01/Pat_Riley_HEAT_2016_AP_1-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/01/Pat_Riley_HEAT_2016_AP_1-80x80.jpg 80w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/01/Pat_Riley_HEAT_2016_AP_1-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																			</div><!--mvp-post-more-img-->
																<div class="mvp-post-more-text left relative">
									<div class="mvp-cat-date-wrap left relative">
										<span class="mvp-cd-cat left relative">NBA</span><span class="mvp-cd-date left relative">2 weeks ago</span>
									</div><!--mvp-cat-date-wrap-->
									<p>The Underrated Executives</p>
								</div><!--mvp-post-more-text-->
							</li>
							</a>
													<a href="http://www.basketballinsiders.com/the-next-all-stars-northwest-division/" rel="bookmark">
							<li>
																	<div class="mvp-post-more-img left relative">
										<img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Jamal_Murray_Nuggets_2019_AP-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Jamal_Murray_Nuggets_2019_AP-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Jamal_Murray_Nuggets_2019_AP-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Jamal_Murray_Nuggets_2019_AP-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Jamal_Murray_Nuggets_2019_AP-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Jamal_Murray_Nuggets_2019_AP.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" />										<img width="80" height="80" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Jamal_Murray_Nuggets_2019_AP-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Jamal_Murray_Nuggets_2019_AP-80x80.jpg 80w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Jamal_Murray_Nuggets_2019_AP-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																			</div><!--mvp-post-more-img-->
																<div class="mvp-post-more-text left relative">
									<div class="mvp-cat-date-wrap left relative">
										<span class="mvp-cd-cat left relative">NBA</span><span class="mvp-cd-date left relative">2 weeks ago</span>
									</div><!--mvp-cat-date-wrap-->
									<p>The Next All-Stars: Northwest Division</p>
								</div><!--mvp-post-more-text-->
							</li>
							</a>
													<a href="http://www.basketballinsiders.com/the-underrated-players-southwest-division/" rel="bookmark">
							<li>
																	<div class="mvp-post-more-img left relative">
										<img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/04/Jonas_Valanciunas_Grizzlies_2019_AP-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/04/Jonas_Valanciunas_Grizzlies_2019_AP-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/04/Jonas_Valanciunas_Grizzlies_2019_AP-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/04/Jonas_Valanciunas_Grizzlies_2019_AP-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/04/Jonas_Valanciunas_Grizzlies_2019_AP-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/04/Jonas_Valanciunas_Grizzlies_2019_AP.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" />										<img width="80" height="80" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/04/Jonas_Valanciunas_Grizzlies_2019_AP-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/04/Jonas_Valanciunas_Grizzlies_2019_AP-80x80.jpg 80w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/04/Jonas_Valanciunas_Grizzlies_2019_AP-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																			</div><!--mvp-post-more-img-->
																<div class="mvp-post-more-text left relative">
									<div class="mvp-cat-date-wrap left relative">
										<span class="mvp-cd-cat left relative">NBA</span><span class="mvp-cd-date left relative">1 week ago</span>
									</div><!--mvp-cat-date-wrap-->
									<p>The Underrated Players: Southwest Division</p>
								</div><!--mvp-post-more-text-->
							</li>
							</a>
													<a href="http://www.basketballinsiders.com/sources-nba-considering-disney-world-as-neutral-playing-site-to-restart-season/" rel="bookmark">
							<li>
																	<div class="mvp-post-more-img left relative">
										<img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" />										<img width="80" height="80" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-80x80.jpg 80w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Adam_Silver_NBA_2020_AP1-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																			</div><!--mvp-post-more-img-->
																<div class="mvp-post-more-text left relative">
									<div class="mvp-cat-date-wrap left relative">
										<span class="mvp-cd-cat left relative">Headlines</span><span class="mvp-cd-date left relative">1 week ago</span>
									</div><!--mvp-cat-date-wrap-->
									<p>Sources: NBA Considering Disney World as Neutral Playing Site to Restart Season</p>
								</div><!--mvp-post-more-text-->
							</li>
							</a>
											</ul>
				</div><!--mvp-post-more-wrap-->
						</div><!--mvp-main-box-->
		</div><!--mvp-article-cont-->
		</article><!--mvp-article-wrap-->
			</div><!--mvp-main-body-wrap-->
			<footer id="mvp-foot-wrap" class="left relative">
				<div id="mvp-foot-top" class="left relative">
					<div class="mvp-main-box">
						<div id="mvp-foot-logo" class="left relative">
															<a href="http://www.basketballinsiders.com/"><img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/LargeLogo_WithWhite300-1.png" alt="Basketball Insiders | NBA Rumors And Basketball News" data-rjs="2" /></a>
													</div><!--mvp-foot-logo-->
						<div id="mvp-foot-soc" class="left relative">
							<ul class="mvp-foot-soc-list left relative">
																	<li><a href="https://www.facebook.com/BasketballInsiders" target="_blank" class="fa fa-facebook fa-2"></a></li>
																									<li><a href="https://twitter.com/BBallInsiders" target="_blank" class="fa fa-twitter fa-2"></a></li>
																									<li><a href="http://www.pinterest.com/bballinsiders/" target="_blank" class="fa fa-pinterest-p fa-2"></a></li>
																									<li><a href="http://instagram.com/basketballinsiders" target="_blank" class="fa fa-instagram fa-2"></a></li>
																									<li><a href="https://plus.google.com/u/0/+Basketballinsiderscom/" target="_blank" class="fa fa-google-plus fa-2"></a></li>
																									<li><a href="https://www.youtube.com/user/BasketballInsiders" target="_blank" class="fa fa-youtube-play fa-2"></a></li>
																															</ul>
						</div><!--mvp-foot-soc-->
						<div id="mvp-foot-menu-wrap" class="left relative">
							<div id="mvp-foot-menu" class="left relative">
								<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-7340" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7340"><a href="http://www.basketballinsiders.com/the-latest-basketball-news/">NBA Trade Rumors</a></li>
<li id="menu-item-202" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-202"><a href="http://www.basketballinsiders.com/nbas-top-50-highest-paid-players/">NBA&#8217;s Top 50 Highest Paid Players</a></li>
<li id="menu-item-203" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-203"><a href="http://www.basketballinsiders.com/top-100-nba-draft-prospects/">Top 100 NBA Draft Prospects</a></li>
<li id="menu-item-199" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-199"><a href="http://www.basketballinsiders.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-200" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-200"><a href="http://www.basketballinsiders.com/terms-of-service/">Terms Of Service</a></li>
<li id="menu-item-201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-201"><a href="http://www.basketballinsiders.com/contact-us/">Contact Us</a></li>
</ul></div>							</div><!--mvp-foot-menu-->
						</div><!--mvp-foot-menu-wrap-->
					</div><!--mvp-main-box-->
				</div><!--mvp-foot-top-->
				<div id="mvp-foot-bot" class="left relative">
					<div class="mvp-main-box">
						<div id="mvp-foot-copy" class="left relative">
							<p>Copyright © 2018 Insiders Sports, Inc.</p>
						</div><!--mvp-foot-copy-->
					</div><!--mvp-main-box-->
				</div><!--mvp-foot-bot-->
			</footer>
		</div><!--mvp-site-main-->
	</div><!--mvp-site-wall-->
</div><!--mvp-site-->
<div class="mvp-fly-top back-to-top">
	<i class="fa fa-angle-up fa-3"></i>
</div><!--mvp-fly-top-->
<div class="mvp-fly-fade mvp-fly-but-click">
</div><!--mvp-fly-fade-->
<meta id="ba_s" property="options" content="" data-o="{&quot;tid&quot;:&quot;UA-46749583-1&quot;,&quot;co&quot;:&quot;auto&quot;,&quot;g&quot;:1074072168,&quot;s&quot;:6,&quot;a&quot;:0,&quot;d&quot;:{&quot;c&quot;:[3,&quot;NBA,NBA DAILY&quot;],&quot;a&quot;:[1,&quot;David Yapkowitz&quot;],&quot;t&quot;:[2,&quot;Main Page,NBA&quot;]}}" /><script type="text/javascript">(function(w, d, s, id) {
  w.PUBX=w.PUBX || {pub: "basketball_insiders", discover: false, lazy: true};
  var js, pjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id; js.async = true;
  js.src = "//main.pubexchange.com/loader.min.js";
  pjs.parentNode.insertBefore(js, pjs);
}(window, document, "script", "pubexchange-jssdk"));</script><style type="text/css">

	
	
	#sab_wrap{
		margin:0 auto;
					width:100%;
								height:50;
								background:;
					position: fixed;
					bottom:0px;;
							
  		left: 0;
  		right: 0;
  		z-index: 99999;
	}
	#sab_bar_opn{
		margin:0 auto;
		position: fixed;
		background:#000;
		color: #fff;
		padding: 5px;
		display: none;
					bottom:0px;;
				
		cursor: pointer;
	}
	
	#sab_elem{
		float: left;
		width: 3%;
		text-align: center;
		padding-top: 7px;

	}
	#sab_content{
		width: 95%;
		float: right;
		display: inline-block;
		text-align: center;
		margin-right:2%;
	}
	#sab_text{
					color: ;
				
			
					font-size: px;
								
		/*font-family: ;*/
		font-weight: normal;
		font-style: normal;
		margin: 0;
		padding: 0;
	}
	#sab_close_btn{
		cursor: pointer;
	}

</style>



	
<style>
#mvp-side-wrap,.mvp-feat1-right-wrap,.mvp-post-soc-wrap,.mvp-flex-side-wrap
</style>
		<div data-theiaStickySidebar-sidebarSelector='"#mvp-side-wrap,.mvp-feat1-right-wrap,.mvp-post-soc-wrap,.mvp-flex-side-wrap"'
		     data-theiaStickySidebar-options='{"containerSelector":"","additionalMarginTop":120,"additionalMarginBottom":20,"updateSidebarHeight":false,"minWidth":1004,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
		<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/theia-sticky-sidebar/js/ResizeSensor.js?ver=1.7.0'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/theia-sticky-sidebar/js/theia-sticky-sidebar.js?ver=1.7.0'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/theia-sticky-sidebar/js/main.js?ver=1.7.0'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/themes/zox-news/js/mvpcustom.js?ver=5.4.1'></script>
<script type='text/javascript'>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</script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/themes/zox-news/js/scripts.js?ver=5.4.1'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/themes/zox-news/js/retina.js?ver=5.4.1'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/themes/zox-news/js/flexslider.js?ver=5.4.1'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/themes/zox-news/js/jquery.infinitescroll.min.js?ver=5.4.1'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-includes/js/comment-reply.js?ver=5.4.1'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-includes/js/wp-embed.js?ver=5.4.1'></script>
<script async="async" type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.4'></script>

<!-- Begin comScore Tag -->
<script>document.write(unescape("%3Cscript src=\'" + (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js\' %3E%3C/script%3E"));</script>
<script>
  COMSCORE.beacon({
    c1:2,
    c2:6685975,
    c3:"",
    c4:"'.$_SERVER["SERVER_NAME"].$_SERVER["REQUEST_URI"].'",
    c5:"",
    c6:"",
    c15:""
  });
</script>
<noscript><img src="http://b.scorecardresearch.com/p?c1=2&c2=6685975&c3=&c4=&c5=&c6=&c15=&cj=1" /></noscript>
<!-- End comScore Tag -->

<!-- Start Alexa Certify Javascript -->
<script type="text/javascript">
_atrk_opts = { atrk_acct:"a0JVi1a8Dy00qI", domain:"footballinsiders.com",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://d31qbv1cthcecs.cloudfront.net/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=a0JVi1a8Dy00qI" style="display:none" height="1" width="1" alt="" /></noscript>
<!-- End Alexa Certify Javascript -->

<!-- Start Teads Javascript -->
<script type="text/javascript" class="teads" async="true" src="//a.teads.tv/page/69634/tag"></script>
<!-- End Teads Javascript -->
<link rel="stylesheet" href="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/themes/zox-news/css/nice-select.css">
<script src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/themes/zox-news/js/jquery.nice-select.js"></script>
<script lang="javascript" type="text/javascript">
    jQuery(document).ready(function() {
        jQuery('select').niceSelect();
      });
</script>
</body>
</html>