<!DOCTYPE html>
<html lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<head>
<meta charset="UTF-8" >
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />
<link rel="shortcut icon" href="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/SmallBallLogo.png" /><link rel="pingback" href="http://www.basketballinsiders.com/xmlrpc.php" />
<meta property="og:type" content="article" />
					<meta property="og:image" content="http://www.basketballinsiders.com/wp-content/uploads/2019/11/Buddy_Hield_Kings_2019_AP_November_25.jpg" />
		<meta name="twitter:image" content="http://www.basketballinsiders.com/wp-content/uploads/2019/11/Buddy_Hield_Kings_2019_AP_November_25.jpg" />
	<meta property="og:url" content="http://www.basketballinsiders.com/now-what-sacramento-kings/" />
<meta property="og:title" content="Now What? Sacramento Kings" />
<meta property="og:description" content="As the regular season nears the finish line, some teams have begun to examine the state of their franchise. The Sacramento Kings have some major decisions to make in the off-season, but there are also some bright spots that the organization will use as building blocks for their future." />
<meta name="twitter:card" content="summary">
<meta name="twitter:url" content="http://www.basketballinsiders.com/now-what-sacramento-kings/">
<meta name="twitter:title" content="Now What? Sacramento Kings">
<meta name="twitter:description" content="As the regular season nears the finish line, some teams have begun to examine the state of their franchise. The Sacramento Kings have some major decisions to make in the off-season, but there are also some bright spots that the organization will use as building blocks for their future.">
<title>Now What? Sacramento Kings | Basketball Insiders | NBA Rumors And Basketball News</title>

		<!-- All in One SEO 4.1.0.2 -->
		<meta name="description" content="As the regular season nears the finish line, some teams have begun to examine the state of their franchise. The Sacramento Kings have some major decisions to make in the off-season, but there are also some bright spots that the organization will use as building blocks for their future."/>
		<meta name="keywords" content="main page,sacramento kings" />
		<link rel="canonical" href="http://www.basketballinsiders.com/now-what-sacramento-kings/" />
		<meta property="og:site_name" content="Basketball Insiders | NBA Rumors And Basketball News |" />
		<meta property="og:type" content="article" />
		<meta property="og:title" content="Now What? Sacramento Kings | Basketball Insiders | NBA Rumors And Basketball News" />
		<meta property="og:description" content="As the regular season nears the finish line, some teams have begun to examine the state of their franchise. The Sacramento Kings have some major decisions to make in the off-season, but there are also some bright spots that the organization will use as building blocks for their future." />
		<meta property="og:url" content="http://www.basketballinsiders.com/now-what-sacramento-kings/" />
		<meta property="article:published_time" content="2021-05-02T13:30:37Z" />
		<meta property="article:modified_time" content="2021-05-02T10:36:51Z" />
		<meta name="twitter:card" content="summary" />
		<meta name="twitter:domain" content="www.basketballinsiders.com" />
		<meta name="twitter:title" content="Now What? Sacramento Kings | Basketball Insiders | NBA Rumors And Basketball News" />
		<meta name="twitter:description" content="As the regular season nears the finish line, some teams have begun to examine the state of their franchise. The Sacramento Kings have some major decisions to make in the off-season, but there are also some bright spots that the organization will use as building blocks for their future." />
		<script type="application/ld+json" class="aioseo-schema">
			{"@context":"https:\/\/schema.org","@graph":[{"@type":"WebSite","@id":"http:\/\/www.basketballinsiders.com\/#website","url":"http:\/\/www.basketballinsiders.com\/","name":"Basketball Insiders | NBA Rumors And Basketball News","publisher":{"@id":"http:\/\/www.basketballinsiders.com\/#organization"}},{"@type":"Organization","@id":"http:\/\/www.basketballinsiders.com\/#organization","name":"Basketball Insiders | NBA Rumors And Basketball News","url":"http:\/\/www.basketballinsiders.com\/"},{"@type":"BreadcrumbList","@id":"http:\/\/www.basketballinsiders.com\/now-what-sacramento-kings\/#breadcrumblist","itemListElement":[{"@type":"ListItem","@id":"http:\/\/www.basketballinsiders.com\/#listItem","position":"1","item":{"@id":"http:\/\/www.basketballinsiders.com\/#item","name":"Home","description":"Your complete source for all things basketball. NBA trade rumors, basketball news, NBA draft, NBA salaries and updated news and insight on every NBA team from some of of the best writers and voices covering basketball.","url":"http:\/\/www.basketballinsiders.com\/"},"nextItem":"http:\/\/www.basketballinsiders.com\/now-what-sacramento-kings\/#listItem"},{"@type":"ListItem","@id":"http:\/\/www.basketballinsiders.com\/now-what-sacramento-kings\/#listItem","position":"2","item":{"@id":"http:\/\/www.basketballinsiders.com\/now-what-sacramento-kings\/#item","name":"Now What? Sacramento Kings","description":"As the regular season nears the finish line, some teams have begun to examine the state of their franchise. The Sacramento Kings have some major decisions to make in the off-season, but there are also some bright spots that the organization will use as building blocks for their future.","url":"http:\/\/www.basketballinsiders.com\/now-what-sacramento-kings\/"},"previousItem":"http:\/\/www.basketballinsiders.com\/#listItem"}]},{"@type":"Person","@id":"http:\/\/www.basketballinsiders.com\/author\/csmith\/#author","url":"http:\/\/www.basketballinsiders.com\/author\/csmith\/","name":"Chad Smith","image":{"@type":"ImageObject","@id":"http:\/\/www.basketballinsiders.com\/now-what-sacramento-kings\/#authorImage","url":"http:\/\/www.basketballinsiders.com\/wp-content\/uploads\/2021\/01\/Headshot-White-scaled-e1611420999747.jpg","width":"96","height":"96","caption":"Chad Smith"}},{"@type":"WebPage","@id":"http:\/\/www.basketballinsiders.com\/now-what-sacramento-kings\/#webpage","url":"http:\/\/www.basketballinsiders.com\/now-what-sacramento-kings\/","name":"Now What? Sacramento Kings | Basketball Insiders | NBA Rumors And Basketball News","description":"As the regular season nears the finish line, some teams have begun to examine the state of their franchise. The Sacramento Kings have some major decisions to make in the off-season, but there are also some bright spots that the organization will use as building blocks for their future.","inLanguage":"en-US","isPartOf":{"@id":"http:\/\/www.basketballinsiders.com\/#website"},"breadcrumb":{"@id":"http:\/\/www.basketballinsiders.com\/now-what-sacramento-kings\/#breadcrumblist"},"author":"http:\/\/www.basketballinsiders.com\/now-what-sacramento-kings\/#author","creator":"http:\/\/www.basketballinsiders.com\/now-what-sacramento-kings\/#author","image":{"@type":"ImageObject","@id":"http:\/\/www.basketballinsiders.com\/#mainImage","url":"http:\/\/www.basketballinsiders.com\/wp-content\/uploads\/2019\/11\/Buddy_Hield_Kings_2019_AP_November_25.jpg","width":"1000","height":"600"},"primaryImageOfPage":{"@id":"http:\/\/www.basketballinsiders.com\/now-what-sacramento-kings\/#mainImage"},"datePublished":"2021-05-02T13:30:37-04:00","dateModified":"2021-05-02T10:36:51-04:00"},{"@type":"Article","@id":"http:\/\/www.basketballinsiders.com\/now-what-sacramento-kings\/#article","name":"Now What? Sacramento Kings | Basketball Insiders | NBA Rumors And Basketball News","description":"As the regular season nears the finish line, some teams have begun to examine the state of their franchise. The Sacramento Kings have some major decisions to make in the off-season, but there are also some bright spots that the organization will use as building blocks for their future.","headline":"Now What? Sacramento Kings","author":{"@id":"http:\/\/www.basketballinsiders.com\/author\/csmith\/#author"},"publisher":{"@id":"http:\/\/www.basketballinsiders.com\/#organization"},"datePublished":"2021-05-02T13:30:37-04:00","dateModified":"2021-05-02T10:36:51-04:00","commentCount":"1","articleSection":"NBA, NBA DAILY, Main Page, Sacramento Kings","mainEntityOfPage":{"@id":"http:\/\/www.basketballinsiders.com\/now-what-sacramento-kings\/#webpage"},"isPartOf":{"@id":"http:\/\/www.basketballinsiders.com\/now-what-sacramento-kings\/#webpage"},"image":{"@type":"ImageObject","@id":"http:\/\/www.basketballinsiders.com\/#articleImage","url":"http:\/\/www.basketballinsiders.com\/wp-content\/uploads\/2019\/11\/Buddy_Hield_Kings_2019_AP_November_25.jpg","width":"1000","height":"600"}}]}
		</script>
		<!-- All in One SEO -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Basketball Insiders | NBA Rumors And Basketball News &raquo; Feed" href="http://www.basketballinsiders.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Basketball Insiders | NBA Rumors And Basketball News &raquo; Comments Feed" href="http://www.basketballinsiders.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Basketball Insiders | NBA Rumors And Basketball News &raquo; Now What? Sacramento Kings Comments Feed" href="http://www.basketballinsiders.com/now-what-sacramento-kings/feed/" />
		<script type="text/javascript">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</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-includes/css/dist/block-library/style.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='bcct_style-css'  href='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/better-click-to-tweet/assets/css/styles.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='theiaPostSlider-css'  href='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/theia-post-slider/css/base.css?ver=1.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='theiaPostSlider-font-css'  href='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/theia-post-slider/fonts/style.css?ver=1.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-custom-style-css'  href='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/themes/zox-news/style.css?ver=5.7.1' type='text/css' media='all' />
<style id='mvp-custom-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='mvp-reset-css'  href='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/themes/zox-news/css/reset.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/themes/zox-news/font-awesome/css/font-awesome.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-fonts-css'  href='//fonts.googleapis.com/css?family=Advent+Pro%3A700%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese%7COpen+Sans%3A700%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese%7CAnton%3A400%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese%7COswald%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese%7COswald%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese%7CRoboto%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese%7CRoboto%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese%7CPT+Serif%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese%7COswald%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-media-queries-css'  href='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/themes/zox-news/css/media-queries.css?ver=5.7.1' type='text/css' media='all' />
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-includes/js/jquery/jquery.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-includes/js/jquery/jquery-migrate.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/sticky-ad-bar/js/sab_bar_script.js?ver=5.7.1' id='sab_bar_script1-js'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/sticky-ad-bar/js/jquery.cookie.js?ver=5.7.1' id='sab_bar_script2-js'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/theia-post-slider/js/balupton-history.js/jquery.history.js?ver=1.7.1' id='history.js-js'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/theia-post-slider/js/async.min.js?ver=25.11.2012' id='async.js-js'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/theia-post-slider/js/tps.js?ver=1.6.4' id='theiaPostSlider.js-js'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/theia-post-slider/js/tps-transition-slide.js?ver=1.6.4' id='theiaPostSlider-transition-slide.js-js'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/wp-infinite-scrolling/js/jquery.sifs.js?ver=5.7.1' id='jquery.sifs-js'></script>
<script type='text/javascript' id='wpifs-js-extra'>
/* <![CDATA[ */
var wpifs_options = {"container":".blog-layout1","post":".infinite-post","pagination":".navigation","next":".next-post-link a","loading":"<div style=\"text-align: center; font-weight: bold; font-size: 22px; color: #b5b5b5;\">Loading More Posts...<\/div>"};
/* ]]> */
</script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/wp-infinite-scrolling/js/wpifs.js?ver=5.7.1' id='wpifs-js'></script>
<!-- This site uses the Better Analytics plugin.  https://marketplace.digitalpoint.com/better-analytics.3354/item -->
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/better-analytics/js/loader.php?ver=1.2.6.js' ></script><link rel="https://api.w.org/" href="http://www.basketballinsiders.com/wp-json/" /><link rel="alternate" type="application/json" href="http://www.basketballinsiders.com/wp-json/wp/v2/posts/67418" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.basketballinsiders.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.basketballinsiders.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='http://www.basketballinsiders.com/?p=67418' />
<link rel="alternate" type="application/json+oembed" href="http://www.basketballinsiders.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.basketballinsiders.com%2Fnow-what-sacramento-kings%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.basketballinsiders.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.basketballinsiders.com%2Fnow-what-sacramento-kings%2F&#038;format=xml" />
<meta name="pubexchange:image" content="http://www.basketballinsiders.com/wp-content/uploads/2019/11/Buddy_Hield_Kings_2019_AP_November_25-300x180.jpg">
<meta name="pubexchange:title" content="Now What? Sacramento Kings">
        <style>
            .theiaPostSlider_nav.fontTheme ._title {
                line-height: 48px;
            }

            .theiaPostSlider_nav.fontTheme ._prev,
            .theiaPostSlider_nav.fontTheme ._next {
                font-size: 48px;
                color: #dd0000;
                line-height: 0;
            }

            .theiaPostSlider_nav.fontTheme ._prev:hover,
            .theiaPostSlider_nav.fontTheme ._next:hover {
                color: #ff2626;
            }

            .theiaPostSlider_nav.fontTheme ._disabled {
                color: #6d6d6d !important;
            }
        </style>
        
<!-- Twitter Cards Meta - V 2.5.4 -->
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@bballinsiders" />
<meta name="twitter:creator" content="@bballinsiders" />
<meta name="twitter:url" content="http://www.basketballinsiders.com/now-what-sacramento-kings/" />
<meta name="twitter:title" content="Now What? Sacramento Kings" />
<meta name="twitter:description" content="As the regular season nears the finish line, some teams have begun to examine the state of their franchise. The Sacramento Kings have some major decisions [...]" />
<meta name="twitter:image" content="http://www.basketballinsiders.com/wp-content/uploads/2019/11/Buddy_Hield_Kings_2019_AP_November_25.jpg" />
<!-- Twitter Cards Meta By WPDeveloper.net -->

<style id="tt-easy-google-font-styles" type="text/css">p { }
h1 { }
h2 { }
h3 { }
h4 { }
h5 { }
h6 { }
</style>
<!-- DFP Tags Start -->
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/1246049/BasketballInsiders_1x1', [1, 1], 'div-gpt-ad-1509057907764-1').addService(googletag.pubads());
    googletag.defineSlot('/1246049/BasketballInsiders_1x1_Passback', [1, 1], 'div-gpt-ad-1509057907764-2').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().enableVideoAds();
    googletag.companionAds().setRefreshUnfilledSlots(true);
    googletag.enableServices();
  });
</script>
<!-- DFP Tags End -->
<!-- Please add to the top of the head element —>

<script src="//tags-cdn.deployads.com/a/basketballinsiders.com.js" async ></script>

<!-- Start AIR.TV Viral -->
<script async src='https://embed.air.tv/v1/twoview_bootstrap.js?organization=b6V9NyTdRQGeWbnMmfnvwg'></script>
<!-- End AIR.TV Viral -->

<!-- Start Sharethrough Tag -->
<script type="text/javascript" src="//native.sharethrough.com/assets/sfp.js"></script>
<!-- End Sharethrough Tag -->
</head>
<body class="post-template-default single single-post postid-67418 single-format-standard">
	<div id="mvp-fly-wrap">
	<div id="mvp-fly-menu-top" class="left relative">
		<div class="mvp-fly-top-out left relative">
			<div class="mvp-fly-top-in">
				<div id="mvp-fly-logo" class="left relative">
											<a href="http://www.basketballinsiders.com/"><img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/LargeLogo_w30.png" alt="Basketball Insiders | NBA Rumors And Basketball News" data-rjs="2" /></a>
									</div><!--mvp-fly-logo-->
			</div><!--mvp-fly-top-in-->
			<div class="mvp-fly-but-wrap mvp-fly-but-menu mvp-fly-but-click">
				<span></span>
				<span></span>
				<span></span>
				<span></span>
			</div><!--mvp-fly-but-wrap-->
		</div><!--mvp-fly-top-out-->
	</div><!--mvp-fly-menu-top-->
	<div id="mvp-fly-menu-wrap">
		<nav class="mvp-fly-nav-menu left relative">
			<div class="menu-top-nav-container"><ul id="menu-top-nav" class="menu"><li id="menu-item-148" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-148"><a href="http://www.basketballinsiders.com/category/nba-news/">NBA News</a>
<ul class="sub-menu">
	<li id="menu-item-486" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-486"><a href="http://www.basketballinsiders.com/key-nba-dates/">Key NBA Dates – 2019-20</a></li>
	<li id="menu-item-10601" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10601"><a href="http://www.basketballinsiders.com/category/insiders-video/">Insiders Video</a></li>
	<li id="menu-item-17063" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17063"><a href="http://www.basketballinsiders.com/authors/">Our Team</a></li>
	<li id="menu-item-15328" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15328"><a href="http://www.basketballinsiders.com/contact-us/">Contact Us</a></li>
</ul>
</li>
<li id="menu-item-182" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-182"><a href="http://www.basketballinsiders.com/nba-salaries/">NBA Salary Cap &#8211; By Team</a></li>
<li id="menu-item-61325" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-61325"><a href="http://www.basketballinsiders.com/2019-20-nba-salary-cap-109-140-million/">2019-20 NBA Salary Cap – $109.140M</a></li>
<li id="menu-item-55120" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-55120"><a href="http://www.basketballinsiders.com/nba-salaries/nba-free-agents-2019-2020-2/">NBA Free Agents – 2019-2020</a></li>
<li id="menu-item-186" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-186"><a href="http://www.basketballinsiders.com/nba-news-sorted-by-team/">NBA News By Team</a></li>
<li id="menu-item-501" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-501"><a href="http://www.basketballinsiders.com/nba-trade-history/">NBA Trade History</a></li>
<li id="menu-item-2819" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2819"><a href="http://www.basketballinsiders.com/nba-salaries/nba-rookie-salary-scale-by-draft-year/">NBA Rookie Salary Scale</a></li>
<li id="menu-item-51042" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51042"><a href="http://www.basketballinsiders.com/top-100-nba-draft-prospects/">Top 100 NBA Draft Prospects</a></li>
<li id="menu-item-6571" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6571"><a href="http://www.basketballinsiders.com/tag/mock-drafts/">Mock Drafts</a></li>
<li id="menu-item-446" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-446"><a href="http://www.basketballinsiders.com/history-of-the-nba-draft-by-pick/">History of the NBA Draft – By Pick</a></li>
<li id="menu-item-467" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-467"><a href="http://www.basketballinsiders.com/history-of-the-nba-draft-by-team/">History of the NBA Draft – By Team</a></li>
</ul></div>		</nav>
	</div><!--mvp-fly-menu-wrap-->
	<div id="mvp-fly-soc-wrap">
		<span class="mvp-fly-soc-head">Connect with us</span>
		<ul class="mvp-fly-soc-list left relative">
							<li><a href="https://www.facebook.com/BasketballInsiders" target="_blank" class="fa fa-facebook fa-2"></a></li>
										<li><a href="https://twitter.com/BBallInsiders" target="_blank" class="fa fa-twitter fa-2"></a></li>
										<li><a href="http://www.pinterest.com/bballinsiders/" target="_blank" class="fa fa-pinterest-p fa-2"></a></li>
										<li><a href="http://instagram.com/basketballinsiders" target="_blank" class="fa fa-instagram fa-2"></a></li>
										<li><a href="https://plus.google.com/u/0/+Basketballinsiderscom/" target="_blank" class="fa fa-google-plus fa-2"></a></li>
										<li><a href="https://www.youtube.com/user/BasketballInsiders" target="_blank" class="fa fa-youtube-play fa-2"></a></li>
											</ul>
	</div><!--mvp-fly-soc-wrap-->
</div><!--mvp-fly-wrap-->	<div id="mvp-site" class="left relative">
		<div id="mvp-search-wrap">
			<div id="mvp-search-box">
				<form method="get" id="searchform" action="http://www.basketballinsiders.com/">
	<input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' />
	<input type="hidden" id="searchsubmit" value="Search" />
</form>			</div><!--mvp-search-box-->
			<div class="mvp-search-but-wrap mvp-search-click">
				<span></span>
				<span></span>
			</div><!--mvp-search-but-wrap-->
		</div><!--mvp-search-wrap-->
				<div id="mvp-site-wall" class="left relative">
											<div id="mvp-leader-wrap">
					<table border="0" width="100%" bgcolor="#000000" cellspacing="0" cellpadding="0">
	<tr>
		<td>

<p align="center">
<!-- BI_Homepage_MidLeader (responsive) -->
<div class="ad-tag" data-ad-name="BI_Homepage_Leaderboard_BTF"></div>
<script src="//tags-cdn.deployads.com/a/basketballinsiders.com.js" async ></script>
<script>(deployads = window.deployads || []).push({});</script>
</p>		
</td>
	</tr>
</table>				</div><!--mvp-leader-wrap-->
										<div id="mvp-site-main" class="left relative">
			<header id="mvp-main-head-wrap" class="left relative">
									<nav id="mvp-main-nav-wrap" class="left relative">
						<div id="mvp-main-nav-top" class="left relative">
							<div class="mvp-main-box">
								<div id="mvp-nav-top-wrap" class="left relative">
									<div class="mvp-nav-top-right-out left relative">
										<div class="mvp-nav-top-right-in">
											<div class="mvp-nav-top-cont left relative">
												<div class="mvp-nav-top-left-out relative">
													<div class="mvp-nav-top-left">
														<div class="mvp-nav-soc-wrap">
																															<a href="https://www.facebook.com/BasketballInsiders" target="_blank"><span class="mvp-nav-soc-but fa fa-facebook fa-2"></span></a>
																																														<a href="https://twitter.com/BBallInsiders" target="_blank"><span class="mvp-nav-soc-but fa fa-twitter fa-2"></span></a>
																																														<a href="http://instagram.com/basketballinsiders" target="_blank"><span class="mvp-nav-soc-but fa fa-instagram fa-2"></span></a>
																																														<a href="https://www.youtube.com/user/BasketballInsiders" target="_blank"><span class="mvp-nav-soc-but fa fa-youtube-play fa-2"></span></a>
																													</div><!--mvp-nav-soc-wrap-->
														<div class="mvp-fly-but-wrap mvp-fly-but-click left relative">
															<span></span>
															<span></span>
															<span></span>
															<span></span>
														</div><!--mvp-fly-but-wrap-->
													</div><!--mvp-nav-top-left-->
													<div class="mvp-nav-top-left-in">
														<div class="mvp-nav-top-mid left relative" itemscope itemtype="http://schema.org/Organization">
																															<a class="mvp-nav-logo-reg" itemprop="url" href="http://www.basketballinsiders.com/"><img itemprop="logo" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/LargeLogo_WithWhite200-1.png" alt="Basketball Insiders | NBA Rumors And Basketball News" data-rjs="2" /></a>
																																														<a class="mvp-nav-logo-small" href="http://www.basketballinsiders.com/"><img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/LargeLogo_w30.png" alt="Basketball Insiders | NBA Rumors And Basketball News" data-rjs="2" /></a>
																																														<h2 class="mvp-logo-title">Basketball Insiders | NBA Rumors And Basketball News</h2>
																																														<div class="mvp-drop-nav-title left">
																	<h4>Now What? Sacramento Kings</h4>
																</div><!--mvp-drop-nav-title-->
																													</div><!--mvp-nav-top-mid-->
													</div><!--mvp-nav-top-left-in-->
												</div><!--mvp-nav-top-left-out-->
											</div><!--mvp-nav-top-cont-->
										</div><!--mvp-nav-top-right-in-->
										<div class="mvp-nav-top-right">
																						<span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span>
										</div><!--mvp-nav-top-right-->
									</div><!--mvp-nav-top-right-out-->
								</div><!--mvp-nav-top-wrap-->
							</div><!--mvp-main-box-->
						</div><!--mvp-main-nav-top-->
						<div id="mvp-main-nav-bot" class="left relative">
							<div id="mvp-main-nav-bot-cont" class="left">
								<div class="mvp-main-box">
									<div id="mvp-nav-bot-wrap" class="left">
										<div class="mvp-nav-bot-right-out left">
											<div class="mvp-nav-bot-right-in">
												<div class="mvp-nav-bot-cont left">
													<div class="mvp-nav-bot-left-out">
														<div class="mvp-nav-bot-left left relative">
															<div class="mvp-fly-but-wrap mvp-fly-but-click left relative">
																<span></span>
																<span></span>
																<span></span>
																<span></span>
															</div><!--mvp-fly-but-wrap-->
														</div><!--mvp-nav-bot-left-->
														<div class="mvp-nav-bot-left-in">
															<div class="mvp-nav-menu left">
																<div class="menu-main-nav-container"><ul id="menu-main-nav" class="menu"><li id="menu-item-48819" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48819"><a href="http://www.basketballinsiders.com/category/basketball-headlines/nba-headlines/">NBA Headlines</a><div class="mvp-mega-dropdown"><div class="mvp-main-box"><ul class="mvp-mega-list"><li><a href="http://www.basketballinsiders.com/report-lamarcus-aldridge-to-retire/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2018/01/LaMarcus_Aldridge_Spurs_2018_AP-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2018/01/LaMarcus_Aldridge_Spurs_2018_AP-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2018/01/LaMarcus_Aldridge_Spurs_2018_AP-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2018/01/LaMarcus_Aldridge_Spurs_2018_AP-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2018/01/LaMarcus_Aldridge_Spurs_2018_AP-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2018/01/LaMarcus_Aldridge_Spurs_2018_AP.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>Report: LaMarcus Aldridge to Retire</p></a></li><li><a href="http://www.basketballinsiders.com/sources-jamal-murray-to-miss-rest-of-season-with-torn-left-acl/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Jamal_Murray_Nuggets_2019_AP-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Jamal_Murray_Nuggets_2019_AP-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Jamal_Murray_Nuggets_2019_AP-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Jamal_Murray_Nuggets_2019_AP-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Jamal_Murray_Nuggets_2019_AP-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Jamal_Murray_Nuggets_2019_AP.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>Sources: Jamal Murray to Miss Rest of Season with Torn Left ACL</p></a></li><li><a href="http://www.basketballinsiders.com/sources-james-wiseman-expected-to-miss-rest-of-season-with-torn-right-meniscus/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/James_Wiseman_Warriors_AP-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/James_Wiseman_Warriors_AP-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/James_Wiseman_Warriors_AP-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/James_Wiseman_Warriors_AP-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/James_Wiseman_Warriors_AP.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/James_Wiseman_Warriors_AP-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>Sources: James Wiseman Expected to Miss Rest of Season with Torn Right Meniscus</p></a></li><li><a href="http://www.basketballinsiders.com/report-patrick-beverley-out-three-to-four-weeks-with-left-hand-fracture/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Patrick_Beverley_Clippers_2019_AP2-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Patrick_Beverley_Clippers_2019_AP2-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Patrick_Beverley_Clippers_2019_AP2-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Patrick_Beverley_Clippers_2019_AP2-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Patrick_Beverley_Clippers_2019_AP2-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/12/Patrick_Beverley_Clippers_2019_AP2.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>Report: Patrick Beverley Out Three-to-Four Weeks with Left Hand Fracture</p></a></li><li><a href="http://www.basketballinsiders.com/report-victor-oladipo-out-indefinitely/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/Victor_Oladipo_Rockets_AP_2021_2-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/Victor_Oladipo_Rockets_AP_2021_2-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/Victor_Oladipo_Rockets_AP_2021_2-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/Victor_Oladipo_Rockets_AP_2021_2-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/Victor_Oladipo_Rockets_AP_2021_2.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/Victor_Oladipo_Rockets_AP_2021_2-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>Report: Victor Oladipo Out Indefinitely</p></a></li></ul></div></div></li>
<li id="menu-item-48820" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-48820"><a href="http://www.basketballinsiders.com/category/nba-news/">NBA News</a><div class="mvp-mega-dropdown"><div class="mvp-main-box"><ul class="mvp-mega-list"><li><a href="http://www.basketballinsiders.com/now-what-sacramento-kings/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/11/Buddy_Hield_Kings_2019_AP_November_25-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/11/Buddy_Hield_Kings_2019_AP_November_25-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/11/Buddy_Hield_Kings_2019_AP_November_25-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/11/Buddy_Hield_Kings_2019_AP_November_25-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/11/Buddy_Hield_Kings_2019_AP_November_25-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/11/Buddy_Hield_Kings_2019_AP_November_25.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>Now What? Sacramento Kings</p></a></li><li><a href="http://www.basketballinsiders.com/nba-daily-depth-fueling-washingtons-turnaround/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/Russell_Westbrook_Wizards_2021-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/Russell_Westbrook_Wizards_2021-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/Russell_Westbrook_Wizards_2021-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/Russell_Westbrook_Wizards_2021-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/Russell_Westbrook_Wizards_2021.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/Russell_Westbrook_Wizards_2021-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>NBA Daily: Depth Fueling Washington&#8217;s Turnaround</p></a></li><li><a href="http://www.basketballinsiders.com/kevin-knox-ii-needs-a-fresh-start/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2018/10/Kevin_Knox_Knicks_2018_AP4-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2018/10/Kevin_Knox_Knicks_2018_AP4-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2018/10/Kevin_Knox_Knicks_2018_AP4-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2018/10/Kevin_Knox_Knicks_2018_AP4-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2018/10/Kevin_Knox_Knicks_2018_AP4-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2018/10/Kevin_Knox_Knicks_2018_AP4.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>Kevin Knox II Needs A Fresh Start</p></a></li><li><a href="http://www.basketballinsiders.com/nba-am-now-what-oklahoma-city-thunder/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Shai_Gilgeous_Alexander_Thunder_2019_AP1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Shai_Gilgeous_Alexander_Thunder_2019_AP1-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Shai_Gilgeous_Alexander_Thunder_2019_AP1-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Shai_Gilgeous_Alexander_Thunder_2019_AP1-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Shai_Gilgeous_Alexander_Thunder_2019_AP1-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Shai_Gilgeous_Alexander_Thunder_2019_AP1.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>NBA AM: Now What? &#8211; Oklahoma City Thunder</p></a></li><li><a href="http://www.basketballinsiders.com/under-the-radar-rookies-who-have-impressed/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/04/Malachi-Flynn_Raptors_2021_AP-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/04/Malachi-Flynn_Raptors_2021_AP-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/04/Malachi-Flynn_Raptors_2021_AP-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/04/Malachi-Flynn_Raptors_2021_AP-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/04/Malachi-Flynn_Raptors_2021_AP.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/04/Malachi-Flynn_Raptors_2021_AP-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>Under The Radar Rookies Who Have Impressed</p></a></li></ul></div></div></li>
<li id="menu-item-60338" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60338"><a href="http://www.basketballinsiders.com/nba-salaries/nba-free-agents-2019-2020-2/">NBA Free Agents</a></li>
<li id="menu-item-48842" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48842"><a href="http://www.basketballinsiders.com/top-100-nba-draft-prospects/">Top 100 Draft Prospects</a></li>
<li id="menu-item-48844" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48844"><a href="http://www.basketballinsiders.com/category/nba-draft/mock-drafts/">Mock Drafts</a><div class="mvp-mega-dropdown"><div class="mvp-main-box"><ul class="mvp-mega-list"><li><a href="http://www.basketballinsiders.com/2020-nba-mock-draft-the-final-60-pick-mock/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/04/2020NBADraft-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/04/2020NBADraft-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/04/2020NBADraft-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/04/2020NBADraft-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/04/2020NBADraft.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/04/2020NBADraft-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>2020 NBA Mock Draft &#8211; The Final 60-Pick Mock</p></a></li><li><a href="http://www.basketballinsiders.com/2020-nba-mock-draft-first-round-08-21-2020/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/08/Draft_Haliburton_Edwards_Toppin-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/08/Draft_Haliburton_Edwards_Toppin-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/08/Draft_Haliburton_Edwards_Toppin-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/08/Draft_Haliburton_Edwards_Toppin-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/08/Draft_Haliburton_Edwards_Toppin.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/08/Draft_Haliburton_Edwards_Toppin-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>2020 NBA Mock Draft &#8211; First Round &#8211; 08/21/2020</p></a></li><li><a href="http://www.basketballinsiders.com/2019-nba-consensus-mock-draft-final/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/01/Draft_Williamson_Barrett_Morant-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/01/Draft_Williamson_Barrett_Morant-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/01/Draft_Williamson_Barrett_Morant-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/01/Draft_Williamson_Barrett_Morant-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/01/Draft_Williamson_Barrett_Morant-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/01/Draft_Williamson_Barrett_Morant.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>2019 NBA Consensus Mock Draft – Final</p></a></li><li><a href="http://www.basketballinsiders.com/nba-daily-60-pick-nba-mock-draft-6-18-2019/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Draft_Okpala_Hayes_Gafford-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Draft_Okpala_Hayes_Gafford-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Draft_Okpala_Hayes_Gafford-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Draft_Okpala_Hayes_Gafford-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Draft_Okpala_Hayes_Gafford-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Draft_Okpala_Hayes_Gafford.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>NBA Daily: 60-Pick Mock Draft &#8211; 6/18/2019</p></a></li><li><a href="http://www.basketballinsiders.com/2019-nba-consensus-mock-draft-ver-6-0/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/01/Draft_Williamson_Barrett_Morant-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/01/Draft_Williamson_Barrett_Morant-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/01/Draft_Williamson_Barrett_Morant-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/01/Draft_Williamson_Barrett_Morant-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/01/Draft_Williamson_Barrett_Morant-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/01/Draft_Williamson_Barrett_Morant.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>2019 NBA Consensus Mock Draft &#8211; Ver 6.0</p></a></li></ul></div></div></li>
<li id="menu-item-48823" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48823"><a href="http://www.basketballinsiders.com/category/insiders-podcast/">Insiders Podcast</a><div class="mvp-mega-dropdown"><div class="mvp-main-box"><ul class="mvp-mega-list"><li><a href="http://www.basketballinsiders.com/podcast-from-the-final-four-to-the-g-league-with-collin-terry/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_4-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_4-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_4-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_4-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_4-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_4.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>PODCAST: From The Final Four To The G-League With Collin Terry</p></a></li><li><a href="http://www.basketballinsiders.com/podcast-the-agent-life-with-daniel-poneman/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2015/06/BIThePodcast-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2015/06/BIThePodcast-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2015/06/BIThePodcast-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2015/06/BIThePodcast-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2015/06/BIThePodcast-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2015/06/BIThePodcast.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>PODCAST: The Agent Life With Daniel Poneman</p></a></li><li><a href="http://www.basketballinsiders.com/podcast-whos-got-next-with-jordan-fair/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_7-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_7-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_7-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_7-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_7-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_7.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>PODCAST: Who&#8217;s Got Next With Jordan Fair</p></a></li><li><a href="http://www.basketballinsiders.com/podcast-the-next-part-of-the-journey-with-xavier-silas/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_1-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_1-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_1-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_1-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_1.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>PODCAST: The Next Part Of The Journey With Xavier Silas</p></a></li><li><a href="http://www.basketballinsiders.com/podcast-catching-up-with-john-henson-the-pros-pro/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_5-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_5-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_5-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_5-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_5-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/Insiders_Podcast1000_5.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>PODCAST: Catching Up With John Henson, The Pro&#8217;s Pro</p></a></li></ul></div></div></li>
<li id="menu-item-67066" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-67066"><a href="http://www.basketballinsiders.com/nba-salaries/">NBA Team Salaries</a>
<ul class="sub-menu">
	<li id="menu-item-48838" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48838"><a href="http://www.basketballinsiders.com/nbas-top-50-highest-paid-players/">NBA&#8217;s Top 50 Highest Paid Players</a></li>
	<li id="menu-item-48834" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48834"><a href="http://www.basketballinsiders.com/nba-salaries/nba-rookie-salary-scale-by-draft-year/">NBA Rookie Salary Scale – By Draft Year</a></li>
	<li id="menu-item-48835" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48835"><a href="http://www.basketballinsiders.com/nba-salaries/nba-salary-cap-notes/">NBA Salary Cap Notes</a></li>
	<li id="menu-item-54315" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54315"><a href="http://www.basketballinsiders.com/nba-salaries/nba-free-agents-2018-2019/">NBA Free Agents – 2018-2019</a></li>
	<li id="menu-item-54320" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54320"><a href="http://www.basketballinsiders.com/nba-salaries/nba-free-agents-2019-2020-2/">NBA Free Agents – 2019-2020</a></li>
	<li id="menu-item-54321" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54321"><a href="http://www.basketballinsiders.com/nba-salaries/nba-free-agents-2020-2021/">NBA Free Agents – 2020-2021</a></li>
	<li id="menu-item-48868" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48868"><a href="http://www.basketballinsiders.com/nba-salaries/2015-16-nba-salary-cap-70-million/">2015-16 NBA Salary Cap – $70 Million</a></li>
	<li id="menu-item-48867" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48867"><a href="http://www.basketballinsiders.com/nba-salaries/2016-17-nba-salary-cap-94-143-million/">2016-17 NBA Salary Cap – $94.143 million</a></li>
	<li id="menu-item-48866" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48866"><a href="http://www.basketballinsiders.com/nba-salaries/2017-18-nba-salary-cap-99-093-million/">2017-18 NBA Salary Cap – $99.093 Million</a></li>
	<li id="menu-item-54377" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54377"><a href="http://www.basketballinsiders.com/nba-salaries/2018-19-nba-salary-cap-101-869-million/">2018-19 NBA Salary Cap – $101.869 Million</a></li>
	<li id="menu-item-60893" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-60893"><a href="http://www.basketballinsiders.com/2019-20-nba-salary-cap-109-140-million/">2019-20 NBA Salary Cap – $109.140 Million</a></li>
</ul>
</li>
<li id="menu-item-48824" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-48824"><a href="http://#">More</a>
<ul class="sub-menu">
	<li id="menu-item-48829" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48829"><a href="http://www.basketballinsiders.com/authors/">Our Team</a></li>
	<li id="menu-item-48822" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48822"><a href="http://www.basketballinsiders.com/category/nba-draft/">NBA Draft</a><div class="mvp-mega-dropdown"><div class="mvp-main-box"><ul class="mvp-mega-list"><li><a href="http://www.basketballinsiders.com/2020-nba-mock-draft-the-final-60-pick-mock/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/04/2020NBADraft-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/04/2020NBADraft-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/04/2020NBADraft-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/04/2020NBADraft-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/04/2020NBADraft.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/04/2020NBADraft-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>2020 NBA Mock Draft &#8211; The Final 60-Pick Mock</p></a></li><li><a href="http://www.basketballinsiders.com/2020-nba-mock-draft-first-round-08-21-2020/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/08/Draft_Haliburton_Edwards_Toppin-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/08/Draft_Haliburton_Edwards_Toppin-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/08/Draft_Haliburton_Edwards_Toppin-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/08/Draft_Haliburton_Edwards_Toppin-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/08/Draft_Haliburton_Edwards_Toppin.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/08/Draft_Haliburton_Edwards_Toppin-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>2020 NBA Mock Draft &#8211; First Round &#8211; 08/21/2020</p></a></li><li><a href="http://www.basketballinsiders.com/nba-announces-early-entry-candidates-for-2020-nba-draft/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/04/2020NBADraft-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/04/2020NBADraft-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/04/2020NBADraft-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/04/2020NBADraft-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/04/2020NBADraft.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/04/2020NBADraft-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>NBA ANNOUNCES EARLY ENTRY CANDIDATES FOR 2020 NBA DRAFT</p></a></li><li><a href="http://www.basketballinsiders.com/nba-daily-biggest-winners-on-draft-night/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Reddish-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Reddish-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Reddish-1000x600.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Reddish-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>NBA Daily: Biggest Winners On Draft Night</p></a></li><li><a href="http://www.basketballinsiders.com/2019-nba-draft-trade-recap/"><div class="mvp-mega-img"><img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Culver_Shake-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Culver_Shake-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Culver_Shake-300x179.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Culver_Shake-768x458.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Culver_Shake-1024x611.jpg 1024w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Culver_Shake-1000x600.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Culver_Shake-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/06/Culver_Shake.jpg 1250w" sizes="(max-width: 400px) 100vw, 400px" /></div><p>2019 NBA Draft Trade Recap</p></a></li></ul></div></div></li>
	<li id="menu-item-48839" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48839"><a href="http://www.basketballinsiders.com/history-of-the-nba-draft-by-team/">History of the NBA Draft – By Team</a></li>
	<li id="menu-item-48840" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48840"><a href="http://www.basketballinsiders.com/history-of-the-nba-draft-by-pick/">History of the NBA Draft – By Pick</a></li>
	<li id="menu-item-48827" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48827"><a href="http://www.basketballinsiders.com/nba-trade-history/">NBA Trade History</a></li>
	<li id="menu-item-48828" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48828"><a href="http://www.basketballinsiders.com/key-nba-dates/">Key NBA Dates – 2019-20</a></li>
	<li id="menu-item-48826" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48826"><a href="http://www.basketballinsiders.com/privacy-policy/">Privacy Policy</a></li>
	<li id="menu-item-48825" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48825"><a href="http://www.basketballinsiders.com/terms-of-service/">Terms Of Service</a></li>
	<li id="menu-item-48830" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48830"><a href="http://www.basketballinsiders.com/contact-us/">Contact Us</a></li>
</ul>
</li>
</ul></div>															</div><!--mvp-nav-menu-->
														</div><!--mvp-nav-bot-left-in-->
													</div><!--mvp-nav-bot-left-out-->
												</div><!--mvp-nav-bot-cont-->
											</div><!--mvp-nav-bot-right-in-->
											<div class="mvp-nav-bot-right left relative">
												<span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span>
											</div><!--mvp-nav-bot-right-->
										</div><!--mvp-nav-bot-right-out-->
									</div><!--mvp-nav-bot-wrap-->
								</div><!--mvp-main-nav-bot-cont-->
							</div><!--mvp-main-box-->
						</div><!--mvp-main-nav-bot-->
					</nav><!--mvp-main-nav-wrap-->
							</header><!--mvp-main-head-wrap-->
			
			<div id="mvp-main-body-wrap" class="left relative"><article id="mvp-article-wrap" itemscope itemtype="http://schema.org/NewsArticle">
			<meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="http://www.basketballinsiders.com/now-what-sacramento-kings/"/>
						<div id="mvp-article-cont" class="left relative">
			<div class="mvp-main-box">
				<div id="mvp-post-main" class="left relative">
										<header id="mvp-post-head" class="left relative">
						<h3 class="mvp-post-cat left relative"><a class="mvp-post-cat-link" href="http://www.basketballinsiders.com/category/nba-news/"><span class="mvp-post-cat left">NBA</span></a></h3>
						<h1 class="mvp-post-title left entry-title" itemprop="headline">Now What? Sacramento Kings</h1>
													<span class="mvp-post-excerpt left"><p>As the regular season nears the finish line, some teams have begun to examine the state of their franchise. The Sacramento Kings have some major decisions to make in the off-season, but there are also some bright spots that the organization will use as building blocks for their future.</p>
</span>
																			<div class="mvp-author-info-wrap left relative">
								<div class="mvp-author-info-thumb left relative">
									<img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/01/Headshot-White-scaled-e1611420999747-80x80.jpg" width="46" height="46" alt="Chad Smith" class="avatar avatar-46 wp-user-avatar wp-user-avatar-46 alignnone photo" />								</div><!--mvp-author-info-thumb-->
								<div class="mvp-author-info-text left relative">
									<div class="mvp-author-info-date left relative">
										<p>Published</p> <span class="mvp-post-date">14 hours ago</span> <p>on</p> <span class="mvp-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2021-05-02">May 2, 2021</time></span>
										<meta itemprop="dateModified" content="2021-05-02"/>
									</div><!--mvp-author-info-date-->
									<div class="mvp-author-info-name left relative" itemprop="author" itemscope itemtype="https://schema.org/Person">
										<p>By</p> <span class="author-name vcard fn author" itemprop="name"><a href="http://www.basketballinsiders.com/author/csmith/" title="Posts by Chad Smith" rel="author">Chad Smith</a></span> <a href="https://twitter.com/Chad200" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a>
									</div><!--mvp-author-info-name-->
								</div><!--mvp-author-info-text-->
							</div><!--mvp-author-info-wrap-->
											</header>
										<div class="mvp-post-main-out left relative">
						<div class="mvp-post-main-in">
							<div id="mvp-post-content" class="left relative">
																																																			<div id="mvp-video-embed-wrap" class="left relative">
											<div id="mvp-video-embed-cont" class="left relative">
												<span class="mvp-video-close fa fa-times" aria-hidden="true"></span>
												<div id="mvp-video-embed" class="left relative">
													<div class='s2nPlayer k-xN7MeEOC' data-type='float'></div><script type='text/javascript' src='//embed.sendtonews.com/player3/embedcode.js?fk=xN7MeEOC&cid=7380&offsetx=0&offsety=0&floatwidth=400&floatposition=bottom-right' data-type='s2nScript'></script>												</div><!--mvp-video-embed-->
											</div><!--mvp-video-embed-cont-->
										</div><!--mvp-video-embed-wrap-->
										<div class="mvp-post-img-hide" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
																						<meta itemprop="url" content="http://www.basketballinsiders.com/wp-content/uploads/2019/11/Buddy_Hield_Kings_2019_AP_November_25.jpg">
											<meta itemprop="width" content="1000">
											<meta itemprop="height" content="600">
										</div><!--mvp-post-img-hide-->
																																									<div id="mvp-content-wrap" class="left relative">
									<div class="mvp-post-soc-out right relative">
																																		<div class="mvp-post-soc-wrap left relative">
		<ul class="mvp-post-soc-list left relative">
			<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=http://www.basketballinsiders.com/now-what-sacramento-kings/&amp;t=Now What? Sacramento Kings', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
			<li class="mvp-post-soc-fb">
				<i class="fa fa-2 fa-facebook" aria-hidden="true"></i>
			</li>
			</a>
			<a href="#" onclick="window.open('http://twitter.com/share?text=Now What? Sacramento Kings -&amp;url=http://www.basketballinsiders.com/now-what-sacramento-kings/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
			<li class="mvp-post-soc-twit">
				<i class="fa fa-2 fa-twitter" aria-hidden="true"></i>
			</li>
			</a>
			<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=http://www.basketballinsiders.com/now-what-sacramento-kings/&amp;media=http://www.basketballinsiders.com/wp-content/uploads/2019/11/Buddy_Hield_Kings_2019_AP_November_25.jpg&amp;description=Now What? Sacramento Kings', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
			<li class="mvp-post-soc-pin">
				<i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i>
			</li>
			</a>
			<a href="mailto:?subject=Now What? Sacramento Kings&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: http://www.basketballinsiders.com/now-what-sacramento-kings/">
			<li class="mvp-post-soc-email">
				<i class="fa fa-2 fa-envelope" aria-hidden="true"></i>
			</li>
			</a>
												<a href="http://www.basketballinsiders.com/now-what-sacramento-kings/#comments">
					<li class="mvp-post-soc-com mvp-com-click">
						<i class="fa fa-2 fa-commenting" aria-hidden="true"></i>
					</li>
					</a>
									</ul>
	</div><!--mvp-post-soc-wrap-->
	<div id="mvp-soc-mob-wrap">
		<div class="mvp-soc-mob-out left relative">
			<div class="mvp-soc-mob-in">
				<div class="mvp-soc-mob-left left relative">
					<ul class="mvp-soc-mob-list left relative">
						<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=http://www.basketballinsiders.com/now-what-sacramento-kings/&amp;t=Now What? Sacramento Kings', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
						<li class="mvp-soc-mob-fb">
							<i class="fa fa-facebook" aria-hidden="true"></i><span class="mvp-soc-mob-fb">Share</span>
						</li>
						</a>
						<a href="#" onclick="window.open('http://twitter.com/share?text=Now What? Sacramento Kings -&amp;url=http://www.basketballinsiders.com/now-what-sacramento-kings/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
						<li class="mvp-soc-mob-twit">
							<i class="fa fa-twitter" aria-hidden="true"></i><span class="mvp-soc-mob-fb">Tweet</span>
						</li>
						</a>
						<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=http://www.basketballinsiders.com/now-what-sacramento-kings/&amp;media=http://www.basketballinsiders.com/wp-content/uploads/2019/11/Buddy_Hield_Kings_2019_AP_November_25.jpg&amp;description=Now What? Sacramento Kings', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
						<li class="mvp-soc-mob-pin">
							<i class="fa fa-pinterest-p" aria-hidden="true"></i>
						</li>
						</a>
						<a href="whatsapp://send?text=Now What? Sacramento Kings http://www.basketballinsiders.com/now-what-sacramento-kings/"><div class="whatsapp-share"><span class="whatsapp-but1">
						<li class="mvp-soc-mob-what">
							<i class="fa fa-whatsapp" aria-hidden="true"></i>
						</li>
						</a>
						<a href="mailto:?subject=Now What? Sacramento Kings&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: http://www.basketballinsiders.com/now-what-sacramento-kings/">
						<li class="mvp-soc-mob-email">
							<i class="fa fa-envelope-o" aria-hidden="true"></i>
						</li>
						</a>
																					<a href="http://www.basketballinsiders.com/now-what-sacramento-kings/#comments">
								<li class="mvp-soc-mob-com mvp-com-click">
									<i class="fa fa-comment-o" aria-hidden="true"></i>
								</li>
								</a>
																		</ul>
				</div><!--mvp-soc-mob-left-->
			</div><!--mvp-soc-mob-in-->
			<div class="mvp-soc-mob-right left relative">
				<i class="fa fa-ellipsis-h" aria-hidden="true"></i>
			</div><!--mvp-soc-mob-right-->
		</div><!--mvp-soc-mob-out-->
	</div><!--mvp-soc-mob-wrap-->
																															<div class="mvp-post-soc-in">
											<div id="mvp-content-body" class="left relative">
												<div id="mvp-content-body-top" class=left relative">
																																							<div id="mvp-content-main" class="left relative">
														<p><!-- BEGIN THEIA POST SLIDER --></p>
<p>The Sacramento Kings have never really had high expectations entering a season. The last time the Kings were in the playoffs, Rick Adelman guided them to 44 wins during the 2005-06 season. That team was led by Mike Bibby, Brad Miller, Peja Stojakovic and Metta World Peace. The face of the franchise now is De’Aaron Fox, who was just eight years old the last time this team played in the postseason.</p>
<p>The last 15 years have been a wild ride, but there may finally be light at the end of the tunnel. Most of that depends on how the off-season goes. The Kings have just nine games remaining on their schedule, with a trip to Dallas up next.</p>
<p>Sacramento has won just four of their last 16 games, which began with a nine-game losing streak and a 49-point blowout at the hands of the Utah Jazz last Wednesday. They did follow up that game by beating the Los Angeles Lakers on their home floor to spoil LeBron James&#8217; return after missing 20 games. This came without the help of their star point guard. Last Friday the team announced that Fox would miss at least the next 10-14 days due to health and safety protocols.</p>
<p>The 12th-seeded Kings are currently 5.5 games out of the final spot in the Play-In Tournament, on the brink of elimination. In addition to Fox missing time, Sacramento has been without Harrison Barnes and Marvin Bagley III over this stretch as they continue to deal with injuries. Bagley made his return on Friday but this is still a very young team without much veteran experience to help guide them.</p>
<p>With their season seemingly headed for the finish line, it is important to get a gauge on where this team is at. What changes are likely coming in the days ahead? Where do they need to improve in the offseason? What is working and what needs to be fixed? The answers to these questions can be found below.</p>
<h3><strong>Strengths</strong></h3>
<p>Despite their lack of collective talent, the Kings do have a young, All-Star-caliber point guard that should be the face of their franchise for years to come. Fox has elevated his game this season in a multitude of areas. The former Kentucky Wildcat is averaging career-highs in points (25.2 per game) and field goal percentage. His shot-making and ability to get to the rim will give even the strongest defenses serious trouble. Fox&#8217;s scoring has increased but he is also trusting his teammates more, and distributing the ball before the double-team can get to him.</p>
<p>Sacramento also found a real gem in Tyrese Haliburton. The Kings stole the Iowa State guard with the 12th pick in the 2020 NBA Draft, and he has truly been a bright spot for this organization. With Fox being 23 years old and Haliburton just turning 21, this backcourt duo gives Sacramento something special to build around going forward.</p>
<blockquote class="twitter-tweet">
<p dir="ltr" lang="en">Tyrese Haliburton since De’Aaron Fox went out:</p>
<p>23 PTS | 10 AST | 4 3PT<br />
13 PTS | 8 AST | 1 3PT<br />
14 PTS | 10 AST | 2 3PT<br />
24 PTS | 8 AST | 2 3PT <a href="https://t.co/czGwqKH79q">pic.twitter.com/czGwqKH79q</a></p>
<p>— StatMuse (@statmuse) <a href="https://twitter.com/statmuse/status/1388357908446937091?ref_src=twsrc%5Etfw">May 1, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>The Kings also rank fifth in terms of field goal percentage as a team this season. This is due to them getting quality shots by moving the ball, instead of relying heavily on isolation plays. Despite their youth, the Kings don&#8217;t turn the ball over much, <a href="https://www.nba.com/stats/teams/traditional/?sort=TOV&amp;dir=-1" target="_blank" rel="noopener">ranking ninth-best</a> in the league in that category.</p>
<h3><strong>Weaknesses</strong></h3>
<p>Luke Walton is finishing up his second season as head coach and the results have not been great. Walton&#8217;s Los Angeles Lakers teams increased their win totals each season under his tutelage, but that has not been the case in Sacramento. The Kings have suffered the same type of late-game collapses and struggled with in-game adjustments with Walton at the helm.</p>
<p>The Kings have gone through ten different coaches since their last playoff game. Whether or not the organization decides another coaching change is in order, there is still much more work to do. One other area they must improve is their team defense. This season they rank dead last in both defensive rating and opponents scoring. They were in the bottom third in those same categories last season.</p>
<p>The last time Sacramento ranked better than 20th in defensive rating was the 2005-06 season; the last time they made the playoffs. That is not just a coincidence. If they want to turn this ship around, they are going to have to start playing solid defense.</p>
<p>Other weaknesses that need to be addressed include free-throw shooting and three-point shooting as a unit. While Buddy Hield has been one of the best shooters from distance this season, the team as a whole has struggled. Sacramento shoots 22.7 free throws per game, which is the seventh-most in the league. The problem is, they are hitting just 74.6 percent of those, <a href="https://www.nba.com/stats/teams/traditional/?sort=FT_PCT&amp;dir=-1" target="_blank" rel="noopener">which ranks 25th</a>. Many of their close games have been decided because of poor shooting from the charity stripe.</p>
<h3><strong>Opportunities</strong></h3>
<p>The future still looks bright for the Kings, as they have the <a href="https://www.basketball-reference.com/contracts/SAC.html" target="_blank" rel="noopener">majority of their core under contract through at least the next couple of seasons</a>. Fox signed a multi-year extension before the season and is under contract through the 2025-26 season. Barnes is signed on through the 2022-23 season and Hield&#8217;s contract goes a year longer than that. Haliburton has three more years on his rookie contract and the team has some options on a few other guys.</p>
<p>As far as the draft goes, the Kings do have all of their own first-round picks to use over the next seven years. Should they get a little bit of luck in the Draft Lottery, a top-four selection could land them Cade Cunningham, Evan Mobley, Jalen Suggs or Jalen Green. A talent like Mobley would certainly fit right in with this young group and really allow them the opportunity to blossom together.</p>
<p>There will be plenty of opportunities for guys to continue to grow and prove themselves. This is a very young team with nine players having less than five years of experience. With some added veterans, additional talent and a possible coaching change on the horizon, the Kings should be able to improve next season and possibly push their way into the postseason.</p>
<h3><strong>Threats</strong></h3>
<p>The biggest threat facing this team going forward will be what happens to their core of big men. Richaun Holmes and Hassan Whiteside are both hitting free agency, and while Whiteside probably won&#8217;t be a huge loss, the team desperately needs to bring back Holmes. The former Bowling Green big man has had a career year in Sacramento, increasing his numbers in nearly every statistical category. His rebounding has been crucial for this team, <a href="https://www.nba.com/stats/teams/traditional/?sort=REB&amp;dir=-1" target="_blank" rel="noopener">which currently ranks dead last in hitting the glass</a>.</p>
<p>Since Sacramento signed Holmes to a two-year deal in 2019, they do not have full bird rights. The Kings don&#8217;t have cap space so the maximum deal they could offer him would be around $43 million over the next four seasons. That may not be enough to keep the talented big man, although he has carved himself a nice role with this team.</p>
<p>The bigger story might be what happens with Bagley, who will be a free agent after next season. The second overall pick in the 2018 draft is averaging career-lows this season and has only played in 38 games after missing the last six weeks with a hand injury. Bagley is eligible for a rookie-scale extension before next season, but James Ham of NBC Sports Bay Area believes his time in Sacramento will soon be coming to an end.</p>
<blockquote class="twitter-tweet">
<p dir="ltr" lang="en">.<a href="https://twitter.com/James_HamNBCS?ref_src=twsrc%5Etfw">@james_hamNBCS</a> says it&#8217;s very possible Bagley will not be back with the Kings next season <a href="https://t.co/UoDq56yS80">pic.twitter.com/UoDq56yS80</a></p>
<p>— Kings on NBCS (@NBCSKings) <a href="https://twitter.com/NBCSKings/status/1386497803531153410?ref_src=twsrc%5Etfw">April 26, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>Bagley may just need a change of scenery to get his career back on track. The Kings will have a handful of games to showcase him to other interested teams as the regular season comes to a close. The organization did sign Chimezie Metu and Damian Jones to multi-year deals and could always look elsewhere, but retaining Holmes should be a major priority in the offseason.</p>
<p><!-- END THEIA POST SLIDER --></p>
																											</div><!--mvp-content-main-->
													<div id="mvp-content-bot" class="left">
																												<div class="mvp-post-tags">
															<span class="mvp-post-tags-header">Related Topics:</span><span itemprop="keywords"><a href="http://www.basketballinsiders.com/tag/main-page/" rel="tag">Main Page</a><a href="http://www.basketballinsiders.com/tag/sacramento-kings/" rel="tag">Sacramento Kings</a></span>
														</div><!--mvp-post-tags-->
														<div class="posts-nav-link">
																													</div><!--posts-nav-link-->
																													<div id="mvp-prev-next-wrap" class="left relative">
																																																	<div class="mvp-prev-post-wrap left relative">
																		<a href="http://www.basketballinsiders.com/nba-daily-depth-fueling-washingtons-turnaround/" rel="bookmark">
																		<div class="mvp-prev-next-cont left relative">
																			<div class="mvp-prev-cont-out right relative">
																				<span class="mvp-prev-arr fa fa-chevron-left left"></span>
																				<div class="mvp-prev-cont-in">
																					<div class="mvp-prev-next-text left relative">
																						<span class="mvp-prev-next-label left relative">Don&#039;t Miss</span>
																						<p>NBA Daily: Depth Fueling Washington&#8217;s Turnaround</p>
																					</div><!--mvp-prev-next-text-->
																				</div><!--mvp-prev-cont-in-->
																			</div><!--mvp-prev-cont-out-->
																		</div><!--mvp-prev-next-cont-->
																		</a>
																	</div><!--mvp-prev-post-wrap-->
																															</div><!--mvp-prev-next-wrap-->
																																											<div id="mvp-author-box-wrap" class="left relative">
																<div class="mvp-author-box-out right relative">
																	<div id="mvp-author-box-img" class="left relative">
																		<img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/01/Headshot-White-scaled-e1611420999747-80x80.jpg" width="60" height="60" alt="Chad Smith" class="avatar avatar-60 wp-user-avatar wp-user-avatar-60 alignnone photo" />																	</div><!--mvp-author-box-img-->
																	<div class="mvp-author-box-in">
																		<div id="mvp-author-box-head" class="left relative">
																			<span class="mvp-author-box-name left relative"><a href="http://www.basketballinsiders.com/author/csmith/" title="Posts by Chad Smith" rel="author">Chad Smith</a></span>
																			<div id="mvp-author-box-soc-wrap" class="left relative">
																																																																																	<a href="https://twitter.com/Chad200" alt="Twitter" target="_blank"><span class="mvp-author-box-soc fa fa-twitter-square fa-2"></span></a>
																																																																																																																							</div><!--mvp-author-box-soc-wrap-->
																		</div><!--mvp-author-box-head-->
																	</div><!--mvp-author-box-in-->
																</div><!--mvp-author-box-out-->
																<div id="mvp-author-box-text" class="left relative">
																	<p>Basketball Insiders contributor based in Indianapolis.</p>
																</div><!--mvp-author-box-text-->
															</div><!--mvp-author-box-wrap-->
																												<div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
															<div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
																																	<img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/LargeLogo_WithWhite200-1.png"/>
																	<meta itemprop="url" content="http://www.basketballinsiders.com/wp-content/uploads/2017/08/LargeLogo_WithWhite200-1.png">
																															</div><!--mvp-org-logo-->
															<meta itemprop="name" content="Basketball Insiders | NBA Rumors And Basketball News">
														</div><!--mvp-org-wrap-->
													</div><!--mvp-content-bot-->
												</div><!--mvp-content-body-top-->
												<div class="mvp-cont-read-wrap">
																																								<div id="mvp-post-bot-ad" class="left relative">
															<span class="mvp-ad-label">Advertisement</span>
															<!-- Rev Content Start -->
<div id="rcjsload_b16eff"></div>
<script type="text/javascript">
(function() {
var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);
var rcel = document.createElement("script");
rcel.id = 'rc_' + Math.floor(Math.random() * 1000);
rcel.type = 'text/javascript';
rcel.src = "http://trends.revcontent.com/serve.js.php?w=1750&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth)+"&referer="+referer;
rcel.async = true;
var rcds = document.getElementById("rcjsload_b16eff"); rcds.appendChild(rcel);
})();
</script>
<!-- Rev Content End -->
<br><br>
<!-- BI_Homepage_Leaderboard_BTF (responsive) -->
<div class="ad-tag" data-ad-name="BI_Homepage_Leaderboard_BTF" data-ad-size="auto" ></div>
<script src="//tags-cdn.deployads.com/a/basketballinsiders.com.js" async ></script>
<script>(deployads = window.deployads || []).push({});</script>
<br><br>														</div><!--mvp-post-bot-ad-->
																																								<div id="mvp-related-posts" class="left relative">

															<h4 class="mvp-widget-home-title">
																<span class="mvp-widget-home-title">You may like</span>
															</h4>
																			<ul class="mvp-related-posts-list left related">
            								<a href="http://www.basketballinsiders.com/nba-am-the-play-in-game-west/" rel="bookmark">
            			<li>
							                				<div class="mvp-related-img left relative">
									<img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Stephen_Curry_Draymond_Green_Warriors_2019_AP-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Stephen_Curry_Draymond_Green_Warriors_2019_AP-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Stephen_Curry_Draymond_Green_Warriors_2019_AP-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Stephen_Curry_Draymond_Green_Warriors_2019_AP-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Stephen_Curry_Draymond_Green_Warriors_2019_AP-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Stephen_Curry_Draymond_Green_Warriors_2019_AP.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" />									<img width="80" height="80" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Stephen_Curry_Draymond_Green_Warriors_2019_AP-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Stephen_Curry_Draymond_Green_Warriors_2019_AP-80x80.jpg 80w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Stephen_Curry_Draymond_Green_Warriors_2019_AP-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																	</div><!--mvp-related-img-->
														<div class="mvp-related-text left relative">
								<p>NBA AM: The Play-In Game &#8211; West</p>
							</div><!--mvp-related-text-->
            			</li>
						</a>
            								<a href="http://www.basketballinsiders.com/nba-rookie-of-the-year-watch-april-16/" rel="bookmark">
            			<li>
							                				<div class="mvp-related-img left relative">
									<img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/11/Anthony_Edwards_Georgia_2020_Icon-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/11/Anthony_Edwards_Georgia_2020_Icon-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/11/Anthony_Edwards_Georgia_2020_Icon-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/11/Anthony_Edwards_Georgia_2020_Icon-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/11/Anthony_Edwards_Georgia_2020_Icon.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/11/Anthony_Edwards_Georgia_2020_Icon-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" />									<img width="80" height="80" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/11/Anthony_Edwards_Georgia_2020_Icon-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/11/Anthony_Edwards_Georgia_2020_Icon-80x80.jpg 80w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/11/Anthony_Edwards_Georgia_2020_Icon-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																	</div><!--mvp-related-img-->
														<div class="mvp-related-text left relative">
								<p>NBA Rookie of the Year Watch &#8211; April 16</p>
							</div><!--mvp-related-text-->
            			</li>
						</a>
            								<a href="http://www.basketballinsiders.com/nba-rookie-of-the-year-watch-april-1/" rel="bookmark">
            			<li>
							                				<div class="mvp-related-img left relative">
									<img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/11/Saddiq_Bey_Villanova_2020_Icon-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/11/Saddiq_Bey_Villanova_2020_Icon-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/11/Saddiq_Bey_Villanova_2020_Icon-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/11/Saddiq_Bey_Villanova_2020_Icon-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/11/Saddiq_Bey_Villanova_2020_Icon.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/11/Saddiq_Bey_Villanova_2020_Icon-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" />									<img width="80" height="80" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/11/Saddiq_Bey_Villanova_2020_Icon-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/11/Saddiq_Bey_Villanova_2020_Icon-80x80.jpg 80w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/11/Saddiq_Bey_Villanova_2020_Icon-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																	</div><!--mvp-related-img-->
														<div class="mvp-related-text left relative">
								<p>NBA Rookie of the Year Watch &#8211; April 2</p>
							</div><!--mvp-related-text-->
            			</li>
						</a>
            		</ul>															
														</div><!--mvp-related-posts-->
																																																																						<div id="mvp-comments-button" class="left relative mvp-com-click">
																<span class="mvp-comment-but-text">1 Comment</span>
															</div><!--mvp-comments-button-->
															<div id="comments">
				<h4 class="mvp-widget-home-title"><span class="mvp-widget-home-title">
			1 Comment		</span></h4>
		<ol class="commentlist">
			<li class="post pingback">
		<p>Pingback: <a href='https://sublimatedsportsuniforms.net/basketball/now-what-sacramento-kings/' rel='external nofollow ugc' class='url'>Now What? Sacramento Kings &#8211; sublimatedsportsuniforms.net</a></p>
	</li><!-- #comment-## -->
	</ol>
			
	
	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><h4 class="mvp-widget-home-title"><span class="mvp-widget-home-title">Leave a Reply</span></h4> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/now-what-sacramento-kings/#respond" style="display:none;">Cancel reply</a></small></h3><form action="http://www.basketballinsiders.com/wp-comments-post.php?wpe-comment-post=insiderssports" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='67418' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="348480501f" /></p><input type="hidden" id="ak_js" name="ak_js" value="46"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	
</div><!--comments-->																																							</div><!--mvp-cont-read-wrap-->
											</div><!--mvp-content-body-->
										</div><!--mvp-post-soc-in-->
									</div><!--mvp-post-soc-out-->
								</div><!--mvp-content-wrap-->
													<div id="mvp-post-add-box">
								<div id="mvp-post-add-wrap" class="left relative">
																			<div class="mvp-post-add-story left relative">
											<div class="mvp-post-add-head left relative">
												<h3 class="mvp-post-cat left relative"><a class="mvp-post-cat-link" href="http://www.basketballinsiders.com/category/nba-news/"><span class="mvp-post-cat left">NBA</span></a></h3>
												<h1 class="mvp-post-title left">NBA Daily: Depth Fueling Washington&#8217;s Turnaround</h1>
																									<span class="mvp-post-excerpt left"><p>After a miserable start to the season, the Washington Wizards have won 12 of their last 14 and are close to a play-in berth. Tristan Tucker takes an in-depth look at two factors that are pushing the team over the edge.</p>
</span>
																																					<div class="mvp-author-info-wrap left relative">
														<div class="mvp-author-info-thumb left relative">
															<img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2014/07/BI_Ball_Small-80x80.jpg" width="46" height="46" alt="Tristan Tucker" class="avatar avatar-46 wp-user-avatar wp-user-avatar-46 alignnone photo" />														</div><!--mvp-author-info-thumb-->
														<div class="mvp-author-info-text left relative">
															<div class="mvp-author-info-date left relative">
																<p>Published</p> <span class="mvp-post-date">1 day ago</span> <p>on</p> <span class="mvp-post-date">May 1, 2021</span>
															</div><!--mvp-author-info-date-->
															<div class="mvp-author-info-name left relative">
																<p>By</p> <span class="author-name"><a href="http://www.basketballinsiders.com/author/ttucker/" title="Posts by Tristan Tucker" rel="author">Tristan Tucker</a></span> <a href="https://twitter.com/TristanRTucker" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a>
															</div><!--mvp-author-info-name-->
														</div><!--mvp-author-info-text-->
													</div><!--mvp-author-info-wrap-->
																							</div><!--mvp-post-add-head-->
											<div class="mvp-post-add-body left relative">
																																							<div class="mvp-post-add-img left relative">
															<img width="1000" height="600" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/Russell_Westbrook_Wizards_2021.jpg" class="attachment- size- wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/Russell_Westbrook_Wizards_2021.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/Russell_Westbrook_Wizards_2021-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/Russell_Westbrook_Wizards_2021-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/Russell_Westbrook_Wizards_2021-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/Russell_Westbrook_Wizards_2021-400x240.jpg 400w" sizes="(max-width: 1000px) 100vw, 1000px" />														</div><!--mvp-post-feat-img-->
																																																			<div class="mvp-post-add-cont left relative">
													<div class="mvp-post-add-main right relative">
														<p><!-- BEGIN THEIA POST SLIDER --></p>
<p><span style="font-weight: 400;">Since starting the season at a miserable 17-32 mark, the Washington Wizards have won </span><a href="https://www.basketball-reference.com/teams/WAS/2021_games.html"><span style="font-weight: 400;">12 of their last 14 games</span></a><span style="font-weight: 400;">. The unlikely run gave the team a shot at the postseason that would’ve seemed laughable just mere weeks ago.</span></p>
<p><span style="font-weight: 400;">Now, the team is on the verge of making the </span><a href="http://www.basketballinsiders.com/nba-daily-the-play-in-game-east/"><span style="font-weight: 400;">play-in tournament</span></a><span style="font-weight: 400;">. Let’s take a look at two key factors for the team and what has sparked Washington’s turnaround.</span></p>
<h3><b>Russell Westbrook and Bradley Beal Clicking</b></h3>
<p><span style="font-weight: 400;">The Wizards traded former franchise icon John Wall to the Houston Rockets on </span><a href="https://northernvirginiamag.com/culture/news/2020/12/09/washington-wizards-acquire-russell-westbrook-in-trade/#:~:text=The%20Washington%20Wizards%20started%20December,Westbrook%20from%20the%20Houston%20Rockets."><span style="font-weight: 400;">Dec. 2, 2020</span></a><span style="font-weight: 400;">. The 2020-21 NBA season began on Dec. 22, 2020. It’s not hard to fathom why the backcourt of Russell Westbrook and Bradley Beal took a while to get back to their winning ways.</span></p>
<p><span style="font-weight: 400;">As they say, time heals all &#8212; and that’s certainly all it took for Westbrook and Beal.</span></p>
<p><span style="font-weight: 400;">“They don’t have that excuse bone that some players have,” said head coach Scott Brooks. “It’s easy to find it, there’s a lot. Travel, body hurts, ‘things I gotta deal with off the court,’ ‘I have a cold,’ ‘coach is not playing me,’ ‘I’m not getting shots. There are always excuses you can use but those two guys don’t use excuses. They lead. If you’re gonna have a chance to win back-to-backs [your two best players have to buy in].”</span></p>
<p><span style="font-weight: 400;">Westbrook was “only” averaging </span><a href="https://www.basketball-reference.com/players/w/westbru01/gamelog/2021"><span style="font-weight: 400;">21.8 points, 10.5 rebounds and 10.5 assists, though, his shooting numbers were poor at a 43.2/30.9/61.3</span></a><span style="font-weight: 400;"> split.</span></p>
<blockquote class="twitter-tweet">
<p dir="ltr" lang="en">Our 12-2 record since April 7 is the best record in the NBA during that stretch.<a href="https://twitter.com/hashtag/DCAboveAll?src=hash&amp;ref_src=twsrc%5Etfw">#DCAboveAll</a> <a href="https://t.co/olDcChnupv">pic.twitter.com/olDcChnupv</a></p>
<p>— Washington Wizards (@WashWizards) <a href="https://twitter.com/WashWizards/status/1388519419643584517?ref_src=twsrc%5Etfw">May 1, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p><span style="font-weight: 400;">However, </span><a href="https://www.basketball-reference.com/players/w/westbru01/gamelog/2021"><span style="font-weight: 400;">since April 7</span></a><span style="font-weight: 400;">, the former MVP is averaging more assists and boards on more efficient shooting. Whereas Westbrook was sporadically available to begin the year, Westbrook started all 14 of the team’s last games.</span></p>
<p><span style="font-weight: 400;">“I coached [Westbrook] in the shortened season,” Brooks said. “I don’t even know what year it was, we had like five games in seven nights. By the fifth night, we had three games in a row, I wasn’t even worried. I’ve said it many times, that young man is different in a way that I love.”</span></p>
<p><span style="font-weight: 400;">Furthermore, Westbrook has </span><a href="https://www.basketball-reference.com/players/w/westbru01/gamelog/2021"><span style="font-weight: 400;">27 consecutive double-doubles, which is the longest streak of his career</span></a><span style="font-weight: 400;">. Westbrook is at 177 career triple-doubles after the team’s victory over the Cleveland Cavaliers, putting him </span><a href="https://www.basketball-reference.com/leaders/trp_dbl_career.html"><span style="font-weight: 400;">just four shy</span></a><span style="font-weight: 400;"> of tying Oscar Robertson for most in league history.</span></p>
<p><span style="font-weight: 400;">“When you’re in this position and you get mentioned with greats like Oscar [Robertson], they compliment things you do for the game, it’s truly an honor,” Westbrook said. “It’s something I don’t take for granted. </span></p>
<p><span style="font-weight: 400;">“[Robertson] is someone that did more for the game, played in the era where it was tough being an African-American athlete in our game and he sacrificed so many things to play the game. I understand that and to me, I’m just grateful to be in the conversation with my name connected to his.”</span></p>
<blockquote class="twitter-tweet">
<p dir="ltr" lang="en">Russell Westbrook has his 177th career triple-double tonight &#8230; after three quarters. Five more and he passes Oscar Robertson.</p>
<p>The Big O tells <a href="https://twitter.com/PeterVecsey1?ref_src=twsrc%5Etfw">@PeterVecsey1</a> here: &#8220;I think he will (pass me) and I&#8217;ll be glad when he does, because he&#8217;s a tremendous basketball player and athlete.&#8221; <a href="https://t.co/SM2c7GRj4K">https://t.co/SM2c7GRj4K</a></p>
<p>— Marc Stein (@TheSteinLine) <a href="https://twitter.com/TheSteinLine/status/1388306252141318147?ref_src=twsrc%5Etfw">May 1, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p><span style="font-weight: 400;">In his short time with the Wizards, Westbrook is already the </span><a href="https://www.basketball-reference.com/teams/WAS/leaders_career.html"><span style="font-weight: 400;">team’s all-time leader in triple-doubles</span></a><span style="font-weight: 400;">.</span></p>
<p><span style="font-weight: 400;">“It’s really awesome,” Brooks said. “I can’t even think of any other words other than it’s pretty cool to see him, what he does. How he leads us off the court, on the court, in the locker room, in the hotel, on the bus, he’s just been terrific for our organization. I cannot be more happy for him and his family. He’s earned this. I’m hoping that he does get it … I’m thrilled. … He’s that good.”</span></p>
<p><span style="font-weight: 400;">The two-man lineup of Westbrook and Beal isn’t the team’s best, </span><a href="https://www.nba.com/stats/lineups/advanced/?Season=2020-21&amp;SeasonType=Regular%20Season&amp;sort=MIN&amp;dir=1&amp;TeamID=1610612764&amp;GroupQuantity=2"><span style="font-weight: 400;">but it is the highest-rated of Washington’s six most-played two-man pairings</span></a><span style="font-weight: 400;">. </span></p>
<p><span style="font-weight: 400;">And as always, Beal is completely dominating the season. His </span><a href="https://www.nba.com/stats/leaders/"><span style="font-weight: 400;">31.3 points per game rank second in the NBA</span></a><span style="font-weight: 400;">. One underrated aspect of Beal’s game is how he’s getting to the line and the rate at which he’s connecting. </span><a href="https://www.basketball-reference.com/players/b/bealbr01.html"><span style="font-weight: 400;">Beal is averaging 7.5 free throw attempts per game, which ranks second-most in his career. He&#8217;s making the most of those chances, shooting a career-high 90.1 percent from the line</span></a><span style="font-weight: 400;">.</span></p>
<h3><b>Role Players Stepping Up</b></h3>
<p><span style="font-weight: 400;">While the team’s stars are playing stellar basketball, Washington has its role players to thank just as much for this spectacular run. Despite losing Thomas Bryant and Deni Avdija for the year, the Wizards still run deep.</span></p>
<p><span style="font-weight: 400;">Over the last 14 games, the Wizards’ bench is averaging 45.4 points per game, second-best in the league. That unit is also shooting a 54.8 percent clip from the floor, which ranks the best in the league.</span></p>
<p><span style="font-weight: 400;">Raul Neto, </span><a href="http://www.basketballinsiders.com/nba-daily-raul-neto-seizing-his-opportunity-in-washington/"><span style="font-weight: 400;">who Basketball Insiders talked to earlier this season</span></a><span style="font-weight: 400;">, is averaging career-high numbers across the board and has slid into a starting role with the team.</span></p>
<p><span style="font-weight: 400;">“Just his consistent scrappiness. [Neto] just scraps,” Brooks said. “He grinds and plays every possession with a pure heart and he just competes. … [Neto] does a great job of driving and kicking … he’s consistent, love the guy. His teammates love him. He competes every day. Same demeanor game in and game out.”</span></p>
<p><span style="font-weight: 400;">Neto is averaging 8.4 points and 1.1 steals while shooting 46.6 percent from the floor and 38.8 percent from three. Furthermore, Neto’s been a pest on defense to counter Westbrook and Beal’s scoring punch. </span><a href="https://www.basketball-reference.com/teams/WAS/2021.html"><span style="font-weight: 400;">Neto is one of just a few players with a positive defensive box plus/minus, something that’s easily noticeable by watching the team play</span></a><span style="font-weight: 400;">.</span></p>
<p><span style="font-weight: 400;">In fact, the Wizards are 11-5 when Neto scores more than 12 points this season.</span></p>
<p><span style="font-weight: 400;">“I think having everybody healthy and having consistency in that,” Neto said of what sparked the midseason turnaround. “Most of the games we’re having mostly everybody. We don’t have games where we have three or four guys out and it kills our rhythm. … And definitely [Westbrook] and [Beal]. They’re having an amazing stretch playing well every game and being huge for us. I think it shows that their leadership is important. Not only talking or doing what they do but playing well for us, it’s been huge for us.”</span></p>
<p><span style="font-weight: 400;">Another player that has been an unlikely marvel is Daniel Gafford. Gafford&#8217;s arrival alongside Chandler Hutchinson at the trade deadline helped spark the 12-2 run. After a disappointing stint with the Chicago Bulls, Gafford has been a surreal glue guy for the Wizards.</span></p>
<p><span style="font-weight: 400;">In the 14-game sample size, </span><a href="https://www.basketball-reference.com/teams/WAS/2021.html"><span style="font-weight: 400;">Gafford is averaging 10.8 points, 6.1 rebounds, 1.9 blocks and 0.8 steals per game in just over 18 minutes per night</span></a><span style="font-weight: 400;">. During this time, Gafford boasts a whopping plus-23 net rating </span><span style="font-weight: 400;">and a 104 defensive rating</span><span style="font-weight: 400;">, both best on the team.</span></p>
<p><span style="font-weight: 400;">Gafford’s 5.1 box plus/minus is the best on the team, ranking ahead of Beal’s 3.4 and Westbrook’s 2.2.</span></p>
<blockquote class="twitter-tweet">
<p dir="ltr" lang="en">Daniel Gafford dunked all over Kuzma 😤 <a title="" href="https://t.co/x8It8Agt9H">pic.twitter.com/x8It8Agt9H</a></p>
<p>— ESPN (@espn) <a href="https://twitter.com/espn/status/1387558868629266435?ref_src=twsrc%5Etfw">April 29, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p><span style="font-weight: 400;">While Gafford has undoubtedly helped shore up the Wizards’ frontcourt, Robin Lopez and Alex Len both deserve credit for holding down the fort without Bryant.</span></p>
<p><span style="font-weight: 400;">Len arrived midseason after a short stint with the Toronto Raptors. After his arrival, Len became a starter at the center position and is averaging 7.6 points per game on a highly efficient 63.4 percent clip. Len splits the time at that position with Lopez, who is having a bounce-back season on the same field-goal percentage as Len.</span></p>
<p><a href="https://www.basketball-reference.com/players/l/lopezro01/gamelog/2021"><span style="font-weight: 400;">During Washington’s hot streak, Lopez is connecting at a ridiculous 73 percent clip from the floor.</span></a></p>
<p><span style="font-weight: 400;">Even rookie Anthony Gill is getting in on the fun in the frontcourt, </span><a href="https://www.basketball-reference.com/players/g/gillan01/gamelog/2021"><span style="font-weight: 400;">averaging 9.3 points on 76.2 percent shooting in his last four games</span></a><span style="font-weight: 400;">, earning expanded playing time.</span></p>
<p><span style="font-weight: 400;">“[Gafford] came in and gave us good minutes, Ish Smith came in and gave us good minutes,” Brooks said. “It seems like this last month and a half we’ve been playing good and then an out of nowhere guy would surface in any given game. I have confidence in any guy, that’s why I always tell them to stay ready. Recently, it’s been [Gill]. He hasn’t played all year but he stayed ready and he’s stepped up, that’s what you want. They put a lot of work in.”</span></p>
<p><span style="font-weight: 400;">And of course, fans can’t forget Davis Bertans and Rui Hachimura, with Bertans shooting over 40 percent from deep at a high rate while Hachimura continues to grow in his age-22 season.</span></p>
<p><span style="font-weight: 400;">Even if the Wizards don’t make it far in the postseason, fans of the team have to feel good about the way the team responded in the wake of adversity. Losing Bryant and Avdija is not a small deal, and one can only wonder how different the Wizards would look if Beal and Westbrook had a full training camp to click.</span></p>
<p><span style="font-weight: 400;">With a first-round pick in tow and a full offseason ahead, the Wizards’ once-dim future might be brighter than many once thought.</span></p>
<p><span style="font-weight: 400;">“I think we have a good team,” Brooks said. “We got some good players, continuity as a group. We’ve had guys step up any given game, like tonight it was [Gill] who stepped up and gave us good minutes. </span></p>
<p><span style="font-weight: 400;">“We’re healthy. We have a good team. We’ve had a lot of stuff go on and I think the biggest thing is we stayed with it. We still have nine games to go and we’re going to play how we’ve played. Every game, every day is important. It seems like every night someone is stepping up.”</span></p>
<p><!-- END THEIA POST SLIDER --></p>
													</div><!--mvp-post-add-main-->
													<div class="mvp-post-add-link">
														<a href="http://www.basketballinsiders.com/nba-daily-depth-fueling-washingtons-turnaround/" rel="bookmark"><span class="mvp-post-add-link-but">Continue Reading</span></a>
													</div><!--mvp-post-add-link-->
												</div><!--mvp-post-add-cont-->
											</div><!--mvp-post-add-body-->
										</div><!--mvp-post-add-story-->
																			<div class="mvp-post-add-story left relative">
											<div class="mvp-post-add-head left relative">
												<h3 class="mvp-post-cat left relative"><a class="mvp-post-cat-link" href="http://www.basketballinsiders.com/category/nba-news/"><span class="mvp-post-cat left">NBA</span></a></h3>
												<h1 class="mvp-post-title left">Kevin Knox II Needs A Fresh Start</h1>
																																					<div class="mvp-author-info-wrap left relative">
														<div class="mvp-author-info-thumb left relative">
															<img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/05/Drew_Marseca_InsidersSM-80x80.jpg" width="46" height="46" alt="Drew Maresca" class="avatar avatar-46 wp-user-avatar wp-user-avatar-46 alignnone photo" />														</div><!--mvp-author-info-thumb-->
														<div class="mvp-author-info-text left relative">
															<div class="mvp-author-info-date left relative">
																<p>Published</p> <span class="mvp-post-date">2 days ago</span> <p>on</p> <span class="mvp-post-date">April 30, 2021</span>
															</div><!--mvp-author-info-date-->
															<div class="mvp-author-info-name left relative">
																<p>By</p> <span class="author-name"><a href="http://www.basketballinsiders.com/author/dmaresca/" title="Posts by Drew Maresca" rel="author">Drew Maresca</a></span> <a href="https://twitter.com/DrewMaresca" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a>
															</div><!--mvp-author-info-name-->
														</div><!--mvp-author-info-text-->
													</div><!--mvp-author-info-wrap-->
																							</div><!--mvp-post-add-head-->
											<div class="mvp-post-add-body left relative">
																																							<div class="mvp-post-add-img left relative">
															<img width="1000" height="600" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2018/10/Kevin_Knox_Knicks_2018_AP4.jpg" class="attachment- size- wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2018/10/Kevin_Knox_Knicks_2018_AP4.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2018/10/Kevin_Knox_Knicks_2018_AP4-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2018/10/Kevin_Knox_Knicks_2018_AP4-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2018/10/Kevin_Knox_Knicks_2018_AP4-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2018/10/Kevin_Knox_Knicks_2018_AP4-400x240.jpg 400w" sizes="(max-width: 1000px) 100vw, 1000px" />														</div><!--mvp-post-feat-img-->
																																																			<div class="mvp-post-add-cont left relative">
													<div class="mvp-post-add-main right relative">
														<p><!-- BEGIN THEIA POST SLIDER --></p>
<p>In the NBA Draft, late-lottery teams typically face tough decisions. The late lottery is usually home to teams with some – albeit not a whole lot – of talent. Ideally, teams in the late lottery are up-and-coming, allowing them to either draft based on need or take a chance on someone they can bring along slowly.</p>
<p>In 2018, the New York Knicks had the ninth pick in the draft. Due mostly to a talented draft class, there were still a few strong prospects in play when it was the Knicks turn to make a selection.</p>
<p>Prior to the 2018 draft, the Knicks had been closely linked to Mikal Bridges. There were also rumors about their interest in Miles Bridges. Michael Porter Jr. was looked at as a long shot to drop to ninth, but he, too, was available when the Knicks made their selection.</p>
<p>Ultimately, the Knicks went with a less established forward from Kentucky – Kevin Knox II. The Kentucky product initially looked the part, impressing in his first Summer League. Knox averaged 21.3 points and 6.5 rebounds per game. He was even named to the All-NBA Summer League First Team.</p>
<p>His first season was similarly impressive. As a 19-year-old role, Knox averaged 12.8 points and 4.5 rebounds in 28.8 minutes per game, scoring 20 or more points 11 times – including a career-high 31 points against the Philadelphia 76ers in January 2019. He shot 37% from the field – which definitely requires improvement – and 34.3% on three-point attempts.</p>
<p>But everything can’t be summed up by stats. Knox demonstrated a strong foundation. He proved to be a fluid athlete, even against NBA-level competition, and the form on his jump shot was clearly a strength.</p>
<p>Knox also had his work cut out for him – but initially, the areas of game requiring work seemed easy enough to improve—namely, strength, shooting and shot selection. Knox’s biggest need – from this writer’s perspective, anyway – was that he avoided contact at the rim, opting to rely on off balance floaters far too often. But that’s an easy fix involving strengthening and repetition.</p>
<p>Knox’s second go-round in Summer League was as impressive as his first. He averaged 16.8 points, 5.6 rebounds and 2 assists per game. He demonstrated a more complete game throughout Summer League play, and he looked more comfortable picking his spots, all the while helping to accommodate the new rookie, RJ Barrett.</p>
<p>But confidence is a fickly beast, especially for NBA players, and Knox’s confidence quickly took a hit in his Sophomore season. And it had little to do with him or his game.</p>
<p>Coaching is paramount to player confidence. A select few guys <em>really</em> <em>know</em> they belong, but most young players are only as good as their opportunities. In his rookie season, Knox had a player-advocate for a coach in David Fizdale. In the 21 games that Fizdale was still the Knicks’ coach in 2019-20, the Knicks struggled and Knox slumped a bit – averaging just 7.9 points, 3.0 rebounds and 1.2 assists in 20.2 minutes per game on 37.1% shooting and 35.9% on three-point attempts.</p>
<p>After Fizdale was let go, the Knicks promoted Mike Miller to interim head coach. Miller dealt with all of the same pressures as Fizdale, but he also had to struggle with the idea that his NBA future would be based squarely on the final 44 games of the season, a fact that likely motivated him to lean on his more proven players – Knox was not a part of that group.</p>
<p>Knox averaged only 5.8 points, 2.8 rebounds and 0.8 assists in 16.9 minutes per game under Miller, shooting 35.3% from the field and 30.6% on three-point attempts.</p>
<p>Knox has had a tough go-of-it as a professional so far. He’s had three coaches in three seasons. Coach Tom Thibodeau is by far the best of the bunch, and he’s had an incredibly positive effect on many of the younger Knicks – but Knox is simply not in his rotation. Once again, it’s not his fault; he’s plays the same position as All-Star Julius Randle, who is Thibodeau’s most beloved workhorse.</p>
<p>Knox is receiving just 11.6 minutes per game in 2020-21, in which he’s posting 4.1 points, 1.6 rebounds and 0.5 assists. His shooting is improved – 39.9% from the field and 39.1% on three-point attempts – but he’s too far down the bench for it to matter. He’s scored in double-figured just three times this season, and he’s received 25 DNP-CDs through 63 games.</p>
<p>New York is a tough place to play, especially for kids who aren’t brimming with confidence. Somehow Knox is still only 21-years-old, so he could very realistically make his mark yet – after all, most teams would trip over themselves to grab a young 6’7” shooter with a good first step. But it’s unlikely to happen in the Big Apple &#8212; which is unfortunate because he has <em>all</em> of the tools.</p>
<p>But switching gears, imagine if the Knicks had taken any of the other guys they were linked to prior to the 2018 NBA Draft? Porter Jr. Mikal Bridges. Miles Bridges. All three have made their mark on the league, and all three would add tangible skills that would benefit the Knicks. It’s hard to imagine any of those three failing to develop into what they’ve become.</p>
<p>This past Monday, Mikal Bridges came to the Garden and gave them an up-close look at what they passed up. Bridges scored 21 points on three-for-six shooting from three-point range in a eight-point Phoenix victory. That game snapped a nine-game win streak for the Knicks.</p>
<p>Examining past drafts picks is an exercise in futility. Players develop partially because of their teammates, coaches and training staffs. You can’t just grab a player’s stats three years into his career and drop him on a roster that developed partially due to the ramifications of the picks they made since.</p>
<p>But it’s pretty clear that any of the other three prospects to whom the Knicks were linked would have produced more for a team currently  in need of offensive fire power.</p>
<p>As for Knox, his inability to secure a consistent role under Thibodeau and the crowding at his position mean it&#8217;s it’s unlikely that a role materializes for him in the near future. A fresh start elsewhere is probably best. It’s not his fault. It&#8217;s just the way it is.</p>
<p><!-- END THEIA POST SLIDER --></p>
													</div><!--mvp-post-add-main-->
													<div class="mvp-post-add-link">
														<a href="http://www.basketballinsiders.com/kevin-knox-ii-needs-a-fresh-start/" rel="bookmark"><span class="mvp-post-add-link-but">Continue Reading</span></a>
													</div><!--mvp-post-add-link-->
												</div><!--mvp-post-add-cont-->
											</div><!--mvp-post-add-body-->
										</div><!--mvp-post-add-story-->
																			<div class="mvp-post-add-story left relative">
											<div class="mvp-post-add-head left relative">
												<h3 class="mvp-post-cat left relative"><a class="mvp-post-cat-link" href="http://www.basketballinsiders.com/category/nba-news/"><span class="mvp-post-cat left">NBA</span></a></h3>
												<h1 class="mvp-post-title left">NBA AM: Now What? &#8211; Oklahoma City Thunder</h1>
																									<span class="mvp-post-excerpt left"><p>Matt John continues Basketball Insiders&#8217; Now What series by diving into the Oklahoma City Thunder.</p>
</span>
																																					<div class="mvp-author-info-wrap left relative">
														<div class="mvp-author-info-thumb left relative">
															<img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2018/03/Matt_John_Small-80x80.jpg" width="46" height="46" alt="Matt John" class="avatar avatar-46 wp-user-avatar wp-user-avatar-46 alignnone photo" />														</div><!--mvp-author-info-thumb-->
														<div class="mvp-author-info-text left relative">
															<div class="mvp-author-info-date left relative">
																<p>Published</p> <span class="mvp-post-date">2 days ago</span> <p>on</p> <span class="mvp-post-date">April 30, 2021</span>
															</div><!--mvp-author-info-date-->
															<div class="mvp-author-info-name left relative">
																<p>By</p> <span class="author-name"><a href="http://www.basketballinsiders.com/author/mjohn/" title="Posts by Matt John" rel="author">Matt John</a></span> <a href="https://twitter.com/MattJohnNBA" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a>
															</div><!--mvp-author-info-name-->
														</div><!--mvp-author-info-text-->
													</div><!--mvp-author-info-wrap-->
																							</div><!--mvp-post-add-head-->
											<div class="mvp-post-add-body left relative">
																																							<div class="mvp-post-add-img left relative">
															<img width="1000" height="600" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Shai_Gilgeous_Alexander_Thunder_2019_AP1.jpg" class="attachment- size- wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Shai_Gilgeous_Alexander_Thunder_2019_AP1.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Shai_Gilgeous_Alexander_Thunder_2019_AP1-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Shai_Gilgeous_Alexander_Thunder_2019_AP1-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Shai_Gilgeous_Alexander_Thunder_2019_AP1-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Shai_Gilgeous_Alexander_Thunder_2019_AP1-400x240.jpg 400w" sizes="(max-width: 1000px) 100vw, 1000px" />														</div><!--mvp-post-feat-img-->
																																																			<div class="mvp-post-add-cont left relative">
													<div class="mvp-post-add-main right relative">
														<p><!-- BEGIN THEIA POST SLIDER --></p>
<p>Welcome back to another edition of Basketball Insiders’ <em>Now What?</em> Series. Today, we’re focusing on the once-revered-now-rebuilding Oklahoma City Thunder. The Thunder have lost twice the amount of games that they won this season, which is pretty much right where we expected them to be. In spite of their immediate prospects as a team not looking good for the next couple of years, there may not be a young team whose future is brighter than OKC.</p>
<p>They already have the face of the franchise in the works. They have a few other intriguing young assets. They have barrels of first-round picks to use. Their record of 21-42 won’t impress anyone, but what’s there not like about where the Thunder are headed?</p>
<p><strong>Strengths</strong></p>
<p>You can’t spell strength without S-G-A!</p>
<p>Okay, yes you can, but the point is, OKC already had its new face of the franchise before their rebuild even started when they traded for Shai Gilgeous-Alexander. Not many players can say that they averaged almost 24 points on 51/42/80 splits, but Gilgeous-Alexander can! Adding the 5.9 assists and 4.7 rebounds a game, and you’ve got a young superstar in the making! Oh and as an added bonus, Shai’s got some nice tutelage from Chris Paul last year and some gritty playoff experience from the last two postseasons, so when the Thunder start taking off, their new face of the franchise has got a good idea of what to expect in a playoff atmosphere.</p>
<p><iframe loading="lazy" title="Shai Gilgeous-Alexander drops career-high 42 points vs. Spurs [FULL GAME HIGHLIGHTS] | NBA on ESPN" width="740" height="416" src="https://www.youtube.com/embed/sYQhQLAfZX4?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
<p>He’s not the only bright spot in OKC. There is also Lu Dort. He’s followed up with a modest improvement in an increased role in Oklahoma City after a pretty solid performance in the bubble. 14.2 points a game is a pretty solid jump from 6.8, even if his shooting splits are not-so-modest at 40/35/75. Upon further review, Dort’s April numbers show that he might just have another gear or two to his game. 25.7 points and 5.7 rebounds with 47/46/72 splits in a seven-game span can make one wonder. Considering he hung 42 on the Utah Jazz, the winningest team in the NBA fighting tooth and nail to get homecourt advantage, Dort might be in the running for Most Improved Player next season.</p>
<p><iframe loading="lazy" title="Luguentz Dort Career Night 42 Points Full Highlights vs Jazz | April 13, 2021" width="740" height="416" src="https://www.youtube.com/embed/i7Fmb4wLlPA?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
<p>Of course, there are other youthful prospects, like Moses Brown, Darius Bazley, and Keinrich Williams. They deserve a shout-out, but Gilgeous-Alexander and Dort. Those guys should be on OKC’s next playoff team.</p>
<p><strong>Weaknesses</strong></p>
<p>When teams are rebuilding, it’s their full intention to be weak. That’s why it’s a little difficult to point out weaknesses in a team that doesn’t have much strength, to begin with. But can there be weaknesses in their rebuild? Let’s find out.</p>
<p>In spite of being one of the worst teams in the league, the Thunder can sleep well at night knowing that their future is in good hands. Sure their roster is weak, but they knew that all too well when they tore it all down in the offseason. It’s a small price to pay for what should be a great future ahead. They could not have played this any better. There is one loose end &#8211; Al Horford.</p>
<p>There’s no enjoyment in ragging on Horford because he’s had a nice bounceback year following the outright disaster he was in Philadelphia. By all indications, he still has enough left in the tank that by all accounts, he should be on a team that’s trying to win. It’s just that, nobody is going to want to pay almost $42 million (should he be waived in 2022) for a big approaching his mid-30s. The only way to trade someone like that is for a worse contract or if you&#8217;re planning on attaching assets to get him out.</p>
<p>The Thunder have publically declared their intentions of trading Horford this summer. Realistically, their options are either to wait out the contract until they can waive it, or waive it now and stretch the cap hit.</p>
<p><strong>Opportunities</strong></p>
<p>This section is probably what’s brought up the most by viewers who know anything about the Thunder these days. If there’s one thing OKC is knee-deep in, it’s opportunities. They own 17 first-round picks from now until 2026. Thanks to Russell Westbrook and Paul George, the Thunder have unprotected first-rounders that could be golden not too long from now or at could draw a disgruntled superstar in a trade. Other rebuilding teams would kill to be in a situation like that.</p>
<p>But there’s also something else they have on their hands. Shai Gilgeous-Alexander and Lu Dort have deserved every last bit of praise thrown their way, but the one prospect that’s made everyone a bit curious is one Aleksej Pokusevski. Poku’s traditional stats won’t jump out at you in the slightest, but his slender frame, passing vision, and shooting stroke make him an unorthodoxly exciting prospect.</p>
<p><iframe loading="lazy" title="Aleksej Pokusevski 25 pts 7 threes 4 asts vs Hornets 20/21 season" width="740" height="416" src="https://www.youtube.com/embed/6j6XEaAppTo?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
<p>There may not be a player rawer in the league than Poku right now. For all we know, he could be a Giannis-type prospect or he could be another Perry Jones III. Either way, the tantalizing potential with Poku could very well be the deciding factor in if this new era of Thunder basketball being ushered in will be more fruitful in the playoffs than the last.</p>
<p><strong>Threats</strong></p>
<p>So, about those first-round picks. It’s never a bad idea to accumulate assets when you’re rebuilding. You just have to make sure you don’t go too overboard because one way or another, those assets are turning into players. This was a conundrum that Boston went through not too long ago. In the 2016 NBA Draft, the Celtics had eight picks. Five years later, the only one that has remained with the team is Jaylen Brown. Everyone else was traded away or waived in a couple of years. In other words, the assets were wasted.</p>
<p>OKC hopefully will do everything they can to not back themselves into a similar corner, but those 17 first-round picks over these next six years are going to be 17 human bodies one way or the other. The Thunder will have to choose carefully what they’re going to do with them. Luckily, Oklahoma City has all the time in the world to think up their next move, but this is something that they cannot brush to the side.</p>
<p>It’s saddening knowing that the Thunder had a decade-long window on their hands in the 2010s and only managed to get to the finals once. But, instead of moping around thinking about what could have been, they’ve been heads-on in their rebuilding approach. They now have the privilege of simply developing a fun and energetic product before it turns into something more meaningful.</p>
<p>But at some point or another, they’ll need to remember that they can’t go through a deja vu.</p>
<p><!-- END THEIA POST SLIDER --></p>
													</div><!--mvp-post-add-main-->
													<div class="mvp-post-add-link">
														<a href="http://www.basketballinsiders.com/nba-am-now-what-oklahoma-city-thunder/" rel="bookmark"><span class="mvp-post-add-link-but">Continue Reading</span></a>
													</div><!--mvp-post-add-link-->
												</div><!--mvp-post-add-cont-->
											</div><!--mvp-post-add-body-->
										</div><!--mvp-post-add-story-->
																	</div><!--mvp-post-add-wrap-->
							</div><!--mvp-post-add-box-->
													</div><!--mvp-post-content-->
						</div><!--mvp-post-main-in-->
													<div id="mvp-side-wrap" class="left relative">
						<section id="mvp_ad_widget-17" class="mvp-side-widget mvp_ad_widget">			<div class="mvp-widget-ad left relative">
				<span class="mvp-ad-label">Advertisement</span>
				<!-- BasketballInsiders_300x250_ROS_ATF (responsive) -->
<div class="ad-tag" data-ad-name="BasketballInsiders_300x250_ROS_ATF" data-ad-size="auto" ></div>
<script src="//tags-cdn.deployads.com/a/basketballinsiders.com.js" async ></script>
<script>(deployads = window.deployads || []).push({});</script>			</div><!--mvp-widget-ad-->
		</section><section id="mvp_ad_widget-23" class="mvp-side-widget mvp_ad_widget">			<div class="mvp-widget-ad left relative">
				<span class="mvp-ad-label">Advertisement</span>
				<!-- Zig Zag Expires 6/19/2021 -->
<p><a title="ZigZagSport - Best Online Sportsbook & Casino" href="https://zigzagsport.com/%20" target="_blank" rel="noopener"><img src="http://www.basketballinsiders.com/ads/ZigZagSport_300x250fl_500usd.gif" alt="ZigZagSport - Best Online Sportsbook & Casino" /></a></p>
<!-- Zig Zag Ends 6/19/2021 -->			</div><!--mvp-widget-ad-->
		</section><section id="mvp_ad_widget-21" class="mvp-side-widget mvp_ad_widget">			<div class="mvp-widget-ad left relative">
				<span class="mvp-ad-label">Advertisement</span>
				<!-- NJ Ads expires 11/27/2020 -->
<center><a href="https://www.americancasinoguide.com/" title="American Casino Guide" target="_blank">
<img border="0" src="http://basketballinsiders.com/ads/american-casino-guide-logo_200x140.jpg" alt="American Casino Guide"></a>
</center>
<center><a href="https://www.njcasino.com/" title="NJ Casino" target="_blank">
<img border="0" src="http://basketballinsiders.com/ads/nj-casino_225x150.png" alt="NJ Casino"></a>
</center>
<center><a href="https://www.betnj.com/" title="NJ Casino" target="_blank">
<img border="0" src="http://basketballinsiders.com/ads/bet-nj-logo_200x140.jpg" alt="NJ Casino"></a>
</center>
<!-- NJ Ads end-->
</br>
			</div><!--mvp-widget-ad-->
		</section><section id="text-45" class="mvp-side-widget widget_text"><div class="mvp-widget-home-head"><h4 class="mvp-widget-home-title"><span class="mvp-widget-home-title">NBA Team Salaries</span></h4></div>			<div class="textwidget"><div style=" float: left; width: 100%; height: 370px;">
<div style="text-align: center">
<table style="border: none;  width: 100%;" cellspacing="0" cellpadding="0">
<tr>
<td> <a href="http://www.basketballinsiders.com/atlanta-hawks-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_01.png" alt="Atlanta Hawks" ></a></td>
<td> <a href="http://www.basketballinsiders.com/boston-celtics-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_02.png" alt="Boston Celtics" ></a></td>
<td> <a href="http://www.basketballinsiders.com/brooklyn-nets-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_18.png" alt="Brooklyn Nets" ></a></td>
<td> <a href="http://www.basketballinsiders.com/charlotte-hornets-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_03.png" alt="Charlotte Hornets" ></a></td>
<td> <a href="http://www.basketballinsiders.com/chicago-bulls-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_04.png" alt="Chicago Bulls" ></a></td>
</tr>
<tr>
<td> <a href="http://www.basketballinsiders.com/cleveland-cavaliers-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_05.png" alt="Cleveland Cavaliers" ></a></td>
<td> <a href="http://www.basketballinsiders.com/dallas-mavericks-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_06.png" alt="Dallas Mavericks" ></a></td>
<td> <a href="http://www.basketballinsiders.com/denver-nuggets-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_07.png" alt="Denver Nuggets" ></a></td>
<td> <a href="http://www.basketballinsiders.com/detroit-pistons-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_08.png" alt="Detroit Pistons" ></a></td>
<td> <a href="http://www.basketballinsiders.com/golden-state-warriors-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_09.png" alt="Golden State Warriors" ></a></td>
</tr>
<tr>
<td> <a href="http://www.basketballinsiders.com/houston-rockets-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_10.png" alt="Houston Rockets" ></a></td>
<td> <a href="http://www.basketballinsiders.com/indiana-pacers-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_11.png" alt="Indiana Pacers" ></a></td>
<td> <a href="http://www.basketballinsiders.com/los-angeles-clippers-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_12.png" alt="Los Angeles Clippers" ></a></td>
<td> <a href="http://www.basketballinsiders.com/los-angeles-lakers-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_13.png" alt="Los Angeles Lakers" ></a></td>
<td> <a href="http://www.basketballinsiders.com/memphis-grizzlies-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_14.png" alt="Memphis Grizzlies" ></a></td>
</tr>
<tr>
<td> <a href="http://www.basketballinsiders.com/miami-heat-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_15.png" alt="Miami Heat" ></a></td>
<td> <a href="http://www.basketballinsiders.com/milwaukee-bucks-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_16.png" alt="Milwaukee Bucks" ></a></td>
<td> <a href="http://www.basketballinsiders.com/minnesota-timberwolves-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_17.png" alt="Minnesota Timberwolves" ></a></td>
<td> <a href="http://www.basketballinsiders.com/new-orleans-pelicans-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_19a.png" alt="New Orleans Pelicans" ></a></td>
<td> <a href="http://www.basketballinsiders.com/new-york-knicks-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_20.png" alt="New York Knicks" ></a></td>
</tr>
<tr>
<td> <a href="http://www.basketballinsiders.com/oklahoma-city-thunder-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_21.png" alt="Oklahoma City Thunder" ></a></td>
<td> <a href="http://www.basketballinsiders.com/orlando-magic-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_22.png" alt="Orlando Magic" ></a></td>
<td> <a href="http://www.basketballinsiders.com/philadelphia-76ers-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_23.png" alt="Philidelphia 76ers" ></a></td>
<td> <a href="http://www.basketballinsiders.com/phoenix-suns-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_24.png" alt="Phoenix Suns" ></a></td>
<td> <a href="http://www.basketballinsiders.com/portland-trail-blazers-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_25.png" alt="Portland Trail Blazers" ></a></td>
</tr>
<tr>
<td> <a href="http://www.basketballinsiders.com/sacramento-kings-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_26.png" alt="Sacramento Kings" ></a></td>
<td> <a href="http://www.basketballinsiders.com/san-antonio-spurs-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_27.png" alt="San Antonio Spurs" ></a></td>
<td> <a href="http://www.basketballinsiders.com/toronto-raptors-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_29.png" alt="Toronto Raptors" ></a></td>
<td> <a href="http://www.basketballinsiders.com/utah-jazz-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_31.png" alt="Utah Jazz" ></a></td>
<td> <a href="http://www.basketballinsiders.com/washington-wizards-team-salary" target="_blank" rel="noopener"> <img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/images/logos/NBA_Logos_32.png" alt="Washington Wizards" ></a></td>
</tr>
</table>
</div>
</div>
</div>
		</section><section id="mvp_ad_widget-18" class="mvp-side-widget mvp_ad_widget">			<div class="mvp-widget-ad left relative">
				<span class="mvp-ad-label">Advertisement</span>
				<!-- BetNow Expires 10/16/2021 -->
<p><a title="Bet on NBA at BetNow Sportsbook" href="https://www.betnow.eu/" target="_blank" rel="noopener"><img src="http://www.basketballinsiders.com/ads/BetNow300x250.gif" alt="Bet on NBA at BetNow Sportsbook" /></a></p>
<!-- BetNow Ends 10/16/2021 --> 			</div><!--mvp-widget-ad-->
		</section><section id="custom_html-6" class="widget_text mvp-side-widget widget_custom_html"><div class="mvp-widget-home-head"><h4 class="mvp-widget-home-title"><span class="mvp-widget-home-title">CloseUp360</span></h4></div><div class="textwidget custom-html-widget"><div class="feedgrabbr_widget" id="fgid_19cbac95836de6d19da621a29"></div>
<script>if (typeof (fg_widgets) === "undefined") fg_widgets = new Array(); fg_widgets.push("fgid_19cbac95836de6d19da621a29");</script>
<script async src="https://www.feedgrabbr.com/widget/fgwidget.js"></script> 

</div></section><section id="custom_html-4" class="widget_text mvp-side-widget widget_custom_html"><div class="mvp-widget-home-head"><h4 class="mvp-widget-home-title"><span class="mvp-widget-home-title">Insiders On Twitter</span></h4></div><div class="textwidget custom-html-widget"><a class="twitter-timeline" data-height="450" href="https://twitter.com/stevekylerNBA/lists/our-team?ref_src=twsrc%5Etfw" data-chrome="noheader nofooter noborder"></a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></div></section><section id="custom_html-5" class="widget_text mvp-side-widget widget_custom_html"><div class="mvp-widget-home-head"><h4 class="mvp-widget-home-title"><span class="mvp-widget-home-title">NBA On Twitter</span></h4></div><div class="textwidget custom-html-widget"><a class="twitter-timeline" data-width="300" data-height="700" href="https://twitter.com/stevekylerNBA/lists/nba-news-2?ref_src=twsrc%5Etfw" data-chrome="noheader nofooter noborder"></a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></div></section>			</div><!--mvp-side-wrap-->											</div><!--mvp-post-main-out-->
				</div><!--mvp-post-main-->
							<div id="mvp-post-more-wrap" class="left relative">
					<h4 class="mvp-widget-home-title">
						<span class="mvp-widget-home-title">Trending Now</span>
					</h4>
					<ul class="mvp-post-more-list left relative">
													<a href="http://www.basketballinsiders.com/nba-daily-examining-the-los-angeles-lakers-path-back-to-the-finals/" rel="bookmark">
							<li>
																	<div class="mvp-post-more-img left relative">
										<img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/LeBron_James_Anthony_Davis_Finals_2020_1-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/LeBron_James_Anthony_Davis_Finals_2020_1-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/LeBron_James_Anthony_Davis_Finals_2020_1-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/LeBron_James_Anthony_Davis_Finals_2020_1-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/LeBron_James_Anthony_Davis_Finals_2020_1.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/LeBron_James_Anthony_Davis_Finals_2020_1-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" />										<img width="80" height="80" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/LeBron_James_Anthony_Davis_Finals_2020_1-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/LeBron_James_Anthony_Davis_Finals_2020_1-80x80.jpg 80w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2021/03/LeBron_James_Anthony_Davis_Finals_2020_1-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																			</div><!--mvp-post-more-img-->
																<div class="mvp-post-more-text left relative">
									<div class="mvp-cat-date-wrap left relative">
										<span class="mvp-cd-cat left relative">NBA</span><span class="mvp-cd-date left relative">2 weeks ago</span>
									</div><!--mvp-cat-date-wrap-->
									<p>NBA Daily: The Lakers&#8217; Path Back to the NBA Finals</p>
								</div><!--mvp-post-more-text-->
							</li>
							</a>
													<a href="http://www.basketballinsiders.com/nba-am-the-play-in-game-west/" rel="bookmark">
							<li>
																	<div class="mvp-post-more-img left relative">
										<img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Stephen_Curry_Draymond_Green_Warriors_2019_AP-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Stephen_Curry_Draymond_Green_Warriors_2019_AP-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Stephen_Curry_Draymond_Green_Warriors_2019_AP-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Stephen_Curry_Draymond_Green_Warriors_2019_AP-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Stephen_Curry_Draymond_Green_Warriors_2019_AP-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Stephen_Curry_Draymond_Green_Warriors_2019_AP.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" />										<img width="80" height="80" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Stephen_Curry_Draymond_Green_Warriors_2019_AP-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Stephen_Curry_Draymond_Green_Warriors_2019_AP-80x80.jpg 80w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2019/10/Stephen_Curry_Draymond_Green_Warriors_2019_AP-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																			</div><!--mvp-post-more-img-->
																<div class="mvp-post-more-text left relative">
									<div class="mvp-cat-date-wrap left relative">
										<span class="mvp-cd-cat left relative">NBA</span><span class="mvp-cd-date left relative">2 weeks ago</span>
									</div><!--mvp-cat-date-wrap-->
									<p>NBA AM: The Play-In Game &#8211; West</p>
								</div><!--mvp-post-more-text-->
							</li>
							</a>
													<a href="http://www.basketballinsiders.com/nba-daily-is-stephen-curry-the-mvp/" rel="bookmark">
							<li>
																	<div class="mvp-post-more-img left relative">
										<img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/12/Stephen_Curry_Warriors_2018_AP5-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/12/Stephen_Curry_Warriors_2018_AP5-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/12/Stephen_Curry_Warriors_2018_AP5-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/12/Stephen_Curry_Warriors_2018_AP5-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/12/Stephen_Curry_Warriors_2018_AP5-590x354.jpg 590w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/12/Stephen_Curry_Warriors_2018_AP5.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" />										<img width="80" height="80" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/12/Stephen_Curry_Warriors_2018_AP5-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/12/Stephen_Curry_Warriors_2018_AP5-80x80.jpg 80w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/12/Stephen_Curry_Warriors_2018_AP5-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																			</div><!--mvp-post-more-img-->
																<div class="mvp-post-more-text left relative">
									<div class="mvp-cat-date-wrap left relative">
										<span class="mvp-cd-cat left relative">NBA</span><span class="mvp-cd-date left relative">2 weeks ago</span>
									</div><!--mvp-cat-date-wrap-->
									<p>NBA Daily: Is Stephen Curry the MVP?</p>
								</div><!--mvp-post-more-text-->
							</li>
							</a>
													<a href="http://www.basketballinsiders.com/nba-daily-jonas-valanciunas-spearheading-grizzlies-growth/" rel="bookmark">
							<li>
																	<div class="mvp-post-more-img left relative">
										<img width="400" height="240" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Jonas_Valanciunas_Grizzlies_2020_AP_Post_Game-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Jonas_Valanciunas_Grizzlies_2020_AP_Post_Game-400x240.jpg 400w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Jonas_Valanciunas_Grizzlies_2020_AP_Post_Game-300x180.jpg 300w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Jonas_Valanciunas_Grizzlies_2020_AP_Post_Game-768x461.jpg 768w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Jonas_Valanciunas_Grizzlies_2020_AP_Post_Game.jpg 1000w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Jonas_Valanciunas_Grizzlies_2020_AP_Post_Game-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" />										<img width="80" height="80" src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Jonas_Valanciunas_Grizzlies_2020_AP_Post_Game-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Jonas_Valanciunas_Grizzlies_2020_AP_Post_Game-80x80.jpg 80w, http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2020/03/Jonas_Valanciunas_Grizzlies_2020_AP_Post_Game-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																			</div><!--mvp-post-more-img-->
																<div class="mvp-post-more-text left relative">
									<div class="mvp-cat-date-wrap left relative">
										<span class="mvp-cd-cat left relative">NBA</span><span class="mvp-cd-date left relative">1 week ago</span>
									</div><!--mvp-cat-date-wrap-->
									<p>NBA Daily: Jonas Valanciunas Spearheading Grizzlies&#8217; Growth</p>
								</div><!--mvp-post-more-text-->
							</li>
							</a>
											</ul>
				</div><!--mvp-post-more-wrap-->
						</div><!--mvp-main-box-->
		</div><!--mvp-article-cont-->
		</article><!--mvp-article-wrap-->
			</div><!--mvp-main-body-wrap-->
			<footer id="mvp-foot-wrap" class="left relative">
				<div id="mvp-foot-top" class="left relative">
					<div class="mvp-main-box">
						<div id="mvp-foot-logo" class="left relative">
															<a href="http://www.basketballinsiders.com/"><img src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/uploads/2017/08/LargeLogo_WithWhite300-1.png" alt="Basketball Insiders | NBA Rumors And Basketball News" data-rjs="2" /></a>
													</div><!--mvp-foot-logo-->
						<div id="mvp-foot-soc" class="left relative">
							<ul class="mvp-foot-soc-list left relative">
																	<li><a href="https://www.facebook.com/BasketballInsiders" target="_blank" class="fa fa-facebook fa-2"></a></li>
																									<li><a href="https://twitter.com/BBallInsiders" target="_blank" class="fa fa-twitter fa-2"></a></li>
																									<li><a href="http://www.pinterest.com/bballinsiders/" target="_blank" class="fa fa-pinterest-p fa-2"></a></li>
																									<li><a href="http://instagram.com/basketballinsiders" target="_blank" class="fa fa-instagram fa-2"></a></li>
																									<li><a href="https://plus.google.com/u/0/+Basketballinsiderscom/" target="_blank" class="fa fa-google-plus fa-2"></a></li>
																									<li><a href="https://www.youtube.com/user/BasketballInsiders" target="_blank" class="fa fa-youtube-play fa-2"></a></li>
																															</ul>
						</div><!--mvp-foot-soc-->
						<div id="mvp-foot-menu-wrap" class="left relative">
							<div id="mvp-foot-menu" class="left relative">
								<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-7340" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7340"><a href="http://www.basketballinsiders.com/the-latest-basketball-news/">NBA Trade Rumors</a></li>
<li id="menu-item-202" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-202"><a href="http://www.basketballinsiders.com/nbas-top-50-highest-paid-players/">NBA&#8217;s Top 50 Highest Paid Players</a></li>
<li id="menu-item-203" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-203"><a href="http://www.basketballinsiders.com/top-100-nba-draft-prospects/">Top 100 NBA Draft Prospects</a></li>
<li id="menu-item-199" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-199"><a href="http://www.basketballinsiders.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-200" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-200"><a href="http://www.basketballinsiders.com/terms-of-service/">Terms Of Service</a></li>
<li id="menu-item-201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-201"><a href="http://www.basketballinsiders.com/contact-us/">Contact Us</a></li>
</ul></div>							</div><!--mvp-foot-menu-->
						</div><!--mvp-foot-menu-wrap-->
					</div><!--mvp-main-box-->
				</div><!--mvp-foot-top-->
				<div id="mvp-foot-bot" class="left relative">
					<div class="mvp-main-box">
						<div id="mvp-foot-copy" class="left relative">
							<p>Copyright © 2018 Insiders Sports, Inc.</p>
						</div><!--mvp-foot-copy-->
					</div><!--mvp-main-box-->
				</div><!--mvp-foot-bot-->
			</footer>
		</div><!--mvp-site-main-->
	</div><!--mvp-site-wall-->
</div><!--mvp-site-->
<div class="mvp-fly-top back-to-top">
	<i class="fa fa-angle-up fa-3"></i>
</div><!--mvp-fly-top-->
<div class="mvp-fly-fade mvp-fly-but-click">
</div><!--mvp-fly-fade-->
<meta id="ba_s" property="options" content="" data-o="{&quot;tid&quot;:&quot;UA-46749583-1&quot;,&quot;co&quot;:&quot;auto&quot;,&quot;g&quot;:1074072168,&quot;s&quot;:6,&quot;a&quot;:0,&quot;d&quot;:{&quot;c&quot;:[3,&quot;NBA,NBA DAILY&quot;],&quot;a&quot;:[1,&quot;Chad Smith&quot;],&quot;t&quot;:[2,&quot;Main Page,Sacramento Kings&quot;]}}" /><script type="text/javascript">(function(w, d, s, id) {
  w.PUBX=w.PUBX || {pub: "basketball_insiders", discover: false, lazy: true};
  var js, pjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id; js.async = true;
  js.src = "//main.pubexchange.com/loader.min.js";
  pjs.parentNode.insertBefore(js, pjs);
}(window, document, "script", "pubexchange-jssdk"));</script><style type="text/css">

	
	
	#sab_wrap{
		margin:0 auto;
					width:100%;
								height:50;
								background:;
					position: fixed;
					bottom:0px;;
							
  		left: 0;
  		right: 0;
  		z-index: 99999;
	}
	#sab_bar_opn{
		margin:0 auto;
		position: fixed;
		background:#000;
		color: #fff;
		padding: 5px;
		display: none;
					bottom:0px;;
				
		cursor: pointer;
	}
	
	#sab_elem{
		float: left;
		width: 3%;
		text-align: center;
		padding-top: 7px;

	}
	#sab_content{
		width: 95%;
		float: right;
		display: inline-block;
		text-align: center;
		margin-right:2%;
	}
	#sab_text{
					color: ;
				
			
					font-size: px;
								
		/*font-family: ;*/
		font-weight: normal;
		font-style: normal;
		margin: 0;
		padding: 0;
	}
	#sab_close_btn{
		cursor: pointer;
	}

</style>



	
<style>
#mvp-side-wrap,.mvp-feat1-right-wrap,.mvp-post-soc-wrap,.mvp-flex-side-wrap
</style>
		<div data-theiaStickySidebar-sidebarSelector='"#mvp-side-wrap,.mvp-feat1-right-wrap,.mvp-post-soc-wrap,.mvp-flex-side-wrap"'
		     data-theiaStickySidebar-options='{"containerSelector":"","additionalMarginTop":120,"additionalMarginBottom":20,"updateSidebarHeight":false,"minWidth":1004,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
		<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/theia-sticky-sidebar/js/ResizeSensor.js?ver=1.7.0' id='theia-sticky-sidebar/ResizeSensor.js-js'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/theia-sticky-sidebar/js/theia-sticky-sidebar.js?ver=1.7.0' id='theia-sticky-sidebar/theia-sticky-sidebar.js-js'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/theia-sticky-sidebar/js/main.js?ver=1.7.0' id='theia-sticky-sidebar/main.js-js'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/themes/zox-news/js/mvpcustom.js?ver=5.7.1' id='mvp-custom-js'></script>
<script type='text/javascript' id='mvp-custom-js-after'>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</script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/themes/zox-news/js/scripts.js?ver=5.7.1' id='clickmag-js'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/themes/zox-news/js/retina.js?ver=5.7.1' id='retina-js'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/themes/zox-news/js/flexslider.js?ver=5.7.1' id='flexslider-js'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/themes/zox-news/js/jquery.infinitescroll.min.js?ver=5.7.1' id='infinitescroll-js'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-includes/js/comment-reply.js?ver=5.7.1' id='comment-reply-js'></script>
<script type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-includes/js/wp-embed.js?ver=5.7.1' id='wp-embed-js'></script>
<script async="async" type='text/javascript' src='http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.9' id='akismet-form-js'></script>

<!-- Begin comScore Tag -->
<script>document.write(unescape("%3Cscript src=\'" + (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js\' %3E%3C/script%3E"));</script>
<script>
  COMSCORE.beacon({
    c1:2,
    c2:6685975,
    c3:"",
    c4:"'.$_SERVER["SERVER_NAME"].$_SERVER["REQUEST_URI"].'",
    c5:"",
    c6:"",
    c15:""
  });
</script>
<noscript><img src="http://b.scorecardresearch.com/p?c1=2&c2=6685975&c3=&c4=&c5=&c6=&c15=&cj=1" /></noscript>
<!-- End comScore Tag -->

<!-- Start Alexa Certify Javascript -->
<script type="text/javascript">
_atrk_opts = { atrk_acct:"a0JVi1a8Dy00qI", domain:"footballinsiders.com",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://d31qbv1cthcecs.cloudfront.net/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=a0JVi1a8Dy00qI" style="display:none" height="1" width="1" alt="" /></noscript>
<!-- End Alexa Certify Javascript -->

<!-- Start Teads Javascript -->
<script type="text/javascript" class="teads" async="true" src="//a.teads.tv/page/69634/tag"></script>
<!-- End Teads Javascript -->
<link rel="stylesheet" href="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/themes/zox-news/css/nice-select.css">
<script src="http://o4526lc90g998y7561v9o735w5s.wpengine.netdna-cdn.com/wp-content/themes/zox-news/js/jquery.nice-select.js"></script>
<script lang="javascript" type="text/javascript">
    jQuery(document).ready(function() {
        jQuery('select').niceSelect();
      });
</script>
</body>
</html>